www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Multiplikation


Autor: Darko Sabljo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,
also ich zweifel grad an mir ;)
warscheinlich ist es auch nur irgendwie ein Flüchtikeitsfehler, aber
mal zur Erklärung.
Ich habe einen Wert, den im mit 10 Multiplizieren möchte. Mein
Controller ist ein 90S4433. Der ja nen Hardwaremultiplier hat wenn ich
mich nicht irre.
Also benutzte ich den befehl "mul"
hier mal mein Quellcode:

heiz_schalt_ein:

           ldi temp2,10
;temp wert zehner
           mov temp1,r22
           rcall BITSWAP
     mul temp1,temp2
     mov temp3,r0

;temp wert einer
           mov temp1,r23
           swap temp1
           rcall BITSWAP

           add temp3,temp1

so.. also ich will temp1 mit temp2 multiplizieren, und laut instruction
Set wird das Ergebnis in R0 und R1 gechrieben.
Nun hab ich das in den Controller geschrieben und es funzt nicht, dann
dacht ich mir, simulier es doch mal in AVRStudio 4 und da macht ers
auch nicht. Mach ich da irgendwie was falsch? Warscheinlich... sonst
würde es ja gehen :)
aber vielleicht könnte mir ja jemand einen Tip geben, wär euch sehr
dankbar!

Gruss
Darko

Autor: Darko Sabljo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi.. man ist das Peinlich!
Ich hab zwar im Instruction Set den Befehl gelesen, aber nun nochmal
die Datenblätter gechecked und gesehen das das wohl erst ab den Megas
implementiert ist. mist :)

naja..

trotzdem danke die sich vielleicht schon den kopf zerbrochen haben :)

Gruss
Darko

Autor: OliverK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Darko!

Dein Studio hätte aber beim Simulieren aber meckern müssen, daß dieser
Controller keine Multiplikation unterstützt!?


Grüße
Oliver

Autor: Frankl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Studio 4 ist noch Baustelle siehe auch www.avrfreaks.net <forum>
<studio4>

Autor: Darko Sabljo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Oliver,

ja, also das hätt ich eigentlich auch erwartet, oder das es zumindest
ne compilerwarnung gibt... aber leider nix :(
nun gut, hab die Multiplikation halt von Hand gelöst :)

@Frankl  leider stimmts wohl, das es absolut unausgereift ist :(

gruss Darko

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.