www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USART ATmega16, Probleme beim Empfang


Autor: Dilligent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, habe ja vor 1-2 Wochen schonmal geschrieben und habe mir in der 
Zwischenzeit ein STK500 mit zusätzlich ATmega16, Atmega32 und AVRDragon 
angeschafft. Auf dem Board vorinstalliert war der ATmega8515, der ja 
eigentlich auch ganz toll ist, nur leider keinen AD Wandler besitzt.

Mit dem ATmega8515 hab ich es geschafft eine recht stabile serielle 
Verbindung über UART zum PC herzustellen und könnte also auch wunderbar 
senden was ich wollte. Nun habe ich den ATmega16 installiert und soweit 
so gut, am Rechner kommen immer noch Daten an, diese sind jedoch nicht 
die die gesendet wurden.

Ich denke mal das es hier ein Taktproblem gibt, das die Baudrate falsch 
eingestellt ist. Nn hab ich schon einiges in Datenblättern und derselben 
rumgesucht und trotzdem keinen Anhaltspunkt gefunden um hier einen 
korrekten Wert einzutragen. Kann mir jmd weiterhelfen?

Achso: Der Atmega8515 lief mit demselben Programm wesentlich schneller 
als der ATMega16 oder der ATmega32, gibt es hier eine Einstellung/Jumper 
den ich übersehen habe?

Schöne Grüße, Dennis

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dennis,

hast Du die Fuses richtig eingestellt ?

Gruss Otto

Autor: Dilligent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, neh.. ich hab da gar nichts gesetzt, gibt es da einen Artikel drüber 
um welche ich mich außer den Oszis kümmern sollte?

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Dilligent (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.... Okay, steinigt mich, alles klar, es klappt.
Danke für deine Hilfe, es war bestimmt nicht das letzte mal das etwas 
unklar ist, aber das hat mich jetzt doch weitergebracht, es funzt wieder 
alles wunderbar!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.