www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fragen zu ISA-CONTROL-Webserver von H.Buss


Autor: Paul Baumann (paul_baumann)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
Ich bin am Verzweifeln. ;-) Ich kann den Webserver nicht "anpingen".

Es ist die Version mit Atmega32 und der Software 1.38 mit SD-Karte und 
der
Adresse 192.168.1.66 von Holgers Seite.

Istzustand:
RTL8019AS-Karte mit Jumpern
Adresse 300, IRQ 2/9 eingestellt
angeschlossen an einen Router

Nach Einschalten blinkt die rote LED auf der Control Karte 5 mal
und es wird über die RS232 gemeldet: "Keine SD Karte"
(ist im Moment auch keine dran, da hat er Recht ;-))

Dann "INIT 34" OK
und die Netzwerkadresse 192.168.1.66
und die MAC-Adresse.

Link LED an der Karte ist an.
Activity der Karte geht nach der Meldung "INIT34 OK" an.
am Router ist auch die 10Mbit LED an.
Verbindung ist also "elektrisch" da.

Ist das vielleicht nur ein Problem mit der IP-Adresse, weil mein
Rechner hat 192.168.178.146 und der Webserver eben 192.168.1.66?

Oder kann ich meinen Rechner irgendwie in den Adressbereich 
192.168.1.xxx
zwingen?


Ratlos
Paul

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Liegt mit Sicherheit daran, daß dein Rechner und der AVR-Webserver nicht 
im gleichen Subnet sind, wie du schon vermutet hast.

Volker

Autor: Paul Baumann (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
** Isa-Ctrl Webserver **
Init Network Card: ......... Init Ready!
Init: Okay 34
My Mac: 1e.a.2b.2b.2d.4d
My IP : 192.168.1.66

So, jetzt habe ich noch die andere Version ohne SD-Karte probiert.
Das ist die Ausgabe davon über RS232. Ist das alles, was ausgegeben 
wird,
oder "hängt" der Mega 32 fest und es müßte noch mehr kommen?

Wie ist das mit dem Subnetz? Muss ich mit beiden (PC und ISA-Control)
die ersten 3 Teile der Adresse gemeinsam haben, d.h. beide müssten
mit 192.168.1.xxx anfangen?

Wenn das so ist, wie kann ich dann meinen Rechner "verstellen", so daß 
er
im Bereich 192.168.1.xx zu liegen kommt?

Immer noch ratlos
Paul

Autor: Chris (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die Rechner müssen im selben Subnet liegen, d.h. z.B. 192.168.1.xxx
Das geht für ein Netz mit 255 Adressen, für den privatbereich völlig 
ausreichend.
Also dem Rechner eine feste IP zuweisen oder den DHCP des Router auf 
diesen Adressbereich umstellen.
Dann sollte alles klappen :)
Gruß,

Autor: Paul_Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HURRA!!! :-))

Es geht. 3 Kreuze.

Ich habe meinen Rechner jetzt auf 192.168.1.67 eingestellt. Damit komme 
ich an den Webserver ran.
Jetzt muß ich mir nur noch etwas einfallen lassen, wie ich es mit dem 
Rechner anstelle, daß er unter dieser Adresse mit der Fritz-Box 
"spricht".


Danke für Eure Hinweise und Hilfe, ich war auf dem falschen Dampfer mit
meiner Überlegung, daß nur die ersten beiden Zahlen der IP-Adresse die 
gleich sein müssen.

Freu!!
Paul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.