www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mega 8 Probleme


Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe hier bei meinen Megas so ein komisches Phänomen, ich habe
4 Stück, und alle lassen sich nicht mehr programmieren, weder seriell,
noch parallel ( STK 500). An den lock Bits habe ich nichts verändert.
Ich konnte jedoch jeden ein par mal proggen.
Hat schon wer ähnliches mitgemacht ???
bei den alten Avrs hatte ich nie solche Probleme.

Steffen

Autor: Joerg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Laß mich raten, bist Du Ponyprog-geschädigt?

Habe von mehreren Leuten mittlerweile gehört, daß Ponyprog wohl die
Fuse-Bits negiert ein- und ausgibt (also so, wie Atmel sie logisch
sehen möchte).  Wenn Du Dir auf diese Weise beim ATmega8 dann den
/RESET-Pin wegdefinierst, ist guter Rat teuer...  Parallele
Programmierung wäre der letzte Ausweg, falls Du nicht zuvor noch einen
Bootloader in den Flash gebracht hast.

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ne, ich benutze das STK 500 und AVR Studio 4

Autor: Jörg Maaßen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Bauart haben die Mega8?
Ach ja im STK500 gehen ja nur PDIP.

Ich hab mir auch schon 2 Module mit Mega8 im TQFP-Gehäuse gehimmelt.

Beim ersten mal anschließen klappte alles wunderbar. Konnte löschen,
schreiben, lesen usw. alles so oft ich wollte. Dann den Rechner
abgeschaltet und zu Bett gegangen. Am nächsten Tag voller Tatendrang
wieder eingeschaltet und nichts ging mehr. Nur noch lesen war möglich.

Ich hab auch keine Erklärung vermute aber, dass die Module über den
ISP-Anschluss (ach so ich benutze PonyProg und Parallelport 74HCT244)
irgendwelche Störimpulse (Spitzen) beim Ausschalten des PC's
mitbekommen hat.

Normale Mega8 im PDIP habe ich noch nicht getestet. Liegen aber hier
schon und mit 2313er hatte ich bisher nie Probleme.

Gruß Jörg

Autor: Johannes Raschke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ich hatte ein ähnliches Prob mit meinem 2313. Hatte schon ein paar
entsorgt, bis mir dann mal jemand sagte, ich solle mal etwas mit der
Versorgungsspannung spielen.
Die also schrittweise abgesenkt und "Chip Erase" gemacht, und
irgendwann meldete sich der Atmel wieder...
Parallele Programmierung konnte ich allerdings nicht testen...

Viele Grüße

Johannes.

Autor: Jörg Maaßen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also meine Mega8 Module wurden dabei noch sehr heiß, was mich vermuten
läßt, dass die wirklich gehimmelt waren.

Mit absenken der Spannung hatte ich es auch versucht. Bei 2,2V hab ich
aufgehört und die Module entsorgt. Ich war einfach gefrustet.

Gruß Jörg

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm,
ich wünsche mir den 4433 zurück g

Autor: BernhardT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es immer wieder, das Mega8 (Dip- frühe Mustertypen) unter dem
Studio 4 und STK 500 bocken. Parallel-Progen habe ich nie probiert. Ich
verwende jetzt immer Studio 3.56, da geht das dann aufeinmal ohne
Probleme.
Gruß Bernhard

Autor: Frank Linde (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf avrfreaks habe ich einen Tipp aufgeschnappt, daß mit einem langsamen
externen Takt (<= 100 kHz) die Dinger wieder ins Leben zurückgeholt
werden können. Bisher habe ich das aber noch nicht probiert.

Hier liegen auch noch 5 Stück Mega8 herum, die ein Bekannter mit
Ponyprog unter WinXP gehimmelt hat. Lassen sich zwar mit STK-500 im
Parallelmode löschen und auch die Fusebits kann man ändern, aber jeder
Versuch, ein Programm zu flashen, scheitert mit Verify Error.

Gruß, Frank

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, dann werde ich mal eure Tipps beherzigen, wenn ich resultate habe,
melde ich mich wieder bei euch

gruss Steffen

Autor: Steffen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe sowohl das mit dem AVR Studio als auch den niedrigend Takt
versucht, und nichts erreicht!!
Das gibt es doch nicht, ich dachte immer der Mega 8 sei die moderne
version des 4433 und daher besser,aberneuer ist eben nicht gleich
besser;)

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jörg,

wenn sie heiß werden, bist Du sicher, daß sie auch richtig rum im
richtigen Sockel und alle Jumper richtig stecken ?

Ich habe auch erst das Heft mehrmals gründlich durchgelesen, ehe ich
das STK500 unter Spannung gesetzt habe.


Allerdings habe ich mir als erstes einen Bootloader reingebrannt. Das
AVR-Studio 4 hochfahren dauert ja ne halbe Ewigkeit.
Dann habe ich die Kommandozeilenversion des Programmers genommen. Ist
zwar etwas schneller aber im Vergleich zum Bootloader immer noch
schnarchlahm.

Jetzt erreiche ich etwa folgende Zeiten:

Compilieren mit WINAVR: 5 Sekunden
Programmieren mit Bootloader: 2 Sekunden


Ehe ich den Bootloader fertig hatte mußte ich etwa 50 mal den
schnarchlahmen Atmel-Programmer nehmen und hatte keine Probleme, außer
ab und zu mal ein Timeout.



Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.