www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Helligkeitsproblem meiner 7-Seg.Anz. nach ein paar Sekunden


Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,
habe ein Problem mit meinen vier 7-Seg. Anzeigen.
Ich stell z.B. nur eine Zahl auf allen Segmenten
dar und am anfang leuchten die auch wunderbar.
Nach etwa 20 sekunden aber werden die Anzeigen ohne einen
Grund blass und bleiben es dann auch.
Die 7 Seg. Anzeigen haben alle eine gemeinsamme Anode,
welche ich über Transistoren ansteuere.
Habe festgestellt, dass mein 7805, welcher den AVR mit Spannung
versorgt ziemlich heiß wird.

Woran kann es liegen?

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
wenn die Anzeigen verblassen, kühlt sich der
7805 und der AT90S4433 ab.

Autor: mmerten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Strom über widerstände korrekt begrenzt? Verlustleistung beim 7805
beachtet und entsprechenden Kühlkörper verwendet? Mehr gibt meine
Glaskugel ohne schaltplan nicht her :-)

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab keinen kühler verwendet.
die widerstände haben einen wert von 200Ohm.
ist das zu wenig?

Autor: formtapez (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eher zuviel.

wenn ein segment z.B. 20mA braucht, dann nimm bei 5V einen 220 Ohm
Widerstand.

Trotzdem komisch das sie mit der Zeit dunkler werden. Evtl. schaffts
der µC nicht die Dinger zu treiben. --> Datenblatt

MfG
formtapez

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke aber das soll 200 Ohm heissen.
nach dem Datenblatt müßte er 20mA treiben können.

Autor: Chaldäer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich weiß zwar auch nicht, wie Deine Beschaltung aussieht, aber 200 Ohm
erscheint mir etwas zu niedrig zu sein. Die Transistoren (je nach Typ)
sollten auch mit 1-10 kOhm (Ich verwende letztere) sauber schalten.
Rechne einfach mal den Gesamtstrom aus, den Deine Schaltung zieht.

Gruß,
Chaldäer

Autor: Chaldäer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmals hi,

Hoffentlich verwechselst Du (oder auch ich) hier nichts. Die AVRs
sinken 20mA und treiben bis zu 2mA? Bei gemeinsamer Anode wirds aber
eher ersteres sein.

Gehe ich recht in der Annahme, daß Du die Anzeigen multiplext, die
Anode über die Transistoren steuerst und mit dem µC über den Widerstand
die Anzeige sinkst?

Trotzdem kann es sein, daß eine Anzeige mit bis zu 8*20 mA zieht, wenn
voll durchgeschaltet. Einen 7805 in der kleinen Bauform ist mit 100mA
Maximum angegeben. Er verträgt mehr, kann dann aber zum Kochen und
Braten verwendet werden.

Gruß,
Chaldäer

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
genau wie du sagst, mach ich das. Also multiplexen über die Widerstände
und ansteuern der einzelnen Segmente über die Transistoren (PNP).
Der 7905 ist im großem Gehäuse.

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry, ich mein der 7805 ist im großem gehäuse

Autor: Joerg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trotzdem überheizt Du den einfach, auch das große Gehäuse braucht
seine Kühlung, wenn Du zu viel Verlustleistung umsetzt.  Der Regler
regelt dann aufgrund Übertemperatur zurück, daher werden die Anzeigen
dunkler.

Wie viel Strom zieht denn die ganze Schaltung?  Wie hoch ist die
Eingangsspannung am Regler?

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
15 V am Eingang des Reglers und die Schaltung zieht 850mA.
Kann das sein?
Ich glaube die ich muß wohl die Widerstände auf 470 Ohm erhöhen.

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

(15V-5V)*0,85A=8,5W

Das ist um den Faktor 10! zu hoch was ein TO220 an Verlustleistung ohne
Kühlkörper abkann.

Matthias

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke,
hab mir schon so was gedacht.
werde also die widerstände größer machen.
Dadurch wird dann aber die helligkeit der segmente auch sinken, oder?
muß ich halt mit leben.

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verkleiner die Eingangsspannung und gib dem armen Regler nen großen
Kühlkörper. Mit anderen Widerständen reduzierst du die Verlustleistung
vielleicht um 10%, (Willst ja wohl schließlich auch noch was sehen,
oder?) was immer noch viel zu viel ist, wie Matthias ja schon gesagt
hat.

Autor: Dag (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann die Eingangsspannung nicht runtersetzen, da ich
die 15V für einen Sensor brauche.
Aber einen Kühlkörper werde ich montieren.

Autor: Chaldäer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

wie wäre es denn mit einem Zwischenregler. Transformiere die 15V erst
auf 9V runter. Oder direkt einen anderen DC-DC-Wandler.

Gruß,
Chaldäer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.