www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik portb.2 am atmega16 ist int 2, geht aber nicht.


Autor: roboterheld (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo, ich über trage daten per soft-rs232(bascom) von einem atmega16 
zum anderen.

wenn ich die daten am empfänger am int0 und int1 per interrupt abfrage, 
kommen die daten an. wenn ich an den interrupt2 gehe , dann nicht.

wie ich sehe hat der int2 noch eine andere funktion (AINO), liegt es 
etwa daran? wie muss ich dann den port zumschalten, damit er auf den 
interrupt anspricht?

mfg

Autor: ES (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da wird dir gehelft.
www.bascom-forum.de

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.