www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik offene Ausgänge


Autor: burkhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich hab da mal ne Frage zum Atmel 8515:

Momentan experimentiere ich mit dem STK200. Es klappt auch wunderbar, da 
alles schon vorgegeben ist.

Nun aber möchte ich diesen µC auf eine eigene Platine bauen. Was muss 
ich bei den nicht beschalteten Pins beachten? Soll ich die auf Masse 
legen oder einfach nicht beachten?

Mit Pins mein ich die "normalen" I/O-Ports und restlichen ALE,  ICP und 
OC1B..,

Ich danke für jede Mithilfe!


Ciao, Burkhard!

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Pins sollten in jedem Falle frei bleiben.
Wenn du die Ausgänge auf Masse legst, wird der Prozessor das wohl nicht 
so lustig finden.

Gruß: Holger

Autor: Niki Hammler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann da eigentlich was passieren?
Was ist denn wenn man aus Versehen einen Port als Ausgang konfiguriert 
aber (eben aus Versehen) irgendwas als Eingang hat?

Und eine kleine Frage so nebenbei: Ich weiss dass das im Datenblatt 
steht aber ich kenn mich bei den ganzen Zahlen nicht so aus.

Bei Eingängen:
Wie hoch kann der Strom dort sein? Eigentlich muss ich den ja nicht 
begrenzen, kann ihn auch direkt von VCC holen, also gibts da im Prinzip 
keine Begrenzung?
Wie hoch darf die Spannung höchstens sein? Im Datenblatt steht irgendwas 
von VCC+1,5 Volt...ist damit das gemeint?
Also wenn ich jetzt 5 Volt an VCC habe kann ich an einen I/O Input Pin 
höchstens 6,5 Volt reingeben?

Niki

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>...aus Versehen einen Port als Ausgang konfiguriert aber (eben aus Versehen) 
irgendwas als Eingang hat?..

Versteh' ich nicht. Erklär' mal.

Eingänge darfst du als hochohmig ansehen. Da fließt so gut wie kein 
Strom hinein. Ich hab' gerade mal nachgeguckt, das Datenblatt vom 2333 
vermeldet einen "Input Leakage Current" vom 8 Microampère bei einer 
Spannung von 6V.

Und ja, du hast Recht: Vcc+1,5V sind 6,5V bei einer Betriebsspannung von 
5V.

Autor: Phagsae (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi jetzt misch ich mich auch noch ein..

Die Eingänge konnen auch im pull up mode betrieben werden.
Wenn DDR =0 Und PORT=1
nur für DDR=0 PORT=0 sind die im HiZ mode.

Ich würde ungenütze Ports immer als Ausgang belegen.
Und auf der LP nicht beschalten.
Dann kann in keinem fall ein Hochohmiger Eingang draus werden.
Hi-Z Eingänge mögen im allgemeinen keine Überspannung
( können sie mangels bezugspegel nicht ableiten )
Aber eigentlich funktionierts auch so.

Phagsae

Autor: Jonas Diemer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum maximalen strom bei ausgängen:

ein output pin kann irgendwas bei 2mA drainen (d.h. wenn er high ist und 
der verbraucher gegen masse geschaltet ist).

Ist der verbraucher gegen vcc geschaltet, kann der output pin (wenn er 
low ist) max. 20mA sinken.

wenn der pin als eingang konfiguriert ist und der pullup ausgeschaltet 
ist (also PORTn auf 0), dann kannst (glaub ich) durchbrennen, wenn du 
den high ziehst - korrigiert mich, wenn ich mich da irre.

Autor: Niki Hammler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich meine wenn man per software mit sbi/cbi einen Port als Ausgang 
gesetzt hat, dann aber z.B. ein IR Decoder angeschlossen ist.

Ist es umgekehrt (auch/auch nicht)gefährlich?

Z.B. einen Port mit sbi/cbi als Eingang konfigurieren aber ein dann ein 
LED anschliessen.

(Alles oben geschriebene basiert natürlich wie schon gesagt auf "aus 
Versehen" denn mit Absicht werd ich ja keinen Port als Eingang 
konfigurieren aber ein LED anschliessen).

Bezüglich VCC+1,5 Volt: Ich bekomme von einem Handy Pin (der, so denke 
TTL kompatibel sein sollte) zwischen 5 und 7 Volt. Es kann natürlich 
auch sein dass die Batterie meines Multimeters schon zuu leer ist (beim 
Widerstandmessen bringt es gar nix mehr zammen).
Es scheint jedenfalls zu gehen.

Noch einmal zu den Port Eingängen:
Kurzer Zwischenschub dass ob ich mir das richtig gemerkt habe mit dem 
hoch/nieder-ohmig, ich merks mir immer an Spannungs/Strommessung:
Also bei der Spannungsmessung ist der Eingang hochohming bei der 
Strommessung niederohmig oder?
Und hab ich das so auch richtig verstanden?. Es fliesst ja immer nur so 
viel Strom wie fliessen kann und der Strom der da reinfliesst (in den 
Port) ist ja sozusagen parallel abgezweigt. Also fliesst eben sowieso 
nur so viel Strom wie fliessen kann, also ein minimaler von 8uA?
Deshalb auch sogar wenn ich den Eingang von der "dicken" VCC Leitung 
nehme...

Also bitte korrigieren falls ich da schon wieder Fehler drin hab!

Danke,

Niki

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.