www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FE und DMX mit ATmega8


Autor: Heiko Thole (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ihr.
ich versuche mit nem Mega8 ein DMX-Signal auszuwerten.
Das klappt auch eigenlich schon ganz gut. Ich nutze das FE-Flag um
einen Reset zu erkennen. Doch leider kommt diese Flag nicht immer beim
Reset, sonder ab und an auch nach dem Startbyte (alles 0).
Die Zeiten von dem Signal sind soweit in Ordnung (ich hab mir das auf
einem Oszi angeguckt; getriggert wenn FE kommt).
Habt ihr eine Idee warum der µC das FE ab und an zu spät bzw. falsch
setzt?
Danke
Heiko

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.