www.mikrocontroller.net

Forum: Compiler & IDEs Simulator und JTAG-ICE MKII Unterschied


Autor: Günther (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe ein komisches Phänomen mit MEGA88, AVR GCC und AVR Studio im 
Kombination mit dem JTAG-ICE MKII.

Ein paar Softwareteile sind mittels Linker speziell plaziert.
Starte ich das Programm im Simulator ist alles dort wo es hinsoll 
(Disassembly).

Mache ich selbiges über den JTAG-ICE MKII, dann sind zwar die 
Sprungmarken richtig eingetragen (also die Kommentare der 
Orginalfunktionen zum Sourcecode) aber der Code liegt an ganz anderen 
Stellen und die Soft funzt nicht, also rjmp - Sprünge mit falschem 
Offset.

Nutze ich den JTAG-ICE als reinen SPI Programmer funktionert alles?!?

Ist das ein bekanntes Problem für jemanden da draussen an der Front.
Vielleicht ein BUG in DWARF-2 oder über das *.elf ... or whatever

PLS Help.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.