www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Analog zum DCF77


Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
ich wollte gerne ein DCF77 an meinen atmega16 naschliesen.
aber der Modul von Conrad ist für als Studenten etwas teuer.
Habe aus meinem Funkwecker den Modul ausgebaut, der für den Empfang 
zuständig ist.
Auf der Platine steht nur "PC901-2  REV 1" drauf.
es gehen noch 4 drähte zur Platine von dem Wecker.
P T G und V.
ich finde aber leider nun kein datenblatt zu diesem Empfänger.
wie soll man in diesem Fall vorgehen?
Danke!
MfG Alexander

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

P=Power on
T=hier liegt das DCF77 Signal an
G=Gnd=minus
V=VDD=plus

an P musst du ausprobieren ob du den kontakt zum einschalten an Gnd oder 
an VDD anschliesen musst

mfg Marcel

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@mfg Marcel
achsooooo :))
ist das doch der übliche DCF77 empfänder, oder nichit?
Also es gibt ganz viele Beispiele für Atmega8 und DCF77.
muss ich noch was ändern, oder kann ich das schon so anschliessen?
danke

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

kann sein das du das signal noch verstäken musst kann es dir aber nicht 
100% sagen da ich habe es von der Zeit her noch nicht geschafft mein 
ausgebautes Teil mal anzuschließen.
alles weitere musst du suchen oder andere müssen dir Helfen.

Mfg Marcel

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, danke! :)))

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest auf keinen Fall mehr Spannung anschließen, als Dein Wecker 
geliefert hat, also 1.5V oder 3V (1 oder 2 Batterien). Ansonsten geht 
das Modul sehr schnell in Rauch auf.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt alles angeschlossen.
statt 3V (im Wecker waren 2x1,5 Batt.) habe ich eine Z-diode mit 2,7V 
genommen.
Das programm läuft, aber die Zeit ist nicht da.
Wie kann ich testen, ob der DCF77 überhaupt irgendwelche signale 
liefert?
danke

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so schwer?
oder kann es gar nicht funktionieren mit 2,7V?

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alex wrote:

> Wie kann ich testen, ob der DCF77 überhaupt irgendwelche signale
> liefert?

Das Modul vom µC abkoppeln und mit einem Oszi mal nachsehen
ob am Datenausgang vom Modul Pulse rauskommen. Wenn du kein Oszi
hast kannst du auch versuchsweise mal eine Led dranhängen.
Jede Sekunde muss ein Pulse daherkommen. Je nachdem ob das eine
logische 0 oder eine 1 sein soll, ist der Puls 100 ms bzw. 200 ms
lang. Die Pulse sind mit freiem Auge gut zu sehen.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für eine Vernünftige Antwort!

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm einfach mal nur das Modul, versorge es mit einer Batterie und eine 
LED (+Vorwiderstand) an den DCF Anschluss.
Die sollte dann im Sekundentakt blinken wenn der Empfang da ist.
Wurde aber auch schon in einigen Beiträgen erwähnt.

Ansonsten sind 2,7V eigentlich ok, evt nach Kondensator parallel.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich bekomme aber keine signale! (auf dem Oszi gegukt)
woran kann es liegen?

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der DCF Ausganag ist meist Open-Kollektor, hast einen Pull-up dran?

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alex wrote:
> ich bekomme aber keine signale! (auf dem Oszi gegukt)
> woran kann es liegen?

* kein Empfang

* hat das Modul vielleicht einen Open Collector Ausgang.
 (dann muesste man einen Widerstand vom Ausgang nach Vcc
 schalten).

* Modul defekt

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein.
pull up. oder pull down?
Up ist doch zur VCC.
schaltet er dann GND?

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>nein.
>pull up. oder pull down?
>Up ist doch zur VCC.
>schaltet er dann GND?

sorry, kollektor schaltet ja natürlich GND

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie gross soll der pull up sein?
12k reicht?

Autor: Klostein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Up ist doch zur VCC.
>schaltet er dann GND?

Jepp, er schaltet nach GND durch.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
12k dran.
schaltet nicht. :(
bleibt immer auf 3V.
Der modul hat gestern im Wecker funktioniert

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Alex (Gast)

>12k dran.
>schaltet nicht. :(

Viel zu klein! Ich hatte mal ein Modul von Reichelt, das war selbst mit 
den internen Pull-Ups vom AVR überlastet (~30k)!

>bleibt immer auf 3V.
>Der modul hat gestern im Wecker funktioniert

Nimm mal 220k und hänge einen Inverter oder Transistor dran. Auf keine 
Fall direkt ein LED.

MFG
Falk

Autor: Klostein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Womit versorgst du denn das Modul? Versuche es am Anfang mal nur mit 
Batterien und gehe möglichst weit weg von PCs, Monitoren und was sonst 
noch schön Störstrahlung verursachen könnte.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit einem Labornetzteil.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
er tickt nicht! :(
wenn meine 12k zu klein waren, dann ist der Collektor warscheinlich 
schon kaputt! :(
ärgerlich.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
muss ich die antenne noch ausrichten?
ich meine im Wecker hat es ja in jeder Position funktioniert.

Autor: Klostein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wenn meine 12k zu klein waren, dann ist der Collektor warscheinlich
>schon kaputt! :(

Bei 3V wären das dann 0,25mA. Unwarscheinlich, dass der Transistor damit 
schon durchbrennt.
Wie gesagt, versuch es mal mit Batterien/Akkus. Mein DCF-Modul aus einem 
Wecker hat übriegens einen "aktiven" Ausgang, d.h. es kann eine LED 
treiben.
Falls du einen Kopfhörer zur Verfügung hast: Schliesse mal deinen 12k 
Widerstand an den Out-Ausgang des Moduls an, an den Widerstand ein 
Spulenende des Kopfhörers, das andere Spulenende entweder an VCC oder 
GND. DU solltest dann in leiser Umgebung ein Knacken im Rhythmus des 
DCF-Signals hören.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>DU solltest dann in leiser Umgebung ein Knacken im Rhythmus des
>DCF-Signals hören.
wenn ich schon am Oszi nichts sehen kann...
ich habe immer noch nicht heraus bekommen wohin ich "P" schalten soll.
habe beides probiert. läuft nicht.
ist das sicher, dass er mit 3V läuft?
wenn nicht mit 3, sondert mit 1,5, dann ist er schon kaputt.
aber der Wecker hat mit 3V funktioniert.

Autor: Klostein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wenn ich schon am Oszi nichts sehen kann...

Das Oszi kann evtl. Störstrahlung aussenden.

>ich habe immer noch nicht heraus bekommen wohin ich "P" schalten soll.

Bei mir war der nicht explizit gekennzeichnet, haben ihn während des 
Betriebs im Wecker mit dem Multimeter ermittelt (VCC und GND war ja 
einfach) und habe ihn über einen 1k Widerstand an VCC geklemmt.

>wenn nicht mit 3, sondert mit 1,5, dann ist er schon kaputt.

Hast du den Wecker noch? Wenn ja, einfach mal nachmessen, kann mir aber 
nicht vorstellen, dass der Rest vom Wecker mit 3V und nur der Empfänger 
mit 1,5V läuft. Mir ist bisher noch keine Funkuhr untergekommen, die nur 
aus einer Batterie gespeist wird.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wenn ich einen Pull-down an GND  und "P" an Gnd Anschliesse, dann 
habe ich immer 3V.
also immer einen high pegel

Autor: Klostein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>also wenn ich einen Pull-down an GND  und "P" an Gnd Anschliesse, dann
>habe ich immer 3V.
>also immer einen high pegel

Habe ich dich jetzt richtig verstanden: Der T-Ausgang wird über einen 
12k Widerstand mit GND verbunden? Benutzt du zur Stromversorgung 
Batterien?

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Der T-Ausgang wird über einen 12k Widerstand mit GND verbunden?
nein, 220k.
sonst alles richtig

Autor: Klostein (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Der T-Ausgang wird über einen 12k Widerstand mit GND verbunden?
>nein, 220k.
>sonst alles richtig

Dann verstehe ich folgende Zeile nicht:

>also wenn ich einen Pull-down an GND

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Dann verstehe ich folgende Zeile nicht:
sorry, habe mich falsch ausgedrückt.
aber so, wie du es beschieben hast ist richtig.
aber es tut sich nichts. immer 3V am T

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm. Blöde Idee:
Hast du den Rest vom Wecker noch?
Ich würde das Modul noch mal in den Wecker einbauen
und nachsehen, ob der dann noch tut.
Wenn nein: Schlecht
Wenn ja: Mit dem Oszi, Multimeter mal alle Modulanschlüsse
beobachten.

Autor: Philipp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim Reichelt Modul war das Problem das der PON Eingang nicht beschaltet 
werden durfte, war schon auf dem Modul verdrahtet.
Egal ob ich PON auf GND oder Vcc gezogen habe, es ging nicht. Erst als 
der nicht angeschlossen war ging es...
Ansonsten einfach mal mit dem Wecker wo es ursprünglich drin war 
vergleichen, wie es auch schon vorgeschlagen wurde...

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sehr gute idee! :)
werde ich mal machen

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ich habe ihn wieder eingebaut.
er läuft mit 3V.
PON ist beim Betrieb auf 0V.
am TCO habe ich mal Oszi angeschlossen. Bild im anhang.
Wenn ich TCO nicht anschliesse, kommen aus dem wecker 1,5V raus.
Das komische ist(war immer so), wenn ich den wecker einschalte, dann 
empfängt der DCF77 sofort Signale, aber die Zeit stellt er nicht ein. 
erst später, nach paar Stunden ist die richtige Zeit eingestellt.

eure Meinungen...

Autor: Alex (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier das Bild

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es sieht so aus, dass er doch NICHT GND schaltet, oder?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.