www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega32 + ISP AVR MKII


Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Ich habe folgendes Problem beim Serial Downloading über ISO:

- Orange led blinkt ein paar Mal
- Dann blink die grüne Led für ca. 1s, dann wieder die Rote led

AVR Studio meldet daraufhin, dass keine Verbindung hergestellt werden 
konnte.

Ich habe bereits denn Reset Pull-Up Wiederstand (1k) nach VCC+ 
geschaltet ebenso 1k Widerstände von SCK, MISO, MOSI an den Atmega. 
Leider hat nichts geholfen und ich kann immer noch keine Verbindung 
aufbauen.

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sollt ISP heissen.

Autor: Marc (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du AVND mit AGND verbunden?

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marc wrote:
> Hast du AVND mit AGND verbunden?
AVND? Ist das ein neuer Anschluss?

@Jonas:
Sag doch bitte mal, was an dem ATMega32 sonst noch so dranhängt, 
speziell an den ISP-Anschlüssen.

Autor: Jörg B. (joerg-sh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Grundsätzlich solltest du alle Anschlüsse kontrollieren, Miso Mosi und 
SCK, Reset mit 10 KOhm gegen VCC. VCC und GND Anschluß. Dann sollte es 
gehen wenn alles stimmt. Ich vertausche immer mit vorliebe Mosi und Miso 
;-)
Am besten mal von den Pins der MCU zu den Anschlüssen Durchmessen!

Grüße

Jörg

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Leider funktioniert es immer noch nicht. Ich denke, dass das Problem 
darin besteht, dass die Spannungsversorgung direkt an das Tischnetzgerät 
(+5V) angeschlossen ist. Evtl. hilft da eine 5V-Spannungsstabilisierung. 
Kennt jemand da grad ein passendes Bauelement?

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum denkst Du dass es an der Versorgung liegt?
Ist das Netzteil irgenwie schlecht?

Wie wäre es mit einem Schaltplan Deines Aufbaus?
Raten ist zwar manchmal ganz spannend, führt aber nicht unbedingt zum 
Ziel...

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, haeng bitte mal den Schaltplan als PNG(!) an.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du mit dem AVR-ISP mkII überhaupt schon etwas erfolgreich geflasht? 
Hast Du Dir mal die Online-Hilfe zum AVR-ISP mkII im AVR-Studio4 
angesehen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.