www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik erst ab 10v spannung durchlassen


Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

ich habe eine schaltung die im moment noch nicht funktioniert.

Fehler: Die schaltung erkennt die spannung 0.2-0.6 v vom meinem geber 
als schaltsignal weil meine schaltung so fein ist.
Diese kleinen spannungen sind aber keine schaltsignale sondern störungen 
oder kp im anderen modul weil das eigendlich für was anderes gedacht 
ist.
Jetzt dachte ich mir weil ja wenn ich die taste drücke der 12v schaltet 
hänge ich da ne z-diode mit 10v dran.

Problem jetzt: welche z-diode? und das signal ist ein masse signal also 
massegeschaltet, geht das auch?

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hä?

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also schaltung 1 gibt immer eine spannung von 0- 1v aus
auch wenn nicht betätigt! wenn betätigt 12v.

die schaltung 2 erkennt die 0-1v schon als schaltspannung, was aber 
falsch ist.

die soll erst ab 10 v schalten.

brauche ne z-diode die das regelt oder noch ne schaltung?!

Autor: Uwe ... (uwegw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komparator mit Schaltschwelle auf 10V.

Autor: BerndB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
mehr Detail infos wären nicht schlecht.
Zum Beispiel wie ist die Schaltung 1 aufgebaut (Schaltplan)? und wie ist 
die Schaltung 2 aufgebaut (Schaltplan)??
sonst kann man nur raten !

Gruß B

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Sprache der Technik ist die Zeichnung.
Poste mal deinen Schaltplan

Gruss Helmi

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schaltung 1 ist eine funkfernbedienung das stuergerät..
an den ausgang an den ich will wird sonst ein stellelement angeschlossen 
dem das egal ist wieviel spannung er bekommt der schaltet erst bei 12 v 
und da liegt das problem meine 2. schaltung erkennt diese kleinen 
spannungen schon als schaltspannungen

schaltung 2 ist eine beleuchtungsverzögerung die wird eigendlich an 
einen türkontaktschalter angeschlossen der ein klares ein/aus signal 
hat.

beides masse geschaltet

schaltpläne habe ich nur vom verzögerungsmodul.

es müsste eigendlich nur das signal von der schaltung 1 umgewandelt 
werden das es ein klares ein / aus signal hat... und zwar ab 10v da die 
batterie spannung ja nie genau 12 v ist.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.smartkit.de/images/big/1115.jpg

das die schltung mehr habe ich auch nicht

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als ich das .jpg angeklickt habe, mußte ich doch herzlich lachen,
sonst sind die Post ja eher traurig.

Autor: jack (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Post*s*

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann es sein das an deiner Schaltung ein Pullup Widerstand fehlt ?
Nur so kann ich mir erklaeren wieso da nur 0.2..0.6V anstehen.
Mach einmal einen Widerstand( ca. 1K .. 10K)  von dem Ausgang nach +12V 
und miss dann noch einmal.

Gruss Helmi

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die schaltung funktioniert ja aber das problem ist das die schaltung ein 
genaues ein/aus signal braucht und das bei meiner funkfernbedienung 
nicht gegeben ist... daher wollte ich erst spannungen ab 10v 
durchlassen..

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche es doch mit einem einfachen Spannungsteiler mit
zwei Widerständen.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also noch mal:

der geber:
nicht geschaltet: 0,1-1v
geschaltet: 12v

der nehmer braucht ein klares ein aus signal also 0 oder > 10v

weil jetzt erkennt er die spannungen vom geber bei nicht geschaltet, was 
weiß ich woher die spannungen kommen, als schaltsignal.


wie funzt denn ein spannungsteiler?

Autor: hubert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
erstmal pulldown um die 0,2Volt zu kompensieren

Autor: Helmi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Spannungsteiler

Bei UE gibst du dein Signal rein , bei UA bekommst du es um den 
Teilerfaktor kleiner raus.

UA = (UE*R2)/(R1+R2)

z.B. wenn du R1 und R2 = 1K machst dann bekommst du wenn du am Eingang 
12V anlegst am Ausgang der Schaltung 6V raus.

Bei anderen verhaeltnissen muss du die beiden Widerstaende R1 und R2 
dementsprechend abaendern.


Gruss Helmi

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, genau so

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
is der pulldown ein ganz normaler wiederstand den ich von dem pin an 
plus lege?

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
will meine spannung aber nicht teilen sondern es so haben wie bei einer 
z-diode das der erst ab 10v die spannung durchlässt...

werde das mit dem pulldown widerstand versuchen

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>is der pulldown ein ganz normaler wiederstand den ich von dem pin an
>plus lege?

Das ist ein Pull-Up!

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pulldown geht vom Ausgang nach Masse.
Pullup geht vom Ausgang nach + Versorgung.

Ich denke mal ein Widerstand von ca. 2..10K wuerde reichen.

Gruss Helmi

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhh meinste das das klappt...?
bin ja eher skeptisch...
dann habe ich da aber auch wieder höheren ruhestrom im auto

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hätte nen 470 ohm da -.-

Autor: Kevin K. (nemon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
10v zenerdiode an den signaleingang, dahinter nen vielleicht 1k 
ohm-widerstand gegen masse und den mittelabgriff als ausgang verwenden: 
unter 10v sperrt die zenerdiode, über ihr liet die ganze spannung an, 
der mittelabgriff liegt quasi auf masse. oberhalb von 10 volt beginnt 
die diode zu leiten und über ihr fallen ziemloich konstant 10 volt ab. 
die spannung am mittelabgriff ist damit U(ein)-10V

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das klingt sehr gut....

nur das mit dem mittelabgriff peil ich nicht so

Autor: Kevin K. (nemon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du musst nur beachten, dass du dann am mittelabgriff 2 volt bekommst, 
wenn du über der reihenschaltung 12v anlegst. das muss der teil, der 
dahinter kommt, verkraften. evtl. mit einem operationsverstärker als 
komparator auf 12v anheben, wenn es nötig erscheint

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
reicht nicht eine 10v z diode?
will ja nur das es ab 10v ein signal bekommt

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>reicht nicht eine 10v z diode?
>will ja nur das es ab 10v ein signal bekommt
Doch, so wie es  Kevin K. (nemon) beschrieben hat. Mittelabgriff ist das 
Stück Draht zwischen Z-Diode und dem 1k-Widerstand.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
War denn beim Bausatz keine Schaltung dabei?
Oder war die Platine bereits fertig aufgebaut?

Da es sich um eine einseitige Platine handelt, kannst Du die ja mal auf 
deinen Scanner legen, oder besser(wenn Du kannst), die Schaltung 
abnehmen. Leider ist im Netz keine Schaltung verfügbar
(siehe zB. hier:)
http://www.smartkit.de/start.php?bausaetze_auto_+_...

Nur mit einer Z-Diode wird es ganz sicher nicht funktionieren, zumal im 
Auto viele Störungen auftreten. Wo ist die Schaltung denn GENAU 
angeschlossen?
Ich tippe mal, "DS" geht irgendwie an die Zentralverriegelung, oder?

Schaltung würde ich ausm Bauch so machen:


        _
    o--|___|----o-----o--------4"DS"
                |     |
        4K7     |     '
               .-.    |+
               | |   ===
            1K | |   /-\ 1uF
               '-'    |
                |     |
                '-----o--------1"GND"
(created by AACircuit v1.28.6 beta 04/19/05 www.tech-chat.de)

Gruß
Axelr.

@edit

wohl doch nicht im Auto verbaut, wegen (Zitat Eingangspost):
>weil das eigendlich für was anderes gedacht ist.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
doch klar im auto verbaut....

aber meinte damit das der ausgang für heckklappen stellmotor gedackt war 
und nicht um ein innenbeleuchtungsverzögerungsmodul einzubaun.

gedacht ist das so.

per ffb de knopf für kofferraum drücken und das licht geht im wagen an.

jetzt ist wie oben beschrieben das problem das die schaltung der 
verögerung sehr anfällig ist und diese kleinen spannungen als 
schaltsignal versteht.
daher dachte ich.... z- diode dazwischen so das meine schaltung nur 
schaltet wenn auch wirklich der knopf der ffb gedrückt wird denn dann 
schaltet der da -12 v.

würde eine z-diode nicht ausreichen? dann wären die spannungen ja weg 
und nur die wirkliche schaltung (da über 10v) würde durchkommen=?

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das kleine Spannungen irgendwo auftreten, und diese als Steuersignal 
interpretiert werden, hast Du uns schon erklärt - wissen wir.

Du hängst also mit PIN "DS" an der Öffnermechanik deiner 
Kofferraumklappe?

[SCHNIPP]
War denn beim Bausatz keine Schaltung dabei?
Oder war die Platine bereits fertig aufgebaut?

Da es sich um eine einseitige Platine handelt, kannst Du die ja mal auf
deinen Scanner legen, oder besser(wenn Du kannst), die Schaltung
abnehmen.
[SCHNAPP]

[SCHNIPP]
Nur mit einer Z-Diode wird es ganz sicher nicht funktionieren, zumal im
Auto viele Störungen auftreten.
[SCHNAPP]

Bau von mir aus 'ne Zener Diode ein, wenn Du zufällig eine da hast.
Ich hätte jetzt keine zur Hand - Widerstände und einen kleinen Elko 
schon.
Daher mein Vorschlag in dieser Richtung.
Du musst aber für etwas Stromfluss durch die Z-Diode sorgen. Daher der 
1K-Widerstand, sonst gehts nicht.

     10V-ZENER
   o---z<----o-----o------o-4"DS"
             |     |      |
             |     '      |
            .-.    |+     |
            | |   ===     - 1N4148
         1K | |   /-\ 1uF ^
            '-'    |      |
             |     |      |
             '-----o------o-1"GND"
(created by AACircuit v1.28.6 beta 04/19/05 www.tech-chat.de)

Autor: Kevin K. (nemon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
genau so, wie axel es gezeichnet hat, sollte es sein. mit der 
zenerdiodenspannung bestimmst du im prinzip nur den eingangspegel, ab 
dem über dem widerstand eine spannung abfällt. du kannst auch eine 
6v-zenerdiode nehmen, dann fallen am widerstand 6 volt ab, wenn du 12v 
auf den eingang gibst. du kannst dann im prinzip sogar eine kleine (!) 
last parallel zu dem widerstand einbauen, eine led mit vorwiderstand für 
6 volt.

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ok ich teste das mal...

ist in der schaltung auch berücksichtigt das das alles massegesteuert 
ist?

Autor: hubert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ggf nach der zener mit transistor durchschalten oder nicht

Autor: Björn Wieck (bwieck)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Axel Rühl wrote:

> Bau von mir aus 'ne Zener Diode ein, wenn Du zufällig eine da hast.
> Ich hätte jetzt keine zur Hand - Widerstände und einen kleinen Elko
> schon.
> Daher mein Vorschlag in dieser Richtung.
> Du musst aber für etwas Stromfluss durch die Z-Diode sorgen. Daher der
> 1K-Widerstand, sonst gehts nicht.
>
>      10V-ZENER
>    o---z<----o-----o------o-4"DS"
>              |     |      |
>              |     '      |
>             .-.    |+     |
>             | |   ===     - 1N4148
>          1K | |   /-\ 1uF ^
>             '-'    |      |
>              |     |      |
>              '-----o------o-1"GND"
> (created by AACircuit v1.28.6 beta 04/19/05 www.tech-chat.de)


Das ist schon eine gute Schaltung, aber gegen fiese Störungen im KFZ
muss noch ein bischen mehr Aufwand getrieben werden.
Siehe Bild
Ich habe das mal in LTSpice simuliert mit einem Spike von 80V (200µs)


Grüße
Björn

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
solche Spitzen sind durchaus zu erwarten. Da ich immer noch nicht weis, 
WO GENAU das Kabel vom Eingang "DS" nun angeschlossen ist, kann man 
schwerlich eine genaue Aussage treffen, ob die grässlichen Störspitzen 
(Stichwort "Lastabwurf") auch in dem Maße durchschlagen. Auf der 
Versorgungsleitung sind diese Spannungsspitzen allemale, ob am 
Steuereingang kann ich nicht sagen.

Wie ist eigentlich "massegesteuert" definiert?

Liegen 12Volt (H) an, schaltet deine Elektronik, liegt nichts an (Z), 
oder (L), beginnt deine Nachlaufzeit. Was ist nun unter "massegesteuert" 
zu verstehen. Für mich hieße massegesteuert, das die 12Volt über einen 
Widerstand gegen eben diese erzeugt werden (also ständig da sind, wenn 
die Heckklappe geschlossen ist) und dein Schaltkontakt der Heckklappe 
diese Spannung kurzschliesst. Ist das so?

[SCHNIPP]
War denn beim Bausatz keine Schaltung dabei?
Oder war die Platine bereits fertig aufgebaut?

Da es sich um eine einseitige Platine handelt, kannst Du die ja mal auf
deinen Scanner legen, oder besser(wenn Du kannst), die Schaltung
abnehmen.
[SCHNAPP]

Mach doch bitte wenigstens eine Skizze, WO GENAU Du im Auto da nun drann 
gegangen bist.

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Axel Rühl wrote:

> Wie ist eigentlich "massegesteuert" definiert?

Ich glaube das damit ein Schalter gemeint ist der gegen Masse schaltet.
So wie diese Türkontakte fürs Innenlicht oder ein Öldruckschalter bzw
Thermoschalter.

Das wurde IMHO deswegen gemacht weil im KFZ überall Masse verfügbar ist 
und
somit Kupferleitungen eingespart werden können.


> Mach doch bitte wenigstens eine Skizze, WO GENAU Du im Auto da nun drann
> gegangen bist.

Das würde uns allen mal helfen...

Der OP hat was von einem Teil berichtet das 0.1-1V schon als gültiges 
Signal
betrachtet... wohlgemerkt es war nicht für KFZ-Einsätze ausgelegt. Sowas 
im KFZ zu benutzen zu wollen ist schon fast unmöglich.
Bordspannungen von Autos sind einfach zu dreckig.

Glücklicherweise geht es ja darum die Heckklappe zu öffnen... Das ist 
wärend der Fahrt nicht so schlimm als wenn es die Motorhaube wäre.
Kein Scherz, das habe ich schonmal ausgiebig belachen müssen als ich sah 
wie jemand eine Fernsteuerung benutzt hat um die Motorhaube "hydaulisch" 
zu öffnen... Da war hoffentlich kein Modul drin das bei 0.1V schon 
anspricht.

Grüße
Björn

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im C-Modell des MercedesKombi z.B. ist das gang und gebe.
Blöde nur wenn man während einer Netzwerkinstallation im 10.Stock eines 
BüroRohbaues (noch kein Fahrstuhl, nur "Bautreppe") das seinen Kollegen 
zeigen will und dann die zehn Stockwerke wieder runter muss, um die 
Klappe händisch zu schliessen, weil DAS konnte der Mietwagen damals noch 
nicht.

Die Baugruppe ist schon für den KFZ-Einsatz gedacht, wenn man mal bei 
Smartkits.de nachsieht. Ob nun Heckklappe oder Zentralverriegelung ist 
ja wurscht.

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Axel Rühl wrote:

> Die Baugruppe ist schon für den KFZ-Einsatz gedacht, wenn man mal bei
> Smartkits.de nachsieht. Ob nun Heckklappe oder Zentralverriegelung ist
> ja wurscht.

Hallo Axel

Mag sein, aber das was der OP da hat ist ganz bestimmt nicht eine 
Baugruppe für den KFZ-Einsatz, die bei 0.1V schon schaltet.
Da sind wir uns doch bestimmt einig.


Grüße
Björn

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
doch ist alles für kfz!

das problem:

diese beleuchtungsverzögeung ist dafür gedacht über den 
türkontaktschalter sein schaltsignal zu beziehen, das heißt im klartext 
-> entweder 0 oder -12V da der schalter masseseitig sitzt.

Meine Funkfernbedienung wo ich den komfortausgang (einzelne taste auf 
der fernbedienug) (zb heckklappenstellmotor o.ä.) (massesignal)dazu 
verwenden will die innenbleuchtung anzustellen und durch die 
verzögerunsschaltung automatisch wieder ausgeht.

das klappt auch alles prima aber!!
die funkfernbedienungseinheit ist nicht auf schaltungen sondern auf 
stellelemente ausgelegt und daher nicht so präzise gebaut, sage ich mal.

denn dem stellelement ist das egal ob da bis zu 1 v im ruhemodus 
anliegen das schaltet erst ab 12 v durch.

und meine schaltung erkennt die kleinen spannungenaber schon als die 
schaltspannungen da die nur aus ein / aus ausgelegt ist, die denke das 
die 0.1-1 v schon ein ist. und daher will ich irgendwas das die spannung 
bis ca 10v sperrt sodass nur das eigendliche schaltsignal von 12 v 
durchkommt.

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alex wrote:
>
> und meine schaltung erkennt die kleinen spannungenaber schon als die
> schaltspannungen da die nur aus ein / aus ausgelegt ist, die denke das
> die 0.1-1 v schon ein ist. und daher will ich irgendwas das die spannung
> bis ca 10v sperrt sodass nur das eigendliche schaltsignal von 12 v
> durchkommt.

Du hast doch jetzt genug Beispiele für das Problem bekommen.
Probier die doch erstmal aus.

Grüße
Björn

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Björn Wieck wrote:
> Axel Rühl wrote:
>
>> Die Baugruppe ist schon für den KFZ-Einsatz gedacht, wenn man mal bei
>> Smartkits.de nachsieht. Ob nun Heckklappe oder Zentralverriegelung ist
>> ja wurscht.
>
> Hallo Axel
>
> Mag sein, aber das was der OP da hat ist ganz bestimmt nicht eine
> Baugruppe für den KFZ-Einsatz, die bei 0.1V schon schaltet.
> Da sind wir uns doch bestimmt einig.
>
>
> Grüße
> Björn

Ja klar. Sind wir.

Was die denn da fürn Sch** verkaufen, deshalb hatte mich die Schaltung 
von dem Bausatz/Baugruppe interessiert.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Axel und Björn
ich vermute mal, der OP hat noch gar nicht genau genug festgestellt 
(feststellen können - hat er einen Oszi?), wie groß seine Störungen 
tatsächlich sind. An eine Reaktion bei schon 0.1V kann ich nicht so 
recht glauben ...

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich auch nicht.
Ich würde das ganze schön niederohmig einkoppeln und in dem Moment, wo 
geschaltet wird ruhig 50 oder sogar 100mA fließen lassen.
Dann hat sich das mit den Störungen auch erledigt.
In welche Richtung und von wo nach wo kann ich ohne Schaltung nicht 
sagen ;-))

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.