www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit MAX232


Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich hab nen Problem mit meinem Max232. Und zwar habe ich alles 
angeschlossen, und dobald ich das Kabel zum Computer anstecke, messe ich 
eine Spannung von 9V zwischen RX/TX und Ground des µC's. Wenn ich was 
sende kommt auch nix an. Teils kommt sogar das Gesendete wieder vom PC 
an sich selbst zurück. Eine ne Ahnung, woran das liegen kann? MAX 
kaputt? Kondensatoren kaputt? Ich hab den Max bis jetzt nur ein mal 
verwendet. und da hat er funktioniert.

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du auch Pin 16 +5V und Pin 15 Gnd richtig angeschlossen. Sieht 
danach aus das MAX232 keine richtige Masse verbindung hat.

Gruss Helmi

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ist alles Korrekt angeschlossen. An 16 habe ich VCC und am 15 Ground 
das ganze kommt aus dem PC (USB) hab auch nachgemessen das sind ziemlich 
exakt 5V.

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
an Quarzen etc kanns nicht liegen...ich hab auch schon mal Geräte 
angeschlossen, die Ebenfalls via RS232 kommunizieren und da ging auch 
nix...

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn du alles richtig angeschlossen hast und die Spannungen am 
MAX232 in ordnung sind (versorgung b.z.w. negative versorgung (-10V) am 
Kondensator an PIN6 und Positive (+10V) an PIN 2 dann hast du entwerder 
auf deiner Leiterkarte ein Schluss oder der MAX232 ist defekt . Hast du 
die 9V auch dann wenn du den PC abziehst ? . Ganz dumme Frage nicht boes 
sein: Hast du Transmitter In und Transmitter Out beim MAX232 verwechselt 
?

Gruss Helmi

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also 9V sind weg, wenn ich das PC Kabel abziehe...Die Spannungen am 
Kondensator mess ich mal nach. An 11 und 12 habe ich das Zielgerät und 
an 13 14 den PC.

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann ist die Schaltung so korrekt.
Jetzt koennte noch eine ungewollte verbindung von PIN 13 nach PIN 12 
vorhanden sein. Wenn du den MAX232 gesteckt hast ziehen ihm bitte raus , 
steckt den PC an und miss noch mal ob da irgendwo 9V am uP anliegen. 
Falls das nicht der Fall ist ist mit hoher wahrscheinlichkeit dein 
MAX232 defekt.

Gruss Helmi

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An den Kondensatoren liegen 0,4 und 6,8V an...scheint was nicht OK zu 
sein...

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An welchen Kondensatoren (PIN). Bedenk auch das du die Spannungen an den 
Kodensatoren an PIN 1,3,4,5 nur mit einem Scope messen kannst (Rechteck 
signal)

Gruss Helmi

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An Pin 15 die 0,4 und 16 die 6,8

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PIN 15 ist GND also 0V , PIN 16 = VCC also +5V.
Kann das seine das deine +5V Versorgung schon nicht in Ordnung ist ?

Gruss Helmi

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also An VCC Messe ich 5,04V

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gerade noch sagtes du das du an PIN 16 (VCC) 6.8V misst ?

Gruss Helmi

Autor: Lucas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok war doch ein Problem...die Spannung ist nicht richtig angekommen von 
der USB Schnittstelle...jetzt gehts!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.