www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LPC2138 läuft nicht mehr


Autor: Mark .. (mork)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein LPC2138 hat nach einem halben Jahr zuverlässiger Arbeit den Geist 
aufgegeben ohne dass die Hardware geändert wurde.

Ich wollte mal die IAP-Funktionen des Bootloaders ausprobieren, um den 
Flash zu beschreiben. Beim ersten Versuch hängte sich der Controller 
auf, als die Routine aufgerufen wurde, um eine Seite zum schreiben 
vorzubereiten obwohl ich genau nach dem Datenblatt vorgegangen bin. Nach 
einigen erfolglosen Versuchen fing er plötzlcih an, sich bei jedem 
zweiten oder dritten Einschalten so um den Faktor 500 zu verlangsamen 
(man konnte sehen, wie die Grafik auf dem Display Stück für Stück 
aufgebaut wurde). Auch der Bootloader fing an zu spinnen und lies sich 
ca jedes 15ste mal ansprechen, wobei er häufig beim Flashen abstürzte. 
Nach einiger Zeit klappte dann überhaupt nichts mehr.

Die Akkus wahren frisch geladen und die Schaltung wurde auch nicht 
geändert. Einen Oszilloskop habe leider nicht. Was kann da losgewesen 
sein??? Ist sowas ähnliches schon mal jemandem passiert?

MfG Mark

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja so änlich... als ich zum ersten mal das LPC2378 board in betrieb 
nahm.
Aber es war bei mir das Steckernetzteil das eine etwas zu kleine 
Spannung hatte, und somit kam im 50Hz takt der Reset. Ohne Osczi hätte 
ich es nie gefunden.
Ja schau und überprüfe mal deinen Oszillator ob der eine Macke hat ?
Die Spannungsregler (Core..) usw.
Oder hast du den Chip mit einer elektrostatischen Entladung geschädigt ?
Aber mann muss auch wissen, dass beim Flaschen der chip intern eine 
Spannung erzeugen muss, und somit eine höhere Stromaufnahme hat, 
vieleicht hat er sich auch selbst geschädigt. Hatte das Problem mal mit 
anderen Flash Kontrollern, wenn man zu lange im aktiven Flash-Mode stand 
wurden die heiss bis zur eigenen Zerstörung.

Autor: Mark .. (mork)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sascha,

danke für die Hinweise.

Einen Oszi habe ich wie gesagt leider nicht. Ob der Controller heiß 
wurde, kann ich auch nicht sagen, da ich darauf nicht geachtet hatte. 
Ich hab mal einen neuen Quarz reingemacht, hat aber nix geholfen. 
Elektrostatische Endladung ist unwahrscheinlich, da man man nur selten 
an die Pins kommt und das Modul schon einiges ausgetragen hat. So wie's 
aussieht muss ein neuer Chip her.

MfG Mark

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.