www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MC34063 will nicht so recht


Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hey!

ich möchte mir hier aus 3 AA batterien 7.0V zaubern.  ich wollte den 
rechner von nomad.ee benutzen um die werte der einzelnen komponenten zu 
bestimmen, aber leider kann ich nur mit den ersten eingabefeldern was 
anfangen: Vin, Vout, Iout.

für Vout 7V und Iout 300mA (damit ist wohl nur ein maximalwert gemeint?) 
bekomme ich trotz alledem folgende werte:

Rsc=0.234 Ohm
R=180 Ohm (180 hatte ich nicht im haus, deshalb sinds bei mir 150)
R1=3.9k
R2=18k

wie die drei kondensatoren und L zu bestimmen sind weiss ich leider 
nicht, deshalb musste ich einfach irgendetwas aus anderen schaltungen 
übernehmen:

Co: 470uF
kondensator, der bei Vin gegen masse geht: 100uF
Ct: 1,5nF
L: 330uH (festinduktivität)

ihr merkt schon - ich bin nicht sehr advanced, deshalb natürlich kommt 
hier jetzt das problem:

Vin: 4.8V --> Vout: 3.6
Vin: 3.2V --> Vout: 2.2

das ist halt leider nicht das, was ich wollte...

woran kanns liegen?

danke euch schonmal
hans

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeig mal deine Schaltung, irgendwas hast du falsch aufgebaut.

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast du denn fuer f und ripple eingegeben ?

Also Ich habe fuer Iout = 300mA , Vin = 4.5V , Vout = 7V
und fmin = 25Khz und Vripple = 100mV eingegeben

Ausgabe:
RSC = 0273 Ohm
R = 180 Ohm
R1 = 3.9K
R2 = 18K
Ct = 725pF
Co = 489uF
Lmin = 58uH

Hast du die Schaltung auch so aufgebaut wie angegeben ?

Gruss Helmi

Autor: Hansi Cardell (honsey)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
da ist meine schaltung angehängt wie ich sie auf dem breadboard 
aufgebaut hab...

Autor: Hansi Cardell (honsey)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
... und hier das ganze schematisch

(entschuldigt die miserable qualität)

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spule ist für 0,3A nicht geeignet. Außerdem wäre ich mit einem 
Steckbrett vorsichtig. Deine Leitungen sind alle etwas lang für einen 
Schaltregler. Versuche die Leitungen rund um die Spule, und die GND 
Leitungen möglichst kurz zu halten,

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke benedikt!

die werte die helmi oben angegeben hat. was hat es damit auf sich? Fmin 
und Vripple - wenn ich wüsste, dass diese Werter für mich ok sind, würde 
ich es einfach mal auf lochraster bauen.

aber abseits davon: müsste es nicht zumindest annähernd funktionieren, 
wenn alles richtig gesteckt ist?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitte KEINE 400x als Diode verwenden! Das muss eine schnelle Schaltdiode 
oder besser noch Schottkydiode sein! Versuchs mal mit ne 4148 zum 
probieren (die schafft nur 200mA). Schaltregler auf Steckbrett ist 
bisweilen kritisch. Deine  Dimensionierung ist soweit OK. Allerdings 
sollte der Ausgangskondensator kein normaler ELKO sein, die verkraften 
die hohen Schaltfrequenzen nicht wwirklich. Da muss ein LOW ESR Typ 
rein.

MFg
Falk

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:
> Bitte KEINE 400x als Diode verwenden!

ursprünglich wollte ich eine 1N58xx oder eine BYV10-40 verwenden, aber 
bei conrad hat man mir dann eine SB130=140 gegeben... passt das?

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
erste entwarnung ... ich habe 7V .. houston wir haben SIEBEN VOLT!

es lag an Rsc... falschen widerstand dringehabt

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Honsey Kk (honsey)

>bei conrad hat man mir dann eine SB130=140 gegeben... passt das?

Passt.

>erste entwarnung ... ich habe 7V .. houston wir haben SIEBEN VOLT!

Rodger, Eagle 1 ;-)

MFG
Falk

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dank eurer hilfe läuft es jetzt schonmal alles - das ging ja doch 
schneller als erwartet: DANKE!

jetzt noch ein paar fragen:

1) was genau bedeuten denn Fmin und Vripple, die man ja auch angeben 
muss, wenn man das design der schaltung ausrechnen will?

2) warum muss man Iout spezifieren?

3) ist es normal, dass, wenn ich meinen 120mA verbraucher an die 7V 
hänge da gleich mal zarte 5V draus werden?

Autor: Defender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.nomad.ee/micros/mc34063a/index.shtml

(zu 1.)

gib da mal ein:
Vin 3V
Vout 7V
Iout 300mA <- - - ( zu 2.) Iout übersteigt 1500mA !!!
Vripple 40mV
Fmin 50kHz

Ergebnis:
Ct=550 pF
Ipk=1920 mA
Rsc=0.156 Ohm
Lmin=14 uH
Co=928 uF
R=180 Ohm
R1=3.9k R2=18k (7.02V)

Fmin = minimale Frequenz (kannst bis 100kHz eintragen)

Vripple = 40mV (schwankt deine Spannung um diesen Betrag)
Wenn du mal probierst (Vripple änderst) ändert sich nur die Größe des 
Ausgangskondensators!


( zu 3.)

Wird dein MC34063 warm?
Der verträgt den hohen Strom nämlich nicht.
Deshalb nimm lieber einen externen Transistor, außerdem ist der 
Wirkungsgrad mies weil an dem internen Transistor 1V abfällt (von den 
3V)

Man kann auch einen Treiber und nen Mosfet nehmen.
Kannste ja mal probieren :-)

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Defender wrote:
> http://www.nomad.ee/micros/mc34063a/index.shtml
>
> (zu 1.)
>
> gib da mal ein:
> Vin 3V
> Vout 7V
> Iout 300mA <- - - ( zu 2.) Iout übersteigt 1500mA !!!
> Vripple 40mV
> Fmin 50kHz
k - du meinst Ipk übersteigt 1500mA. heisst das, dass ich z.B. meine 
batterien nicht soweit leersaugen kann, weil dann Vin zu klein wird und 
Ipk diese 1500mA übersteigt.

was bedeutet das dann konkret - raucht mir der ic ab?


> Fmin = minimale Frequenz (kannst bis 100kHz eintragen)
>
> Vripple = 40mV (schwankt deine Spannung um diesen Betrag)
> Wenn du mal probierst (Vripple änderst) ändert sich nur die Größe des
> Ausgangskondensators!
für welchen anwendungsfall will man denn, dass da etwas schwingt? ich 
möchte nur 7V aus ein paar batterien pressen!

> ( zu 3.)
>
> Wird dein MC34063 warm?
> Der verträgt den hohen Strom nämlich nicht.
MC wird nur ganz leicht warm - kaum spürbar.
L wird ein bisschen warum - spürbar.
kurz vorm exitus wurden auch meine batterien ein bisschen warm. aber 
auch nur ganz subtil...

> Deshalb nimm lieber einen externen Transistor, außerdem ist der
> Wirkungsgrad mies weil an dem internen Transistor 1V abfällt (von den
> 3V)
>
> Man kann auch einen Treiber und nen Mosfet nehmen.
> Kannste ja mal probieren :-)
ich verstehe nur "bahnhof" :)

ich brauche unbedingt diese 7V um meine sensorheizung zu betreiben. 
300mA sollten ja eigentlich kein problem für den MC sein, oder?

danke für deine anregungen!

Autor: Der Dude (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>kurz vorm exitus wurden auch meine batterien ein bisschen warm.

Das wundert mich nicht:

300mA bei 7V: 2.1 W

2.1W bei 4.5V und ein bisschen Verlusten: ca. 500 mA

Ob das die Batterien lange machen?

Autor: Defender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Defender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lies das Datenblatt:
http://www.alldatasheet.net/datasheet-pdf/pdf/1343...

Einfach nur noch einen NPN-Transistor ran,
Widerstand von der Basis nach Masse und vom Ausgang einen zur Basis...
Also nen Darlington transistor machen ;-)

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, danke. werd das nachher mal probieren. das katapultiert mich dann in 
welche bereiche (was die ausgangsleistung angeht)?

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe jetzt mal einen BC547 in meine schaltung gebaut ... jetzt habe ich 
nurnoch 0.7V Vout...

Autor: Patrick S. (kof)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der ist etwas schwach wenn du 2W am ausgang ziehen willst :)

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für den hinweis!

momentan habe ich aber garnicht meine heizung angeschlossen. die 
schaltung bringt im leerlauf 0.7V...

Autor: Defender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1.)
Such dir mal das Datenblatt von dem BC547, du hast da bestimmt etwas 
falsch angeschlossen.

Wenn du auf die Zeichnung im Datenblatt schaust ist das von unten 
(Bottom) oder von oben (Top) ?
Wenn du von unten auf den BC547 schaust kannst du die Beinchen sehen, 
von oben nur die schwarze, rundliche Fläche.

Auf einem Steckbrett ist das ja einfach zu korrigieren ;-)

2.)
Der BC547 kann nur 100mA schalten!
Musst schon einen nehmen der 3A oder so kann.

3.)
Du musst dir den Widerstand von Basis (Emitter des internen Transistors) 
nach Masse berechnen .. oder probieren.
Wenn der groß ist (10k Ohm) nutzt du ja den internen nicht mehr, der 
kann aber bis zu 1,5A schalten.
http://www.elektronik-kompendium.de/sites/slt/0411221.htm

4.)
Wenn du es etwas aufwändiger magst mach das mit einem Mosfet.
Vorteil: keinen Spannungsabfall zwischen Drain und Source

Autor: Hansi Cardell (honsey)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich habe jetzt meine schaltung nochmal neu aufgebaut  - mit neuen 
teilen, nach euren tipps & hinweisen.

sieht sehr gut aus jetzt - ich will eigentlich nurnochmal abklären, dass 
das alles koscher
ist :)

L: 22uH Drossel, kann 530mA ab, R 0.85Ohm
Co: 1500uF LowESR Elko, 16V
Ct: 470pF, Keramik

Diode: SB130, 1A

R: 180Ohm, 0.6W
Rsc: 0.145Ohm (0.22Ohm + 0.43Ohm parallel)
R1: 3.9kOhm, 0.6W
R2: 18kOhm, 0.6W


hier sind die errechneten werte:
Ct=550 pF
Rsc=0.156 Ohm
Lmin=14 uH
Co=928 uF
R=180 Ohm
R1=3.9k R2=18k


im leerlauf schwankt die spannung unregelmässig zwischen 7.03 und 7.05, 
wenn ich jetzt meinen verbraucher (heizung) dranhänge fällt es kurz ab 
auf 6 V und steigt von dort dann wieder auf ca 6.97V (und schwankt dort 
dann wieder um 0.02V).

dabei werden spule und mc34063 ziemlich heiss, aber noch so, dass man 
sie dauerhaft anfassen kann. (das macht mir ein bisschen sorgen...) 
alles andere bleibt kalt.

also nochmals danke an alle, die mir hier geholfen haben!

wo könnte ich noch etwas verbessern? die sache mit dem npn-transistor 
klappt bei mir leider nicht. da bekomm ich nur 5V spannung, die auf 4V 
abfällt bei belastung...

schönen abend!
honsey

Autor: Defender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hast du für einen NPN-Transistor genutzt und wie hast du ihn 
beschaltet?
Also bei mir geht das!

Das Problem bei einem Transistor, der heiß wird ist: der Spannungsabfall 
über den Transistor steigt.
Das heißt dass deine Schaltung ineffizienter wird, je heißer dein 
Transistor.

Mein Transistor hat sogar einen Kühler spendiert bekommen, damit da so 
wenig wie möglich Spannung abfällt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.