www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit dem AD595 (Thermoelement Typ K)


Autor: Jenny Ge (jenny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich versuche seit 3 Wochen die Spannung eines K-Elementes zu verstärken 
und mit einer Messkarte aufzuzeichnen.

Das Aufzeichnen ohne Verstärkung führte zu keinem Erfolg. Die 
Übertragung des Signales in meinem Gerät führt über 3 Kaltstellen. 
Sobald sich die Temperatur dort ändert, kommt es zu falschen Messwerten.

Im Forum bin ich auf den AD595 aufmerksam geworden. Den hab ich bestellt 
und aufgebaut. Zuerst habe ich Messungen mit einem Thermometer im Ölbad 
durchgeführt. Der IC soll 10 mV/°C erzeugen, erzeugt aber nur 5 
Mikrovolt / Grad. Ist nicht so schlimm, linear ist er jedenfalls.

Nun kommt mein Problem: schließe ich den Ausgang an die Messkarte (Fa. 
Meilhaus) an, bricht die Spannung zusammen. Habe alles nochmals 
aufgebaut - gleicher Fehler.

Hier im Forum wurde der IC immer mit "da ist alles drin" beschrieben, 
nur leider funktioniert er bei mir nicht. Das heißt ich hatte 3 Stück 
bestellt und alle drei probiert.

Ich muss noch erwähnen, dass ich nicht die Kondensatoren angeschlossen 
habe, da ich keine zur Hand habe (RS ist zur Zeit nicht online).

Kennt jemand dieses Problem, oder ahnt woher es rührt? Oder könnt ihr 
mir eine andere Schaltung mit Kaltstellenkompensation empfehlen? Dazu 
hier meine Spezifikationen:
Umgebungstemperatur IC: bis +125°C
Messbereich: 20-250°C

Ich hoffe auf schnelle Hilfe, der Wettbewerb findet bald statt.
Viele Grüße, Jenny.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Der IC soll 10 mV/°C erzeugen, erzeugt aber nur 5
>Mikrovolt / Grad. Ist nicht so schlimm, linear ist er jedenfalls.

5uV? Wenn das nicht so schlimm ist, würde mich die Auflösung deiner 
Messkarte interessieren...
Ein Thermoelement vom TypK erzeugt selbst schon etwa 40uV/K

>Ich muss noch erwähnen, dass ich nicht die Kondensatoren angeschlossen
>habe, da ich keine zur Hand habe (RS ist zur Zeit nicht online).

Wenn Bauteile im Datenblatt angegeben sind, sollte man sie auch 
verwenden, umsonst sind sie meist nicht.
Aus eigener Erfahrung auch mit selbst aufgebauten 
Instrumentenverstärkern, weiss ich, dass die Verstärkung in dem Bereich 
nicht einfach ist, der AD595 jedoch sehr gut arbeitet. Wichtig ist 
jedoch das man sich bei der Verdrahtung an die Angaben im Datenblatt 
halten sollte.

Ansonsten wäre es hilfreich, wenn du noch einen Schaltplan deiner 
Schaltung hättest, um weitere Probleme ausschließen zu können.

Gruß Markus

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte zum Testen 3 Stk bei reichelt bestellt und die waren alle 
defekt.

Danach noch mal 2 bei RS geordert, funktionierten wie eine eins.
Vielleicht geht es Dir ja ähnlich; ich war zumindest sehr verzweifelt.

Gruß Sven

Autor: Jenny Ge (jenny)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ihr beiden,

ich meine natürlich 5 mV/°C, sorry.
Folgende Angaben beziehen sich auf das Datenblatt (siehe Anhang, Quelle:
http://www.datasheetcatalog.net/de/datasheets_pdf/...)

Ich bin mir nicht sicher, wass die Kondensatoren bewirken:
"The AD594/AD595 is internally frequency compensated for feedback
ratios (corresponding to normal signal gain) of 75 or more.
If a lower gain is desired, additional frequency compensation
should be added in the form of a 300 pF capacitor from Pin 10
to the output at Pin 9. As shown in Figure 5 an additional 0.01 mF
capacitor between Pins 10 and 11 is recommended."

Aufgebaut habe ich die Schaltung nach Seite 3 (Single Operation) mit 
+5..10V und Masse.

Sven, "verzweifelt" - das bin ich derzeit auch. Ich muss dazu sagen, 
dass der eine drei ICs schon vor einem halben Jahr gekauft wurde. Das 
heißt, ich schließe einen Fehler aus.
Kannst du mir mal bitte deine Konfiguration geben (Single Mode?, 
Spannung,...)?

Viele Grüße, Jenny.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aufbau war nach Figure 1 im Original Datenblatt.

http://www.analog.com/UploadedFiles/Data_Sheets/AD...

Betrieb mit 5V und dann gemessen mit 12Bit-AD Wandler + Atmel Mega32.
Test ist ungefähr 1,5 Jahre her.
Wenn Du sicher bist, das das laufen muss, würde ich mir noch mal von 
einem anderen Lieferanten den Baustein besorgen.
(btw. RS Webseite läuft bei mir)

Gruß Sven

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie soll das möglich sein?

Anforderung:
Umgebungstemperatur IC: bis +125°C

Im Datenblatt steht:
designed to be used from 0°C to +50°C

Da die Kaltstelle (Übergang von Thermoelement auf Kupfer) direkt am IC 
sein muss ist das wohl für diesen Zweck nicht einsetzbar.

Autor: Duck und weg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Umgebungstemperatur 125 Grad ist auf der extremen Seite. Weshalb so hoch 
?

Autor: jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

vielen Dank erst einmal für die vielen Antworten und Mithilfe!

@ Dieter:
bei rs ist die Betriebspannung von -55 bis 125°C angegeben (Datasheet + 
Homepage). Ich weiß nicht, wie warm mein Gerät wird - daher wollte ich 
zunächst das maximal mögliche ansetzen. Es würde sicher auch 80°C gehen.

@Sven:
ich werde mir die ICs bestellen. Bis dahin probiere ich aus Zeitnot noch 
mit den alten. Ist bei dir vorher auch die Spannung zusammengebrochen? 
Wie siehts aus, hastest du 10mV/°C ?

Was ist mit anderen Schaltungen? Falls ihr es schon gemerkt habt, ich 
bin keine Elektrikerin. Welche andere IC-Hersteller gibt es noch, bei 
denen ich mal suchen könnte?

Viele Grüße, Jenny.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ist bei dir vorher auch die Spannung zusammengebrochen?

Nein (es gab nie einen Wert am Ausgang (also immer 0Volt))

>Wie siehts aus, hastest du 10mV/°C ?

Ja. Mit den laufenden Bausteinen, ja.

> Was ist mit anderen Schaltungen? Falls ihr es schon gemerkt habt, ich
> bin keine Elektrikerin. Welche andere IC-Hersteller gibt es noch, bei
> denen ich mal suchen könnte?

Als Tip noch: ESD Schutz. Du solltest schon wissen das diese Bauteile
empfindlich gegen Überspannung sind...

Ich empfehle, da Du sagst das Du nicht so viel Ahnung von der Materie 
hast,
ein Modul einzukaufen.
Das gibt es komplett fertig als Wandlermodul. ca. 100Euro.
Das hat auf der einen Seite ein Thermoelementeingang und auf der anderen 
Seite zb. 0-10V Ausgang. Das einfach mit einem Spannungsteiler auf 0-5V 
und schon kannst Du messen bis der Arzt kommt.

Ist als Vorschlag gemeint,

Gruß Sven

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das würd ich glatt machen, jedoch ist das Gerät viel zu groß! Es muss 
schon bei IC Größe liegen.

ESD ist klar, habe Armband. bei mir kommen nur 5mV/°C an, ich denke da 
liegt der Fehler.

Grüße, Jenny.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> das würd ich glatt machen, jedoch ist das Gerät viel zu groß! Es muss
> schon bei IC Größe liegen.

war halt eine Idee, weil Du mit PCI Messkarte arbeitest
und das ist ja nicht wirklich klein.

Gruß Sven

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
btw: Was hälst Du davon:

MAX6675    Thermocouple-to-digital converter with 12-bit, 0.25°C 
resolution from 0°C to +1024°C;

Muss halt noch ein µC dran.
Aber vielleicht sagst Du mal noch ein paar Randbedingungen,
dann kann man vielleicht noch eine genialere Lösung vorschlagen.

Gruß Sven

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wir setzen den AD595 von Reichelt laufend ein. Kein Problem.
Weil wir bis ca. 1000°C messen nehme ich 10V oder 12V 
Versorgungsspannung, wobei ich die Ausgangsspannung über einen 
1:2-Spannungsteiler an den ADC meines uC lege...
keine Probleme !

Du hast den TC nah an die beiden Pins des AD595 angeschlossen/angelötet 
?
Alle externen R's und C's sind nur zum nachträglichen Abgleich, aber die 
teuren ICs werden im Werk schon abgeglichen...

Ich lege den -IN (Pin14) über 4,7K gegen Masse.
Pin 4,7,13 direkt an Masse,
Pin 11 an 12V
Pin 8 und 9 verbinden - Ausgang.
Mehr braucht es nicht !

Ein Multimeter mit etwas mehr Genauigkeit (!) kann schon helfen !

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

vielen Dank ersteinmal!

@Sven:
Was mache ich dann mit dem µC (Mikrokontroller?)? Ich denke ich brauch 
den nicht, da ich eine Meilhaus ME 2600 Messkarte habe, oder verstehe 
ich dich falsch?

Randbedingungen sind:
max. Durchmesser 1mm, feuchte Umgebung

Daher schließe ich Pt1000 oder Pt10000 aus.

@Bernd:
Du benutzt also auch einen µC. Mit dem Spannungsteiler verdoppelst du 
die Spannung, richtig?

Was meinst du mit "Ich lege den -IN (Pin14) über 4,7K gegen Masse."

Die Multimeterbezeichnung suche ich morgen mal raus.

Viele Grüße, Jenny.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also meine Erfahrungen mit dem AD595 sind nicht die besten.
Der hat zwar nen Differenzeingang, aber ist trotzdem sauempfindlich 
gegen Netzbrummen und andere Störungen.

Und eine PC-Meßkarte ist warscheinlich supergut als Störquelle geeignet.

Um da brauchbare Ergebnisse zu kriegen, muß die Meßkarte einen 
galvanisch getrennten Eingang haben.

Die Versorgung des AD595 muß natürlich auch super sauber sein, also kein 
PC-Netzteil!

Das Thermoeelement sollte isoliert sein und nur an GND des AD595 geerdet 
sein.

Die Typ-K Anschlußbuchse muß sich direkt am IC befinden, sonst 
funktioniert die Kaltstellenkompensation nicht.


Es ist nicht ganz einfach, eine gut funktionierende 
Thermoelementemeßsschaltung aufzubauen.
Selbst zwischen Versuchsschaltung auf Rasterplatine und fertiger 
SMD-Platine ergab sich ne deutliche Verbesserung.


Peter

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jenny wrote:

> ESD ist klar, habe Armband. bei mir kommen nur 5mV/°C an, ich denke da
> liegt der Fehler.

Dann ist Dein Sensor wohl kein Typ-K, sondern ein anderer.


Peter

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jenny:

Du hast Recht, der Vorschlag mit dem MAX6675 war als alternative 
gedacht.

Beispiel: Thermoelement <> MAX6675 <> µC <> USB <> PC

Dann würde es ohne Messkarte funktionieren.
Muss aber alles an Elektronik aufgebaut werden.

---------

Noch mal zu dem Messwandler:
Dies kann man relativ einfach erst mal zum Laufen bringen:

Du verwendest einen PC. (der ist sehr gross)
Was spricht dagegen ein Modul in Handgrösse zu verwenden,
das in ein Gehäuse geschraubt werden kann, zusätzlich eine
Stabilisierte Spannungsquelle und dann ein Verbindung zum PC mit der 
Messkarte ?
(ich verstehe das Argument zu gross einfach nicht, da Du ja einen PC 
verwendest, und für den AD595 brauchst Du ja auch 5V und eine
Platine mit Gehäuse und Klemmen...)

Also:

Thermoelement <> Messwandler <> PC mit Messkarte
                      |
                      |
                   24V DC (stabilisiert)

Gruß Sven


P.S.: Wie versorgst Du eigentlich den AD595 ? Also mit einem 
Steckernetzteil ? Festspannungsregler ? Oder speist Du den mit 5V vom PC 
?

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Sven und Bernd

ich habe hier:
http://www.datasheetcatalog.com/datasheets_pdf/M/A...

gesehen, dass der µC unerlässlich ist. Aber ich kann keine Anleitung für 
den 68HC11AB finden. Welche Funktion hat der? Wo schließe ich diesen an?

Ich denke, es ist kritisch, den Ausgang des AD595 nochmals zu 
verstärken. Ich habe es probiert (verschiedene) und es klappt nicht.

Bei www.datasheetcatalog.com sind auch noch Linear Technology ICs drin 
(Suchwort Cold Junction). Ich denke das Wort "matched" zeigt, dass nicht 
jeder Verstärker unterstützt wird.

Ich sehe folgende Alternativen zum AD595:
1.) MAX6675 und 68HC11AB
2.) AC1226 (Kompensator)
3.) LT1025 + LTKA*

* Quelle: http://www.ortodoxism.ro/datasheets/lineartechnolo...

Brauche ich für den AC1226 noch einen OPV?


@Peter,

ersteinmal vielen Dank für deine Tipps!

Ich weiß nicht, ob die ME 2600 einen galvanisch getrennten Eingang hat 
(zugegeben, ich weiß nicht was das ist). Kannst du mal bitte nachsehen:

http://www.meilhaus.de/fileadmin/upload/download/p...

Ich werde morgen mal nur an GND klemmen. Übrigens: einen Typ-K Stecker 
kann ich nicht verwenden, da dort kein Platz ist. Die Messtelle ist etwa 
30cm vom IC entfernt, das sollte gehen.

"bei mir kommen nur 5mV/°C an, ich denke da liegt der Fehler."
"Dann ist Dein Sensor wohl kein Typ-K, sondern ein anderer."

Ich habe zwei unterschiedliche Sensoren zweier Hersteller genommen, mit 
gleichem Ergebnis. Multimeter hat 100 DM gekostet, weiß aber aus dem 
Kopf nicht welches. Ich denke aber, dass der Eingangswert unabhängig von 
der Verstärkung ist. Ich habe ja die Kurve aufgezeichnet und per Excel 
die Funktion der Geraden bestimmt.

Bis dahin noch mal vielen Dank für eure Mühen!

Viele Grüße, Jenny.

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Sven:

wo bekomme ich eigentlich den MAX6675 her?

Ich habe reichelt, farnell, r+s und conrad als online-Versand Häuser 
ausfindig gemacht, kann den aber nicht finden.

Woher hast du den denn?

Viele Grüße, Jenny.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> wo bekomme ich eigentlich den MAX6675 her?

Bei Maxim kann man ein oder zwei sample als Student/in oder Firma 
anfordern.
Aber den kannst Du definitiv nicht einfach an die Messkarte 
anschliessen.
Dafür muss auch dann ein µC programmiert werden.

----

Bitte beschreibe doch mehr von den Randbedingungen und was Du überhaupt 
messen willst.
Du sagst Dein Thermoelement ist 30cm. Ganz oben erwähnst Du das dadurch 
vermutlich die Elektronik zu nah an die Wärmequelle herangeführt werden 
muss.

Es gibt also durchaus lange Thermoelemente. Wir setzen zb. auch mehr als 
3Meter Länge ein, die natürlich isoliert werden.

Da Du nicht auf alle Fragen auch was die Versorgungsspannung nach der 
auch Peter Danneger gefragt hast eingehst,
kommen wir nicht so recht weiter.

Und bitte warum nicht ein Messwandler Modul ?
(bitte mal auf meine Frage eingehen)

Posting vom:
Autor: Sven (Gast)
Datum: 10.01.2008 22:58

Gruß Sven

Autor: Jenny Ge (jenny)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mit einem Netzteil aus einem "Labor" (in das ich netter Weise rein 
darf). Ist sehr groß (wie eine Stereoanlage). Ich kann aber erst morgen 
nachsehen wie das Dingen heißt.

Hintergrund: Ich messe die Temperatur auf einer sich drehenden Scheibe. 
Das heißt dass ich über einen Schleifer von dieser runtergehen möchte. 
Die Spannung bekomme ich dadurch auch auf die Scheibe.

Viele Grüße, Jenny.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hintergrund: Ich messe die Temperatur auf einer sich drehenden Scheibe.
> Das heißt dass ich über einen Schleifer von dieser runtergehen möchte.
> Die Spannung bekomme ich dadurch auch auf die Scheibe.

Aha, und welche Anschlüsse führst Du genau über diese Schleifkontakte ?
Ich gehe davon aus das Du diesen Aufbau schon so verwendests oder ?

Gruß Sven

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ich weiß nicht, ob die ME 2600 einen galvanisch getrennten Eingang hat
> (zugegeben, ich weiß nicht was das ist). Kannst du mal bitte nachsehen:

Die Karte hat laut DB galvanische Trennung.
Seite 14 / 15. Das ist schon mal sehr gut.

Gruß Sven

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,

nein, derzeit gehe ich noch nicht über den Schleifring. Übrigens ist das 
Netzteil von Voltkraft (VC920). Vielen Dank für den Hinweis mit der 
galvanischen Trennung, habe heute nochmal nachgesehen und weiß jetzt 
auch was das ist.

Ich glaube ich habe mein Problem endeckt:
Bernd machte mich darauf aufmerksam dass dort noch ein Widerstand ran 
muss. Den habe ich bisher nicht angeschlossen. Würde erklären, warum ich 
nur 5mV/°C messe. Und wahrscheinlich auch, dass die Spannung 
zusammenfällt.

In der Bedienungsanleitung steht, dass beim Single Mode ein 50KOHM 
angeschlossen werden muss (Seite2, Note 4):
http://www.analog.com/UploadedFiles/Data_Sheets/AD...

Wie gehe ich vor, wie muss ich die Größe des Widerstandes bestimmen?

Viele Grüße, Jenny.

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Entschuldige aber ich verliere die Lust:

Das was Du vorhast (mit einer Scheibe (und was man sonst noch erraten 
muss) und dann mit einem Thermoelement messen ist nicht so einfach wie 
Du Dir das wohl vorstellst. Die Kontakte für das Thermoelement kann man 
nicht einfach über Schleifkontakte übertragen, genauso wenig die 0-5V 
Ausgangsspannung.
Die Fehler die beim Drehen erzeugt werden sprengen jeglichen Rahmen.

Es gibt sicher eine Lösung, aber da man nicht genau den Plan kennt,
wird das so mit dem Kenntnisstand nichts werden.
Entschuldige, aber ein VC920 ist ein Multimeter von Conrad aber kein 
Netzgerät mit dem Du die stabilisierten 5V für den AD595 erzeugst.

Suche Dir bitte jemanden der sich damit auskennt und Dir vor Ort Hilfe 
anbieten kann.

Ich bin sicher gewillt zu helfen, so wie andere hier, aber wir machen 
das alles in unserer Freizeit.
Und da Du Probleme mit Elektronik hast und kein Gesamtkonzept als 
Zeichnung
vorstellst habe ich das Gefühl das es einen Schritt vor und 4 zurück 
geht.

Gruß Sven

Autor: Jenny Ge (jenny)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,

ich verstehe dein Ärger. Habe gestern in der Schnelle geantwortet. Das 
VC 920 ist natürlich das Multimeter.

Dass die Übertragung mittels Schleifkontakt nicht einfach ist habe ich 
schon gemerkt. Ursprünglich wollte ich die Thermospannung über den 
Schleifring geben. Dabei kam nur Mist raus. Im Nachhinein ist mir das 
klar (Kaltstellen am Stator und Rotor, Rauschen vom Schleifring).

Nun kam die Idee, die Thermospannung vor der Übertragung mittels AD595AQ 
zu vergleichen und verstärken. Dabei würde der AD595AQ seine Spannung 
über Kontakte am Schleifring bekommen. Dadurch dürfte sich der Fehler 
verkleinern. Es gibt wohl Funkübertrager, das wäre noch besser. Aber die 
sind sehr sehr teuer.

Problem liegt glaub ich daran, dass ich den AD im Singlemode ohne 
Widerstand anschließe: Seite2 
http://www.analog.com/UploadedFiles/Data_Sheets/AD...

Anbei noch eine kleine Skizze vom Aufbau und Beschreibung der bisherigen 
Versuche:

ohne Schleifring:
 a) Messung mit Multimeter VC920:
    Die Spannung wird um 5mV/°C verstärkt
 b) Messung mit nochmaliger Verstärkung (z.B. HCPL 7840)
    Spannung bricht zusammen
 c) Messung mit Messkarte Meilhaus ME 2600
    Spannung bricht zusammen

Sofern ich über den Schleifring gehe (n=0), bricht die Sapnnung schon 
beim Ablesen mit dem Multimeter zusammen.

Ich glaube es muss an dem Widerstand liegen, der noch nicht in miener 
Schaltung drin ist. Was hat der für eine Funktion und wie bestimme ich 
diesen?

Da ich das Signal später über 10m übertragen möchte, wäre es schön die 
Spannung vom AD nochmals zu verstärken. Das hatte ich u.A. mit dem HCPL 
7840 probiert.

So, ich hoffe ich konnte die Informationslücke schließen.
Viele Grüße, Jenny.

Autor: Dirk S. (fusebit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es mit einer kleine µC-Schaltung mit Batterie auf dem Rotor und 
einer Übertragung per EasyRadio (Günstige Funkmodule)?

Autor: Sven (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe mir noch mal die Mühe gemacht eine Übersicht zu erstellen,
wie ich das Problem lösen würde.
Dieses Konzept berücksichtigt jetzt erst mal nicht den
Wissensstand von Dir.

Jetzt hat vor mir schon Dirk S. den Vorschalg mit einem Funkmodul 
gemacht.
Das habe ich als Vorschlag so auch schon in der pdf.
Da hat das Erstellen der Zeichnung etwas länger gedauert. ;-)

Gruß Sven

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dirk, hallo Sven,

den Platz für einen µC (wie bekommt ihr das µ-Zeichen eigentlich?) habe 
ich nicht und ich muss in diese Messkarte rein!

Sven, vielen Dank für deine Mühe. Du schreibst "AD595 oder ähnlicher 
Baustein" Zur Zeit sieht es so aus: wenn ich etwas an den AD595 ranhänge 
(außer Multimeter), dann bricht die Sapnnung zusammen. Also vermutlich 
auch wenn ich den µC ranhänge. Und Hauptproblem ist, dass ich in die 
Messkarte rein muss.

Das Problem mit dem AD595 wäre schon gelöst, wenn ich den Ausgang vom 
AD595 mit dem HCPL7840 oder ähnlichem verstärken könnte. Ich denke, es 
liegt am fehlenden Widerstand, aber wie bestimme ich die Größe? Oder 
nehme ich einfach 50kOHM, wie es im Datashett steht. Wieso hat Bernd 
Rütter nur 4,7K genommen?

Viele Grüße

Autor: Dirk S. (fusebit)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Willst Du sinnvolle Messwerte oder eine Anwendung die Deine Karte 
verwendet?
Wenn Du Platz für den AD595 hast, dann kannst Du da doch bestimmt die 
wenigen fehlenden Bauteile unterbringen, in SMD wird das winzig.

Mit welcher Software liest Du Deine Karte aus? Wieso nützt Dir ein 
digitaler Datenstrom über die serielle nichts?

Wenn Du unbedingt auf die Karte willst, dann benutzt Du halt einen DAC.

Aus meiner Sicht wirst Du nur dann sinnvolle Messwerte erhalten, wenn 
die Daten den Rotor digital verlassen. Ein Messsignal über 
Schleifkontakte zu führen ist nach meiner Meinung vollkommen 
unbrauchbar...

Autor: Tastatur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>wie bekommt ihr das µ-Zeichen eigentlich?)

Alt Gr + M

Autor: Jenny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven, ich gebe dir recht. Aber die Verwendung der Messkarte ist 
eine Randbedingung vom Anwender. Der zeichnet nämlich viele Werte mit 
mehreren dieser Karten auf. Das Programm was er benutzt unterstützt nur 
diese Messwerte.

Kannst du mir mal bitte einen "DAC" empfehlen?

Temperaturbereich: 20-240°C
Sofern die Schaltung mit noch unbekannten Widerstand (???) funktioniert:
Spannung K-Element: 0,798mV(20°C)..9,745mV(240°C)
Ausgangsspannung AD595AQ: 200mV(20°C)..2413mv(240°C)

Die Messkarte unterstützt nach Anhang A: 
http://www.meilhaus.de/fileadmin/upload/download/p...
einen Eingang von 0..10V (unipolar)

Das heißt ich brauche eine 4-fache Verstärkung.
Derzeit hatte ich ja den Optokoppler HCPL 7840 probiert.
Der HCPL 7840 hat nach S.1-253 Figure 4 
(http://www.datasheetcatalog.net/de/datasheets_pdf/...) 
eine 10-fache Verstärkung.

Kannst du mir einen "DAC" empfehlen?

Viele Grüße, Jenny.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Analogsignale über Schleifringe zu übertragen würde ich nicht 
machen.

Ich würde ne kleine Schaltung aufbauen (LCT2400, ATtiny25) und dann 
digital mit CRC übertragen. Die Übertragung kann per Stromerhöhung 
erfolgen, dann reichen 2 Schleifringe für VCC/Signal und GND.

Der LTC2400 kann direkt die Thermospannung einlesen, wenns nicht 
supergenau sein muß und der ATtiny25 mißt dann die 
Kaltstellentemperatur.

Man muß allerding noch ein Programm für den ATtiny25 schreiben.


Peter

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Peter:

> Ich würde ne kleine Schaltung aufbauen (LCT2400, ATtiny25) und dann
> digital mit CRC übertragen. Die Übertragung kann per Stromerhöhung
> erfolgen, dann reichen 2 Schleifringe für VCC/Signal und GND.

Sehr gute Idee, hatte ich noch gar nicht bedacht.
Trotzdem bleibt für mich ein ganz grosses Fragezeichen auf Grund der 
Messkarte.

Nach unseren Vorschlägen hat man einen wunderschönen digitalen Wert,
den man dann mit einem DAC wieder auf die Messkarte zuschneidert.
Zusätzlich muss man noch eine Referenzspannung erzeugen, die
dann wiederum vor der Messkarte angeschlossen ist und den DAC treibt.

@all
Sorry, aber dies hat doch nichts mehr mit Messen zu tun,
wenn man den Aufwand betreibt, um hinterher mit dem Umwandeln wieder 
einen zusätzlichen Fehler zu schaffen.

Da würde ich ja noch eher das Messprogamm mit Funktionen und oder 
weiteren Schnittstellen erweitern.

Gruß Sven

Autor: Letzter Versuch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven hat einfach recht.

Hier soll nicht sinnvoll gemessen werden, sondern wird nur Blödsinn 
fabriziert.

Schon einmal über ein IR-Thermometer mit Analogausgang nachgedacht?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.