www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Spannung von Schaltregler bricht ein, Drossel zu klein?


Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Ich habe einen Schaltregler für 8V mit einem LM2675-ADJ gebaut.
Leider bricht beim anschließen an die Anwendung (ca. 100mA) die Spannung 
auf ca. 6,5V ein und die LEDs flackern leicht.
Wenn nur eine LED und ein Multimeter angeschlossen sind, leuchtet die 
LED konstant und die Spannung stimmt.

Bedeutet das ich muß eine Drossel mit höherer Induktivität verwenden?
Benutze jetzt eine Fastron mit 150uH. Sollte ich dann besser 220uH 
verwenden.

Oder liegt der Fehler woanders?

Danke, Euer Klausi

Autor: mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Schaltplan mit exakten Bauteilbezeichnern wäre hilfreich. Sonst kann 
man dir schwerlich helfen.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan? Foto? Die maximale Drosselinduktivität ist im Datenblatt mit 
68µH angegeben.

Autor: Jörg B. (manos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessant könnte auch sein, von welcher Eingangsspannung geregelt 
wird.

Autor: Klausi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Hier der Schaltplan aus Eagle.
Eingangsspannung soll bei einer Anwendung 12V und bei einer Anwendung 
24V sein.

Bauteile sind:
LM2675M-ADJ
Diode 1N5819
Drossel L1 Fastron L-PISR 150uH
C2 Standard C 10nF
C3 Low-ESR ELKO 35V 68uF
C4 Low-ESR ELKO 35V 33uF
R3 Metallschicht 14kOhm
R4 Metallschicht 2,49kOhm

Danke für Eure Hilfe!

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist der Aufbau auch schön HF gerecht ? Also kurze Leiterbahnen usw. ?

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Benedikt: Jau, Leiterbahnen sind nicht länger als 4cm.

@ Travel Rec.: Wo steht denn das mit der max. Drosselinduktivität?
Auf Seite 13, Abbildung 7 sind doch auch 220µH in dem Graphen.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja - ist oberes Limit. 47µ sind als Standardinduktivität verwendet. 
Wie sieht denn Deine Spule überhaupt aus? Geometrie?

Autor: Jörg B. (manos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oberhalb von R1 steht +3,3V, an der Klemme dann 8V... was ist richtig?

Autor: Marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Jörg:

8V sind richtig. Das 3,3V scheint ein überbleibsel aus einer alten Eagle 
Schaltung zu sein...

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau so ist es. Danke Marco ;-)

Stand ja auch oben, 8V.

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Travel Rec.

Was meinst du mit Geometrie der Drossel?
Das ist diese hier:
http://www.reichelt.de/?;ACTION=3;LA=4;GROUP=B517;...

Hilft dir das weiter?

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das hilft. Es gibt ja 1000 Sorten von Induktivitäten und nicht jede 
eignet sich zum Bau von Schaltreglern. Die ist aber okay!

Autor: Severino R. (severino)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wir hatten auch mal ein Problem mit einer Drossel an einem LM2577 
(Aufwärtsregler).

Die richtige Auswahl der Drossel ist sehr wichtig. Wir hatten zuerst 
eine leicht erhältliche genommen und hatten Probleme. Schliesslich eine 
von NS im Datenblatt empfohlene genommen und es klappte!

Sehr wichtig ist der Widerstand DCR: er sollte möglichst tief sein.

Autor: mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Eingangselko scheint mir etwas klein. Ich wähle die immer so, dass 
der Eingangselko größer oder gleich dem Ausgangselko ist.
Einfach mal Testweise einen 220uF Becherelko aus einem kaputten Netzteil 
dranklemmen und dann schauen ob die Spannung noch einbricht.

Was mir zu den Elkos noch einfällt:
Impulsstrom! Diese Elkos müssen auch deinen Impulsströmen standhalten, 
es gibt da Unterschiede.

Autor: Torbven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was mir zu den Elkos noch einfällt:
>Impulsstrom! Diese Elkos müssen auch deinen Impulsströmen standhalten,
>es gibt da Unterschiede.

Er hat schon LOW RSR Typen genommen. Die Dimensonierung von L und C ist 
falsch gewählt.

Ich habe bei einer maximalen Eingangsspannung von 24V und max 7V/500mA 
folgende Werte ermittelt.

L = 330µH
C > 22 µF

Du solltest troitzdem zur besseren Ripple Up Spannung Unterdrückung 
einen 470µF oder 680µF Elko einbauen.

Wie jemand schon meinte LOW DSR L und LOW ESR C. Die Diode ist i.O.,aber 
eine MRBS240  MBRS220  MBRS340 wäre besser.

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mmh. Travel Rec sagt kleinere Induktivität, Torben sagt größere 
Induktivität. Hat evtl. noch irgendwer eine Meinung?

Ach ja, Torben, ich gehe von deutlich unter 500mA aus. Eher so um die 
100-150mA. Dann evtl doch eine kleinere Drossel?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Generell stört eine zu große Spule eigentlich nicht (solange sich nicht 
die parasitären Eigenschaften zu sehr bemerkbar machen.) Weiterhin 
erfordert ein niedrigerer Strom meist eine größere Spule und umgekehrt.

Dass ein Schaltregler mit einer zu großen Spule nicht funktioniert hat, 
habe ich noch nie erlebt, meist ist eine zu kleine Spule schuld.

Da die Bauteile ja schon einigermaßen passen gewählt sind, und ich jetzt 
mal davon ausgehe, dass die Schaltung richtig aufgebaut ist, würde ich 
doch nochmal das Layout prüfen. Vor allem da das Datenblatt bezüglich 
der Feedbackleitung schon auf einiges hinweist.
Wenn du schon schreibst, dass die LEDs flackern, dann schwingt die 
Regelung aus irgendeinem Grund.

Autor: Torbven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, ich habe gepennt und versehentlich LM2576 gelesen. Bitte mein 
Posting ingorieren.

Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Aaaalso das der Spannungseinbruch am Layout liegt halte ich für 
unwahrscheinlich. Layout verursacht normalerweise nur üble Spikes. Hast 
Du denn ein richtiges Layout oder das ganze auf Lochraster aufgebaut?

Dann zur Spule: Ich habe mal Dein Werte in die Simulation von National 
eingegeben, der empfiehlt mir 680uF. Und die Werte stimmen normal, was 
anderes auszuprobieren geht normal in die Hose.

4cm Leiterbahn insgesamt oder von Bauteil zu Bauteil. Zwecks Layout kann 
ich das hier empfehlen: http://www.national.com/an/AN/AN-1149.pdf

Im Anhang noch die Ergebnisse der Simulation.

Gruß

Gepi

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ui, 680µH, da liege ich ja ganz schön daneben.

Aber komisch ist das alles einwandfrei funktioniert solange nur eine LED 
am Ausgang hängt.

Kommt dann meine Schaltung dazu bricht die Spannung ein und die LEDs 
flackern...
Müsste die Drossel nicht umso größer sein desto kleiner der 
Ausgangsstrom ist?

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal ne doofe Frage, darf man evtl nicht einen 7805 mit einem 
Schaltregler betreiben? Ist nur so eine Idee...

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klausi wrote:
> Ui, 680µH, da liege ich ja ganz schön daneben.
>
> Aber komisch ist das alles einwandfrei funktioniert solange nur eine LED
> am Ausgang hängt.

Warum ist das verwunderlich? Du kannst auch einfach einen 
Rechteckgenerator nehmen, Spule und LED dran und die wird mehr oder 
weniger leuchten. Aber den Wirkungsgrad wirst du im Keller suchen 
müssen, ausserdem ist das Teil dann nicht geregelt.
Ob das Ding wirklich tut, zeigt sich erst beim vorgesehenen 
Ausgangsstrom.
Kannst du mal mit einem Oszi messen, was bei Belastung mit deiner 
Eingangs- und Ausgangsspannung passiert?
Und was passiert mit dem Eingangsstrom, wenn du am Ausgang deine 150mA 
ziehst?

> Mal ne doofe Frage, darf man evtl nicht einen 7805 mit einem
> Schaltregler betreiben? Ist nur so eine Idee...

Wie soll man das verstehen?

Autor: Mike J. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Klausi
Wie meinst du das?

Es gibt einen Schaltregler, der sieht genau so aus wie ein 7805 im TO92 
Gehäuse. Spule und Diode sind integriert!

Ich denke du willst die Spannung runtertransformieren (auf 6-7V) und 
dann mit einem 7805 glätten, wegen der Ripple.

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Also ich habe eine Schaltung gebastelt mit einem 7805. Ursprüglich 
sollte diese an 12V betrieben werden. Dann wäre die Temperatur vom 7805 
bei dem geringen Strom i.O. gewesen.

Jetzt möchte ich die Schaltung aber auch an 24V einsetzten. Dann wird 
der 7805 zu warm. Darum soll der Schaltregler davor...

Ich dachte vielleicht stören sich Schaltregler und 7805 vielleicht 
gegenseitig beim regeln oder.

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, ein Oszi hab ich leider nicht...

Autor: Mike J. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Klausi
Wenn du dir einen MC34063 als Step Down Wandler aufbaust kannst du aus 
den 12V gleich 5V machen und die dann noch glätten ( LC oder RC Tiefpass 
dahinter basteln).

Der 7805 erzeugt 5V bei nur 100mA.

Je nach deinen Ansprüchen (AD-Wandlung) wär es auch nicht verkehrt z.B. 
7V zu erzeugen und sie dann auf 5V mit dem 7805 zu stabilisieren.

Autor: UBoot-Stocki (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

welches Bauteil ist gemeint?

"Es gibt einen Schaltregler, der sieht genau so aus wie ein 7805 im TO92
Gehäuse. Spule und Diode sind integriert!"

Gruß

Andreas

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Klausi

Also verstehe ich das richtig, du willst 12V bzw. 24V per Schaltregler 
auf 8V regeln und dann nen 7805 dahinterhängen? Das ist kein Problem, 
vor allem da die 78xx-Festspannungsregler ausdrücklich dafür geeignet 
sind, einem Schaltregler nachgeschaltet zu werden um z.B. Spikes und die 
Ripple-Spannung am Ausgang des Schaltreglers zu glätten. Das sollte also 
kein Problem sein.

Zu der Last und Deiner flackernden LED: Ich mein die LED alleine zieht 
wenig Strom, mit deinem Vorwiderstand von 330 Ohm ungefähr 18mA (ist 
schon relativ viel, nimm mal nen Widerstand von 1k oder etwas weniger, 
dann fliesen ca. 6mA, das soollte reichen solange das ne normale LED ist 
zur Betriebsanzeige). Wenn Du eine Last anschließt die ca. 100 - 150 mA 
zieht, dann kann das schon sein das der Schaltregler nicht 
hinterherkommt. Soll heißen, die Spule speichert nicht genügend Energie 
um die Zeit die der Schalter im Schaltregler offen ist zu überbrücken, 
der Strom fällt zwischenzeitlich auf 0A, dann hast Du nen 
diskontinuierlichen Betrieb. Ich weiß jetzt allerdings nicht warum Deine 
LED flackert, bei der Taktung sollte man nur sehen, dass die LED nicht 
ganz so hell leuchtet wie ohne Last.

Also versuch am besten das mit der Spule mit 680uH, eher ein bischen 
mehr als ein bischen weniger. Ich bin mir ziemlich sicher, das es daran 
liegt.

Gruß

Gepi

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie lange wollt ihr noch dran rumraten?

Ohne ordentliche Oszibilder wird das nix..

Autor: Klausi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab den Fehler gefunden.
Peinlich aber wahr: Ich muß mich bei der Diode vergriffen haben. Statt 
einer 5819 war eine normale 4104 drin.

Ärgerlich wie viel Zeit man veschwendet weil man eine Sekunde unachtsam 
ist...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.