www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega16 Aref spinnt?


Autor: Werner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe einen ATMega16, für den ich mit einer LM385-2.5 Diode die 
Referenzspannung erzeuge (Aref): +5V -> 47k -> LM385 -> GND. Zwischen 
LM385 und dem Widerstand geht's zu Aref. Die Betriebsspannung des ADCs 
(Avcc) ist über ein LC Glied mit +5V verbunden.
Nun zum Problem:
Die Spannung am Aref Pin ist richtigerweise zunächst 2.5 V, doch sobald 
ich den ADC aktiviere (ADEN in ADCSRA setzen), fällt die Spannung am 
Aref Pin auf 1,8 V ab. Als Referenz habe ich REFS1 = 0 und REFS0 = 0 
gewählt, so dass die interne Referenz ausgeschaltet wird. Hat jemand 
eine Idee woran das liegen könnte ?

Und noch eine Frage dazu zum ADC: Wozu sind die differenziellen MUX 
Einstellungen gut, die als pos. und neg. Eingang jeweils den gleichen 
Kanal benutzen, z.B. MUX3 = 1 / ADC0-ADC0; Da kommt doch dann immer 0 
heraus ?

Gruß
Werner

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Werner wrote:

> Die Spannung am Aref Pin ist richtigerweise zunächst 2.5 V, doch sobald
> ich den ADC aktiviere (ADEN in ADCSRA setzen), fällt die Spannung am
> Aref Pin auf 1,8 V ab.

Das Datenblatt nennt einen typischen Eingangswiderstand am Aref-Pin
von 32 kΩ.  Damit erscheinen mir deine 47 kΩ Vorwiderstand ein wenig
zu dünn bemessen.

> Und noch eine Frage dazu zum ADC: Wozu sind die differenziellen MUX
> Einstellungen gut, die als pos. und neg. Eingang jeweils den gleichen
> Kanal benutzen, z.B. MUX3 = 1 / ADC0-ADC0; Da kommt doch dann immer 0
> heraus ?

Nur im Idealfall.  Real sicher etwas anderes, und damit kann man das
zur Ermittlung des statischen Fehlers benutzen.  Ich würde ansonsten
vermuten, dass die entsprechenden Datenpfade sich einfach mal so mit
ergeben haben und es keinen Grund gab, sie dann nicht auch mit zu
dokumentieren.

Autor: Lutz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Damit erscheinen mir deine 47 kΩ Vorwiderstand ein wenig
>zu dünn bemessen.

Mit "zu dünn" sollte wohl "zu hochohmig" gemeint sein?

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lutz wrote:

> Mit "zu dünn" sollte wohl "zu hochohmig" gemeint sein?

Ja, es passt gewissermaßen nicht genug Strom durch...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.