www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Mosfet Spannung GS zu hoch ?


Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

war das ganze WoE mal wieder vor meiner Schaltung gesessen und bin nun 
ratloser als zuvor.

Was mach ein Mosfet der GS 0-10V im Datenblatt hat, aber mit 0-12V 
berieben wird. Ändert sich sein Schaltverhalten?

Kurz zur Info,
ich habe einen BLMC entwickelt und auch die Software mit einem Atmega88 
geschrieben. Das din geht bis ca 11,5V super. Darüber fängt er an zu 
spinnen. Entwickelt habe ich natürlich sauber mit 8V um nicht gleich 
immer alle Mosfets zu verlieren. Der MC hat sauber seine 5V geregelt und 
gepuffert. Der Strom ist es auch nicht da ich momentan nur ca. bei 500mA 
teste, und auch hier das Problem besteht. Außer dem P-Kanal Mosfet ist 
nichts außerhalb der Spec.

Wäre für Tipps und Anregungen sehr dankbar.

Guten morgen noch und einen schönen start in die Woche

Gruß
Jürgen

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner eine Ahnung was passiert wenn am Mosfet die
GS überschritten wird?

Wo sind die Dipl. Ing!

Jürgen

Autor: mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Isolation (Metalloxidschicht) geht bei zu hoher Spannung kaputt und 
der MOSFET damit auch. Deswegen auch immer die ESD-Verpackungen. 
Zugegeben die Spannungen sind einiges höher.
Einen MOSFET außerhalb der SPEC zu betreiben sollte man immer vermeiden. 
Den FET kann man zum Beispiel mit einer Zenerdiode Gate->Source 
schützen. Es gibt bisweilen auch MOSFETs die eine Zenerdiode gleich 
integriert haben.

Ohne Schaltplan ist eine Hilfestellung ziemlich schwierig.
Und was ist eine BLMC?

Um so besser deine Infos sind um so besser wird dir hier geholfen....

Autor: Wolfgang Horn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen,

Du: "Wo sind die Dipl. Ing!"

Hör mal, solche Boss-Allüren erdulde ich nur, wenn ich dafür auch 
bezahlt werde.

Schau Du lieber noch mal ins Datenblatt. Da steht was von Grenzwerten, 
und weiter hinten findest Du Kurven von Idrain @ Ugs.

Mußt wirklich ein Boss sein - hetzt seine Leute auf, ihm Fragen zu 
beantworten, die er in einem 1/10 Arbeitszeit selbst hätte lesen können.

O.K., ich habe die Boss-Allüren ab als Jugendsünde.

Herzlich willkommen im Forum.


Ciao
Wolfgang Horn

Autor: Jürgen (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>Hör mal, solche Boss-Allüren erdulde ich nur, wenn ich dafür auch
>bezahlt werde.

Verstehe ich! So war's ja auch nicht gemeint!
Aber ein kleiner ans*** schadet ja nicht.

Datenblatt habe ich gelesen, daher weiß ich ja auch das sie außerhalb 
der Spec liegen.

Nur das Verhalten der ganzen Schalung kann ich nicht nach vollziehen. 
Das ist mein Problem.
Schaltung habe ich mal drangehängt, vielleicht seht ihr was was ich 
nicht sehen kann.

Zum Fehlerbild:
Motor läuft bei 10,5V super ohne hörbaren Störungen, also ein schönes 
10kHz "schnurren".
Ab ca. 11,5V gerät der Lauf ins stocken, starke Drehzahländerungen bis 
zum Reset des Controllers!

Ich habe auch schon versucht die Gatespannung mit Zenerdioden zu 
beschränken, aber dann funktioniert das ganze gar nicht mehr.
Andere Puffer Kondensatoren. Größere 5V Spannungsregler.

Eigentlich schon fast alles, nur die Mosfets sind noch nicht getauscht. 
Sind SO-8 und das 6 Stück tausche ich ungern aber wahrscheinlich habe 
ich keine andere Wahl!

Und boss bin ich keiner ;-) Und Jugendlich auch nicht mehr wirklich!

Danke Jürgen

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die drei *** sind wegen dem Spamfilter

der schmeißt mich soinst raus.

Sauber sag ich!

Jürgen

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du ein Oszi ?
Falls ja, mess mal die Gate Spannung der P Kanal Fets. Ich würde fast 
drauf wetten, dass die Gatespannung der P Fets beim Einschalten der N 
kanal Fets aufgrund der Millerkapazität mit runter gezogen wird, und so 
ein Kurzschluss entsteht. Da hilft dann nur eine künstliche Vergrößerung 
der Gate Kapazität, oder eine Verkleinerung des 680 Ohm Widerstandes.

Autor: Düsentrieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
erstmal...12v an gate is ok. schaltverhälten wird nich viel anders, nur 
etwas schneller....hier liegt auch vmtl dein problem: shoot ! die 
enstehenden felder verwirren dann alles, bis zum controller selbst.
genauer geht meine glaskugel leider nicht, du müsstest schon schaltplan 
+ foto vom aufbau zeigen...

Autor: Düsentrieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh, sch grad gesehen...fehlt noch n foto bzw layout...
--- fets direkt vom avr getrieben...seehr optimistisch...welche 
schaltzeiten on/off det fets + steuerfrequenz pwm soll das denn machen?

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ganze läuft mit 10 bis 20 kHz. Flanken sind OK ca.1,5µs.

Ist der Millereffekt überhaupt von der Spannung abhängig?
Wie gesagt bei 10V geht es super, und die Schaltzeiten sind auch kein 
Problem.

Osszi hab ich werde heute Abend mal eine Messorgie veranstalten, nur ist 
das ganze ziemlich dynamisch und mit meinem Oszzi schwer einzufangen.

Gruß
Jürgen

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen wrote:

> Ist der Millereffekt überhaupt von der Spannung abhängig?

Minimal.
Aber trotzdem hat man einen Spannungsteiler aus Millerkapazität und 
Gatekapazität. Und wenn die Spannungs ausreichend hoch ist, kommt am 
Gate genügend Spannung an, um den Mosfet einzuschalten.

Bei mir lief die Schaltung bis etwa 10V problemlos, darüber wurden die 
Mosfets heiß und ich hatte Spiks auf der Leitung, selbst wenn ich die P 
kanal Fets dauerhaft abgeschaltet hatte.

Autor: Düsentrieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ist der Millereffekt überhaupt von der Spannung abhängig?
ja...sonst wärs kein miller effekt!

Autor: Düsentrieb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
deine gate-ansteuerung is völlig unbrauchbar für so fette fets.
vieel zu langsam. entweder du nimmst nen gate-treiber oder zumindest ein 
paar p+n dazu, um die gates vernünftig anzusteuern.
speziell der 7220 hat > 100nC Qg , das braucht saft...

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Momentan sind andere verbaut

FDS6675A < 34nC
oder auch
PHK28NQ03LT < 31nC

aber das in Mischkultur vielleicht ist das ein Problem?
Ich werde einfach mal die 680R mal halbieren, dann sehen wir gleich ob 
es das Gate ist.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So hab mal ein bisschen im Netz gesucht und ein wenig zum Miller 
geschaut!

Wenn ich das richtig verstanden habe, wird hier der Kondensator
zwischen Drain und Gate betrachtet, der sich hier auf das Gate auswirken 
kann und mir hier eventuell den P-Kanal kurz auf schaltet. Hab ich das 
richtig verstanden?

Abhilfe?
R verkleinern ==> hält den C besser her
Treiber ==> geht hier nicht mehr Platine ist bereits fertig
Anderen Mosfet ==> bei dem der C nicht so ausgeprägt ist!

Was gäbe es sonst noch? Dadurch lassen sich wenigstens die Symtome 
erklären. Vielleicht wars ja das!

Super Leute
Danke Jürgen

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jürgen wrote:
> Wenn ich das richtig verstanden habe, wird hier der Kondensator
> zwischen Drain und Gate betrachtet, der sich hier auf das Gate auswirken
> kann und mir hier eventuell den P-Kanal kurz auf schaltet. Hab ich das
> richtig verstanden?

Ja

> Abhilfe?
> R verkleinern ==> hält den C besser her

Es bringt nur bedingt etwas: Wenn die Schaktflanke sehr steil ist, muss 
R sehr klein werden, damit der Mosfet wirklich nicht einschaltet.

> Anderen Mosfet ==> bei dem der C nicht so ausgeprägt ist!

Wenn du was passendes findest.

> Was gäbe es sonst noch?

Einen C parallel zu Gate-Source legen. Das hat bei mir geholfen. Damit 
wird die Ansteuerung zwar schwieriger, und die Flanken flacher, aber 
irgendeinen Kompromiss muss man halt eingehen.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Einen C parallel zu Gate-Source legen. Das hat bei mir geholfen. Damit
>wird die Ansteuerung zwar schwieriger, und die Flanken flacher, aber
>irgendeinen Kompromiss muss man halt eingehen.

Welche Größenordnung ?
100nF

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kommt auf den Mosfet an.
Schau dir aber erstmal die Gate Spannung an.
Wenn bei dieser negative Peaks vorhanden sind, dann würde ich die 
Kapazität solange vergrößern, bis diese deutlich kleiner sind als die 
Schaltschwelle.

Autor: Jürgen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So mist!!!!

Kein  Miller auch 300R mit 100nF haben keine aber überhaupt keine 
Änderungen!

So wieder alles zum Start und gehen sie nicht über LOS!

So mal sehen was ich machen kann!

Trotzdem vielen Dank!

Jürgen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.