www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ezurio Bluetooth-Modul => PC erkennt es nicht


Autor: Martin M. (martin69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Bluetooth-Modul gekauft:

Hersteller: Ezurio
Typ: TRBLU23.00200
RS-Components-Bestell-Nr.: 189-223

Zum testweise Kontaktieren habe ich eine Adapterplatine bei Schuricht 
gekauft (Bestell-Nr.: 64 68 77).

Bevor ich mich genauer mit dem Modul befasse, möchte ich erst mal 
schauen, wie weit die Reichweite im Haus ist. Ich hatte schon ein 
anderes Modul gekauft, aber dessen Reichweite war nicht besonders gut.

Leider findet der PC das Ezurio-Modul bei der Bluetooth-Suche nicht, 
obwohl es mit 5V versorgt wurde und der Reset-Eingang auf Low liegt. Die 
3,3V auf dem Modul sind da, also müßte das Ding eigentlich auch laufen.

Muß man das Modul nach dem Auslieferzustand bzw. Reset erst mal 
parametrieren? Bisher habe ich den Controller (Atmel) noch nicht 
angeschlossen. Wie gesagt, erst mal möchte ich die Reichweite testen.

Hat jemand Erfahrungen mit dem Teil?

Ist das Modul eventuell defekt? Oder muß man es tatsächlich erst mal 
z.B. per RxD und TxD parametrieren?

Autor: Martin M. (martin69)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
anbei das Datenblatt des Moduls....

Autor: Martin M. (martin69)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und das AT Comand set....

Autor: Martin M. (martin69)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, nun bin ich einen Schritt weiter....

Ich tausche per Hyperterminal Daten mit dem Ezurio-Modul aus (über 
RS232). Das Modul antwortet z.B. auf "AT" mit "OK" und die LED auf dem 
Modul läßt sich mit den AT-Befehlen schalten. Also ist das Modul nicht 
defekt.

Wenn man "AT+BTP" am Hyperterminal eingibt, dann braucht das Modul mehr 
Strom und es wird vom Bluetoothprogramm auf dem PC gefunden. Soweit auch 
OK. Als Bluetooth-Programm verwende ich "Blue Solei", welches auf dem 
Aldi-PC schon drauf war.

Wenn ich mit Blue Solei "Geräte verbinden" mache, dann wird ein Paßwort 
verlangt. Hier habe ich dann die Nummer des Ezurio-Moduls eigegeben. Das 
scheint auch soweit zu gehen, aber das Hyperterminal zeigt dann "PIN? 
001109E41AEF" an. Hier muß man anscheinend ein PIN vom Bluetooth-Modul 
im PC eingeben. Aber wie lautet die Pin?

Kann man die ganze PIN-Abfrage abschalten? Ich will ja erst mal schauen, 
ob die Reichweite des Moduls OK ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.