www.mikrocontroller.net

Forum: PC-Programmierung XP Embedded - FBA installiert neues Image nicht


Autor: Olaf Rechtner (gruser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vorgeschichte: Habe mit Hilfe von XP Embedded über Target Analyser einen 
PMQ-File importiert, Dependency Checks laufen lassen und ein Image 
erstellt. Dieses Image habe ich auf einen DOM (Disk on module) kopiert 
und in den IDE Port 1 gesteckt (Festplatten u. CD-Rom-LW entfernt).

Problem: Nun sollte beim Neustart der FBA (First Boot Agent) starten. 
Nach dem Text auf dem Bildschirm "Verifying DMI Pool Data" erscheint die 
Meldung "Disk Boot Failure, Insert System Disk And Press Enter".

Frage: Warum startet der FBA nicht und installiert das Image?

Ich hatte das mal vor Jahren gemacht, da hatte es funktioniert. Hätte 
ich mir besser alles haarklein aufschreiben sollen ;o( Im Bios habe ich 
nun auch schon alle Einstellungen durch (HDD-0, LS120, etc.) - daran 
scheint es nicht zu liegen.

Vielleicht hat wer eine Idee - wäre wirklich sehr dankbar dafür.

Beste Grüße
gruser

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein DOM ist nicht bootfähig. Das wird daran liegen, daß Du es mit FAT 
formatiert hast, das nicht per se bootfähig ist.
Mit einem DOS-Tool (diskprep? kann mich an den genauen Namen nicht 
erinnern) kann man eine FAT-Partition bootfähig machen.

Einfacher ist es, NTFS zu verwenden, das ist von Haus aus bootfähig. Du 
musst dann allerdings im TargetDesigner auch die NTFS-Unterstützung 
hinzufügen.

Autor: gruser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dankeschön - aber das DOM ist mit NTFS formatiert worden, werde mir aber 
noch einmal die Einstellungen im Target Designer anschauen, obwohl ich 
beim Dependency Check immer NTFS ausgewählt habe... Aber ich gehe 
trotzdem noch einmal die Einstellungen im Target Designer durch.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, die von Dir geschilderten Meldungen lassen bezweifeln, daß das BIOS 
überhaupt vom DOM versucht zu booten, denn keine der Meldungen ist eine 
des Windows-Bootloaders.

Hast Du das DOM auch korrekt im BIOS angemeldet bzw. wird es in 
irgendeiner Weise erkannt?

Autor: Jiggler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
5 V Versorgung fürs DOM angeschlossen ???

Autor: Olaf Rechtner (gruser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Joah.. eingleisiges Denken - stimmt wohl... der FBA startet 
offensichtlich gar nicht... und ich werde auch die Jumper-Einstellungen 
meines Boards morgen einmal checken, ich glaube hierüber wird geregelt 
ob die Spannungsversorgung über einen externen Stecker läuft oder über 
einen Pin. Danke für die Anregungen aber schon jetzt.

Autor: Olaf Rechtner (gruser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja.. ist mir alles ein Rätsel.. das DOM wird im Bios erkannt, findet es 
auch wenn ich Autodetect anklicke, kann auch einfach die Daten 
draufkopieren - und trotzdem versucht der FBA offensichtlich noch nicht 
einmal von dem Speicherbaustein zu starten. Was kann man da noch tun? 
Bin ratlos.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die zu klärende Frage ist, ob das BIOS versucht, vom DOM zu booten. Erst 
wenn es das tut, hat XPe eine Chance, gebootet zu werden, und erst dann 
tritt der FBA in Erscheinung.

Wenn sich an den von Dir angegebenen Meldungen nichts geändert hat, dann 
mmacht das BIOS aber genau das nicht, es versucht nicht, vom DOM zu 
booten bzw. erkennt darauf keine bootfähige Partition.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.