www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Snubber auslegen


Autor: Dietmar E (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Kann jemand anhand des angehängten Bildes erkenne, in welcher Richtung 
man den Snubber verändern kann, um ein besseres Ergebnis mit dem 
Phasenanschnitt einer Vibrations-Pumpe zu erhalten?`

Die erste Reihe zeigt, wie die Schaltung mit Lampe am Oszilloskop 
aussieht. SSR ist das SHARP S202S11 mit Snubber.

Die zweite Reihe zeigt die Pumpe mit diskretem Snubber + Varistor 
(zusätzlich zum internen Snubber).

Die ditte Reihe ohne diskreten Snubber und Varistor, was anscheinend 
keinen Unterschied macht.

Das SSR schaltet im Nulldurchgang nicht ab, sondern schwingt deutlich 
datüber hinaus. Ich nehme an, das liegt am falsch dimensionierten 
Snubber?

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dietmar,
bei deiner Schaltung scheint etwas grundsätzlich nicht zu stimmen. Die 
Reihe mit 0ms müsste ein Sinus sein, ist es aber bei der Pumpe nicht.
Außerdem ist die Welle nicht symmetrisch. Sehr komisch

Thyristoren schalten im /Strom/nulldurchgang.
Laut Datenblatt hat dein SSR schon einen "Built-in snubber circuit"

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dietmar E wrote:
> Das SSR schaltet im Nulldurchgang nicht ab, sondern schwingt deutlich
> datüber hinaus.

Das ist normal. Ich denke, deine Pumpe wird hauptsächlich induktiv sein. 
Daher ist der Strom um 90° phasenverschoben. Im Spannungsmaximum ist der 
Strom immer am kleinsten, dann schaltet der Triac ab.

Das mit der unsymmetrischen Kurvenform liegt an dem Triac: Dieser hat in 
unterschiedlichen Quadranten unterschiedliche Zünd und Halteströme. Da 
der Triac vermutlich stark überdimensioniert ist, zieht die Pumpe zu 
wenig Strom, damit der Triac sicher zünden kann und zündet daher nur in 
jeder 2. Halbwelle.

Autor: Dietmar E (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> bei deiner Schaltung scheint etwas grundsätzlich nicht zu stimmen

Oops, Du hast Recht. Zwei Fehler gemacht: bei Pumpenmessungen die Lampe 
drin gelassen und den Snubber über die Last statt über SSR gelegt. Wenn 
das korrigiert ist, sieht es aus wie angehängt. Konsistenter - leider 
immer noch zur Hälfte falsch.

> Da der Triac vermutlich stark überdimensioniert ist

Stimmt, ein 8A-Triac für 0.2A-Pumpe.

Autor: Dietmar E (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Laut Datenblatt hat dein SSR schon einen "Built-in snubber circuit"

Es kam mir komisch vor, dass externe Snubber riesig ausfallen während 
das SSR so klein ist. Deshalb der Versuch mit dem zusätzlichen, externen 
Snubber.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal ins Datenblatt:
Minimum Operating current: 50mA
Hat das deine Pumpe ?

Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mich stört eins: Mit Lampe zündet der Triac wunderschön sowohl in der 
positiven als auch in der negativen Halbwelle. Die Spannung über dem 
Lastwiderstand ist ab Nulldurchgang gleich 0. Beim Zünden des Triacs 
geht sie dann "hoch". Mit Pumpe dagegen zündet der Triac in der 
negativen Halbwelle "über Kopf", also ausschließlich durch das zu hohe 
dU/dt im Stromnulldurchgang. In der "Antike" der Thyristoren - so ca. 
1965 bis 1970 - gab es hierzu folgende Regel:
Triac ausschließlich bei ohmscher Last
Thyristoren (2 Stück antiparallel) für induktive Last.

Beim Lichtorgelbau habe ich damals 60W-Leuchtstoffröhren (Schwarzlicht!) 
(incl Drossel und gut vorgeheizt) parallel zum Triac geschaltet, während 
eine 500W-Glühlampe als "normale" Last für den Triac diente - 
gigantisch!

Wenn es sich also darum dreht, eine der üblichen 
Kleinleistungsmembranpumpen zu betreiben, dann wäre es vielleicht 
sinnvoll, etwas ähnliches zu probieren: Pumpe parallel zum Triac, als 
Last für den Triac eine 60W-Glühlampe.

Alternative: antiparallele Thyristoren.

Grüße
Bernhard

Autor: Dietmar E (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Minimum Operating current: 50mA Hat das deine Pumpe ?

Das sollte kein Problem sein, die Pumpe ist mit 48W angegeben. 
Nachgemessen sind es zwischen 300mA bei 0ms und 90mA bei 7ms 
Phasenanschnitt.

Autor: Ferdinand Stettner (themistokles)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi also falls das mit dem Snubber noch aktuell ist

http://focus.ti.com/lit/an/slva255/slva255.pdf

Autor: Dietmar E (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ich gerade erfahren habe, enthalten solche Pumpen eine Diode. Argl.

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann langt ja auch ein Thyristor;)
Ich hab mir sowas schon gedacht, habs dann aber als zu verrückt 
verworfen.

Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das würde die gemessenen Spannungsverläufe als "Feature" statt als "Bug" 
erklären. Grundsätzlich ließe sich das allerdings "durchbimmeln": 
Widerstand in einer Richtung höher als in der anderen - ausreichende 
Meßspannung vorausgesetzt. Oder gar Spannungsabfall an einem (ca. 1 Ohm) 
Vorwiderstand per Oszillogramm.

Grüße
Bernhard

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.