www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Platinenentwurf - Reflowofen - Bewertung


Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo !

Ich habe vor mir in den nächsten Wochen einen Reflow-Ofen aus einem 
Pizzaofen zu bauen. Der Ofen ist bereits bestellt und auf dem Weg zu 
mir, ich würde aber gern vorher noch wissen, ob der Schaltplan sowie das 
Layout der Kontrollplatine so in Ordnung sind. Vor allem da ich den 
FT232 zum ersten mal verwende, bin ich mir da nicht 100% sicher. Hab das 
Teil selbstverständlich den Datenblättern entsprechend aufgebaut, und 
möchte mich vor der entgültigen Herstellung nur nochmal vergewissern. 
Wer also grad Zeit/Langeweile hat, wäre schön wenn er einen Blick 
reinwerfen könnte :)

Danke im Vorraus, Marc

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tip: Wenn du dein Layout als PNG oder PDF anhängst schauen sicher 
zehnmal soviele Leute drüber.
Warum sollt ich mir ein .RAR file runterladen, mühsam auspacken, nur um 
dann festzustellen dass ich kein XYZ-CAD installiert hab um mir die 
Files auch anzusehen...

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
danke für den Tip !

hier dann nochmal alles als .png. Bildgröße sind 700kb, ist recht 
hochauflösend ;), ist einmal der Schaltplan, sowie einmal Ober-, 
Unterseite der Platine und Bestückung. ( THD auf anderer seite als SMD)

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich mir nur mal so kurz drübergeflogen was mir aber aufgefallen ist das 
du erst einen Ablockkondensator an VCC verbaut hast und danach eine 
Drosselspule reingemacht hast, das gehört normalerweise anderstrum rein, 
ansonsten drosselt die Spule diese Impulsströme die ja vom Kerko bezogen 
werden, wodurch er dan ganz eingespart werden könnte.

Und dann nochmal zur Datenleitung zum seriellen EEPROM schaltest du 
wirklich zwischen diesen beiden Zuständen um
1. Portpin(Ausgang) zieht die Leitung auf Masse
2. Portpin wird auf Eingang umgeschaltet

Wenn du nämlich nur den Pin im Ausgabezustand nur von 0 auf 1 wechselst 
lieferst du ohne Pullup Strom auf die Leitung und das EEPROM kann diese 
dann nicht mehr runterziehen z.B. fürs Acknowlegde Bit evtl. geht er 
dann sogar kaputt wenn der interne Transistor keine Strombegrenzung hat.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Marc Seiffert (eurofighter)

Dateianhang: ReflowControll.png (707,9 KB, 34 Downloads)

>hier dann nochmal alles als .png. Bildgröße sind 700kb, ist recht
>hochauflösend ;), ist einmal der Schaltplan, sowie einmal Ober-,

Das kann man auch wieder runterrechnen bzw. mit sinnvoller Auflösung 
generieren. Siehe Bildformate.

MFG
Falk

Autor: Chris None (lamda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, abgesehen vom USB-Baustein, womit sich sicherlich kleinigkeiten
einsparen könnten, wie z.B. Osc, ISP stecker usw, aber das dürfte
nebensächlich sein, fallen mir andere Sachen auf:
die E-Leitung des Displays sollte nicht mit dem ISP Stecker gemultiplext 
sein.
Die Tasten sowie Leds können mit dem Display (lcd) gemultiplext werden,
die pull-up Wiederstände sind in diesem Falle im Display schon 
vorhanden.
Dies ermöglicht entweder mehrere Relais oder ADC´s, je nach Preferenz.

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Thomas O.

der eine kerko vor der spule ist aus dem Datenblatt des FT232 entnommen. 
Wenn du dir das layout anschaust, siehst du, das direkt am FT232 noch 
weitere abblockkondensatoren sind.

und das EEPROM hat ja eine I²C-Schnittstelle. Diese wird nat. so 
angesteuert, das ein portpin entweder eingang ist oder auf masse zieht 
--> es kann nichts passieren :)

@ Falk Brunner

jo, ich hatte das Bild auch mal testweise in paint auf die Hälfte 
reduziert. aber hier macht mir die .png-komprimierung einen strich durch 
dir rechnung, denn das bild wird "unscharf" und damit sinkt die 
komprimierung. Resultat: das bilt hatte nur noch 1/4 der Pixel, war aber 
immernoch fast genauso groß ;)

@ Chris None

Stimmt, das habe ich noch etwas suboptimal gelöst. Ich hab E nu einfach 
an PD6 Gelegt, der 2-Pol-Anschluss hatte eh noch keinen besonderen 
Sinn...weitere anschlüsse brauche ich auch eigenltihc nicht, wüsste 
zumindest nicht wofür. Eventuell führe ich noch die I2C auf eine 
Steckerleiste, damit ich im unwahrscheinlichen Notfall mittels 
Portexpander erweitern kann.

Die anderen Einsparungen wie z.B. Oszi wollte ich extra nicht machen, 
würde nur das Testen der Platine erschweren ;) Und die Einsparung ist 
minimal.



bis hierhin dann schonmal danke an alle die sich das Board mal 
angeschaut haben !

Autor: Christian L. (lorio)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im .png haben die Kondensatoren für den Quarz 100nF

Wenn der schwingen sollte muss du dich bei The Next Uri Geller bewerben 
=)
Denk mal, dass ist aber nur ein Beschriftungsfehler...

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
jo, sicher, ich hab einfach alle Kerkos mit 100nF beschriftet und gar 
nicht drauf geachtet das es da 2 gibt die anders sind ^^ Wahrscheinlcih 
hätte ich sie auch so eingelötet ohne den Beschriftungsfehler jemals zu 
bemerken ^^. In Wahrheit haben die Biester natürlich 22pF.

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

ich hab nu eine Platine gefertigt, hab am alten Layout noch etwas 
gefeilt und das ganze einseitig gemacht, 4 Drahtbrücken sowie ein paar 
SMD-Brücken habens ermöglicht ;)

Ich habe allerdings nun ein Problem:

Der FT232RL zieht 600 (!) mA im Betrieb. Im Anhang sind die aktuellen 
Konstruktionsdaten. Wie man sieht habe ich die Brücke entfernt, die den 
Mega8 versorgt, sowie die Brücke zu VCCIO des FT232RL, sodass im Prinzip 
nur noch der FT232RL selber den Strom ziehen kann.
was ich nur nicht verstehe: Warum ?

Es befinden sich auf der Platine definitiv keine kurzschlüsse zwischen 
VCC und Masse, sodass das kein Grund für den hohen Stromverbrauch sein 
kann.

Vielleicht hat ja jemand eine Idee ?

Gruß, Marc

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Marc Seiffert (eurofighter)

>Dateianhang: RC_C1.jpg (750,8 KB, 11 Downloads)

Kannst du es nicht verstehen oder willst du es nicht verstehen?

>Der FT232RL zieht 600 (!) mA im Betrieb. Im Anhang sind die aktuellen

Dann hast du einen Kurzschluss oder Beschaltungsfehler. Ich bin mal 
gehässig. Das geschieht dir Recht. Kleine Dinge bestraft der liebe Gott 
sofort.

>jo, ich hatte das Bild auch mal testweise in paint auf die Hälfte
>reduziert. aber hier macht mir die .png-komprimierung einen strich durch

Wer mit Paint "arbeitet" ist einmal zuviel auf den Kopf gefallen. 
Ausserdem komprimiert PNG verlustfrei. Steht alles im Artikel!

>dir rechnung, denn das bild wird "unscharf" und damit sinkt die
>komprimierung.

Käse. Lies den Artikel und versuch ihn zu verstehen.

> Resultat: das bilt hatte nur noch 1/4 der Pixel, war aber
>immernoch fast genauso groß ;)

Kaum.

MFG
Falk

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Falk

Versuch mal ein Bild, bei welchem ein Teil des Bildes eine .jpg ist als 
.png zu speichern. ich habs getan. 4,5 MB.

Komisch, bestraft er auch im vorraus ? ich hab das Bild gemacht, nachdem 
das Problem schon einige Stunden alt war...

Und mit was soll ich denn deiner Meinung nach arbeiten ? Ich werde mir 
kaum ein anderes Bildbarbeitungsprogramm kaufen nur weil ich einmal die 
Woche ein Bildchen fürs Inet zurechtschneide.

Mag sein, das das mit photoshop o.ä. geht, aber paint hats unscharf 
gemacht. Und keine Sorge, den Artikel habe ich schon sehr gut 
verstanden.

Marc

P.S.: Ist das eigentlich Typisch für dieses Forum, das lieber an einem 
kleinen Detail gemeckert wird anstelle Probleme zu lösen ?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Marc Seiffert (eurofighter)

>Versuch mal ein Bild, bei welchem ein Teil des Bildes eine .jpg ist als
>.png zu speichern. ich habs getan. 4,5 MB.

Das macht man auch nicht. Poste zwei Bilder und gut.

>Komisch, bestraft er auch im vorraus ?

Klar, ER kennt die Zukunft . . . ;-)

>Und mit was soll ich denn deiner Meinung nach arbeiten ?

Steht auch im Artikel. IrfanView, Paintshop etc.

> Ich werde mir
>kaum ein anderes Bildbarbeitungsprogramm kaufen nur weil ich einmal die
>Woche ein Bildchen fürs Inet zurechtschneide.

Ohhh, nun auf die bockige Tour?

>Mag sein, das das mit photoshop o.ä. geht, aber paint hats unscharf
>gemacht. Und keine Sorge, den Artikel habe ich schon sehr gut
>verstanden.

Was ich mal elementar bezweifle. Was nützt angebliches Verstehen, wenn 
man es nicht umsetzt?

>P.S.: Ist das eigentlich Typisch für dieses Forum, das lieber an einem
>kleinen Detail gemeckert wird anstelle Probleme zu lösen ?

Du solltest dich auch mal über Netiquette informieren. Dann wirst du 
feststellen, du du KEINERLEI Anspruch auf Problemlösung hat.

MfG
Falk

P.S. Es ist ein Kurzschluss oder Schaltungsfehler.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marc Seiffert wrote:

> Versuch mal ein Bild, bei welchem ein Teil des Bildes eine .jpg ist als
> .png zu speichern.

Ist ja auch sinnfrei, dann nimm doch lieber zwei getrennte Bilder.

Den Gimp gibt's übrigens nicht erst seit gestern...

Warum dein FTDI 600 mA zieht, kann ich dir aber auch nicht sagen.
Bei dem Strom könntest du das ja fast schon mit einer Wärmebildkamera
nachmessen, wo er lang fließt. ;-)  (Ich suche in meiner neuesten
Platine gerade 80 µA, die da zu viel fließen, das ist schon
schwieriger... Leider fürchte ich, dass es an Flussmittelresten
liegt, die nahezu unvermeidbar unter einem QFN32-Gehäuse nun mal
landen nach der Handlötung.)

Autor: Sascha Focus (sascha_focus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum hast du die Signale CTS DSR DCD RI# auf GND gelegt?
Im Datenblatt ist nichts davon zu finden.

Gruß Sascha

Autor: Michael Wilhelm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei 600mA müsste man schon mit der Hand detektieren, wo die fließen. Das 
sind immerhin 3 Watt.Nimm deinen sensibelsten Finger.

MW

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite

>schwieriger... Leider fürchte ich, dass es an Flussmittelresten
>liegt, die nahezu unvermeidbar unter einem QFN32-Gehäuse nun mal
>landen nach der Handlötung.)

Ich dachte im ersten Moment du meinst die 600mA ;-)
OK, 80uA können schon mal durch Flussmittel versickern. Schmeiss das 
Ding ein paar Stunden in Alkohol hicks und gut.

MfG
Falk

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@ Falk

das es ein Schaltungsfehler oder Kurzschluss ist ist klar ^^ der FT232 
ist mit 15mA angegeben, selbst wenn beide Leuchtdioden an sind sollte es 
nicht mehr als 30-40mA sein. Die Frage ist nur, WO ist der 
schaltungsfehler ? einen kurzschluss kann ich Praktisch ausschließen, 
habe alles durchgemessen.

Und nein, nicht Bockig. Warum auch ? Nur finde ich es ehrlich gesagt 
bescheiden, das hier im Forum über alles genörgelt wird. Was ist so 
schlimm an einer 750kB großen .jpg ? sogar mit 750kbyte DSL hat man das 
innerhalb von wenigen Sekunden geladen. Modemgeeinget ist es nicht, 
sicher. Hab das ganze mal aufgeteilt. sind 2 Dateien mit 250kb 
rausgekommen...

Und Anspruch habe ich keinen auf Problemlösung, nein. Ich habe 
ledigleich drum gebeten, da ich den FT232 das erste mal einsetze und 
vielleicht jemand mehr Ahnung von dem Bauteil hat als ich (bzw. nicht 
nur vielleicht, sicher hat jemand da mehr Ahnung, vielleicht ist einer 
grad da, der helfen kann).

@ Jörg Wunsch

Hehe, also ich weis nicht, ich bin nicht scharf da drauf meinen FT232 zu 
braten...hab zwar noch einen als Ersatz hier, aber trotzdem ^^

P.S.: Im Anhang mal das ganze in "Forenkonformer Form" ;)

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und die .png ....

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sascha Focus wrote:
> Warum hast du die Signale CTS DSR DCD RI# auf GND gelegt?
> Im Datenblatt ist nichts davon zu finden.
>
> Gruß Sascha

naja, es sind halt Eingänge, ein konstanter Pegel sollte doch nciht 
schaden ?

Gruß, Marc

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Marc Seiffert (eurofighter)

>nicht mehr als 30-40mA sein. Die Frage ist nur, WO ist der
>schaltungsfehler ?

Der Schaltplan scheint OK zu sein.

> einen kurzschluss kann ich Praktisch ausschließen,
>habe alles durchgemessen.

Da hab ich meine Zweifel.

>Und nein, nicht Bockig. Warum auch ? Nur finde ich es ehrlich gesagt
>bescheiden, das hier im Forum über alles genörgelt wird. Was ist so
>schlimm an einer 750kB großen .jpg ? sogar mit 750kbyte DSL hat man das

Steht alles im Artikel.

>innerhalb von wenigen Sekunden geladen. Modemgeeinget ist es nicht,
>sicher. Hab das ganze mal aufgeteilt. sind 2 Dateien mit 250kb
>rausgekommen...

Siehtst, schonmal 30% gespart. Plus bessere Qualität des Schaltplan und 
Layouts.

Wie versorgst du denn deine Schaltung im Moment? Per USB oder Netzteil?
Ich würde mal L3 probehalber rausmachen.

Zur Schaltung an sich.

- C15/C16 sind überflüssig.
- R11..16 sind überflüssig, das kann man alles einfach LOW aktiv 
schalten, auch mit den LEDs
- Dito R19
- B7/B8 sehen komisch aus, da schein ein Leitung die Bauteile 
kurzzuschliessen
- Das mit deinem B1..B5 ist nur bedingt gut, da kann man sich schnell 
verhaspeln. Es ist nämlich nach wie vor nur ein Netz.
- CON1 erscheint mir komisch. kanne sein dass du die falsche Buchse 
erwischt hast und damit Vcc und GND dort verdreht sind? Denn im 
Bestückungsplan sieht das wie ein Typ A Buchse aus, die aber an den PC 
gehört, nicht den FTDI . . .

MfG
Falk

Autor: Marc Seiffert (eurofighter) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Falk

danke fürs durchsehen.

versorgt wird mit nem Labornetzteil, direkt an USB betrachte ich als 
"etwas" ungeeignet für das erste mal ^^

C15/16 sind "angstkondensatoren" höchsten grades....eigentlih können die 
weg, stimmt schon

mit R11..R16 könntest auch recht haben. aber über den teil der schaltung 
hab ich mir ehrlich gesagt nciht sonderlich viel gedanken gemacht. hab 
mir einfach das erstbeste genommen was ich mir ausgedacht hab und was 
offensichtlich funktionieren wird und das dann eingebaut.

B7/8 sind in ordnung, gerade nochmal durchgemessen. Bei Betrachung mit 
er lupe sieht man auch das da ein wenig abstand herrscht.

Das ich VCC so gebrückt habe ist sicher nicht die beste Art. Hast ne 
Idee wie man das besser machen kann ?

Die Buchse ist i.O. VCC ist da wos sein soll, GND auch, die LED die 
"POWER an USB" signalisiert leuchtet auch ganz brav ;)

----------------

Hab den Fehler gerade aber selber gefunden. Der Tantalkondensator wars. 
Hab ihn verpolt reingesetzt....Markierung ist +, nicht -....erstaunlich 
das er nicht verbrannt/explodiert ist bei 3W...wobei die ihm 
vorgeschaltete Spule 2V vernichtet hat, also haben sie sich die Leistung 
geteilt ^^

danke trotzdem fürs drüberschaunt...die Beschaltung der Tasten werd ich 
mir für die nächste Revision schonmal merken :D

Gruß, Marc

Autor: Nils (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohh man ... manchmal habe ich echt mitleid mit manchen Leuten hier. Wie 
man sich nur an so Kleinigkeiten wie der Bildgröße hochziehen kann. Da 
gibts doch wirklich wichtigere Dinge im Leben. Ich komme mir ja vor hier 
wie auf einem Amt. Du hast Dich nicht an die Etikette gehalten also 
bekommst du auch keine Hilfe. Sooo ein Kinderkram. Wie sind alle aus 
Spaß an der Elektronik hier. Jeder hat klein angefangen. Keiner hier ist 
mit dem Wissen auf die Welt gekommen. Nur weil manche Denken Sie sind 
der Crack brauchen Sie hier nicht so große Töne Spucken. Ist doch schön 
das Ihr so viel könnt. Dann lasst doch einfach andere daran teil haben 
oder seid einfach ruhig, anstelle die Foren mit euren Nörgeleien zu 
füllen. Das Nevt nämlich mehr als zu große Bilder oder die zum 1000. mal 
gestellte gleiche Frage. Wenn Ihr wisst das die Frage schon 1000 mal 
gestellt wurde, dann kopiert den Link und gut ist anstelle einer Aussage 
... BENUTZ DIE SUCHFUNKTION! ...

Dieses Forum hier empfand ich als sehr informativ und das ist es 
immernoch, nur diese ewige Nörgelei die ist so viel geworden und neue 
Leute oder Anfänger werden so oft sofort angegiftet, das das echt 
manchmal hier keinen Spaß mehr macht.

Also bekommt euch wieder ein ...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Nils (Gast)

>man sich nur an so Kleinigkeiten wie der Bildgröße hochziehen kann. Da

Niemand zieht sich hoch. Es wurde nur deutlich daraufhingewiesen. Wenn 
jemand ein riesiges Bild hochlädt ist das unschön. Wenn er es trotz 
Hinweis nochmal macht ist das dämlich und damit kritkwürdig. Auch hier 
gibt es ein paar wenige Spielreglen, an die sich alle halten müssen.

MFG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.