www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 7805 im Grenzbereich?


Autor: Andre Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

folgendes Szenario:

Eine Schaltung, mir größtenteils unbelannh, im Wesentlichen ein ATMega 
und ein LCD-Display, hänt an einem 7805 Spannungsregler. Nun passiert es 
unregelmäßig und ohne Vorwarnung, das die Schaltung ausfällt. Wenn Dies 
der Fall ist, hängen am Eingang des 7805 zwar immer noch die normalen 
24V, aber am Ausgang nur noch 2,2V, zusätzlich wird das Teil sehr 
heiss.!
Eine Unterbrechung und Wiederherstellung der Spannungsversorgung behebt 
das Problem, 5V am Ausgang des 7805.

Meiner Meinung nach könnte das zwei verschiedene Ursachen haben.

1) der 7805 ist kaputt.

2) die Schaltung erzeugt (wieso auch immer) irgendwo einen 
Kurzschluss...
Der 7805 wird überlastet und gibt nur noch 2,2V bei unbekannter, hoher 
Stromstärke.

Nun meine Fraage dazu: wie verhält sich ein 7805 normalerweise bei 
Überlastung (elektrisch/thermisch)? schaltet er einfach ab (damit wäre 
Vermutung 2 wiederlegt, neuer 7805 eingebaut, Problem gelöst), oder 
passt das beobachtete verhalten zu einer Überlastung?

Der regler versoprgt nur den Controller und das Display, sollte also ein 
gutes Stück unter 100 mA liefern. Wenn Fall 2 zutrifft, würde es wohl 
nicht helfen, einfach einen neuen, evtl. größeren (2A) 7805 einzubauen, 
dann liegt der Wurm irgendwo in der Schaltung/im Programm...

Eure Meinung dazu interessiert mich sehr!

ach ja, am Ausgang des 7805 sitzen diverse Kondensatoren, ein 
Schwingungsproblem sollte es also nicht sein denke ich..

Viele Grüße
  André

Autor: Obelix X. (obelix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die 7805 haben eine Temperaturabschaltung. Probiers doch mal mit einem 
Kühlkörper. Und wenn es vorerst nur zum testen ist. Oder mal Kältespray 
einsetzen.

Autor: Andre Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn der 7805 funktionieren würde, würde er abschalten, statt nur 
lausige 2,2V auszuspucken, hab' ich das richtig verstanden?
Also ist er einfach nur kaputt?

Kühlkörper sollte eigentlich gar nicht nötig sein, denn im Regelfall 
braucht die Schaltung nur wenig Strom, also wenn, dann knallts irgendwo, 
und zwar plötzlich, spontan und ordentlich...

Leider ist es großer Zufall wann das passiert, hab' das heute 
glücklicherweise miterlebt...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Andre Z. (Gast)

>Eine Unterbrechung und Wiederherstellung der Spannungsversorgung behebt
>das Problem, 5V am Ausgang des 7805.

Thermische Sicherung spricht an und schaltet kurz aus. Dann wieder ein, 
dann wieder aus. Dadurch kommen die 2,2V zustande.

>Nun meine Fraage dazu: wie verhält sich ein 7805 normalerweise bei
<Überlastung (elektrisch/thermisch)? schaltet er einfach ab (damit wäre

Schaltet kurz ab, wiel lange weiss ich nicht.

>Der regler versoprgt nur den Controller und das Display, sollte also ein
>gutes Stück unter 100 mA liefern. Wenn Fall 2 zutrifft, würde es wohl

Haha. Schonmal die Arithmetik und den Herrn Ohm bemüht?

(24V-5V)*0,1A= 2,1W.

Das schafft ein TO220 Gehäuse nicht mehr ohne Kühlkörper, 1W ist so in 
etwa die Obergrenze.

>nicht helfen, einfach einen neuen, evtl. größeren (2A) 7805 einzubauen,

Nöö, du brauchst einen Kühlkörper.

MfG
Falk

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
24V-5V sind ca. 20V Differenzspannung.
Bei 0,1A sind es dann 2W.
Ohne Kühlkörper geht das nicht, es wundert mich nicht, daß das Ding heiß 
wird und abregelt.

Wann werden diese 7805-Threads mal verboten ?

Autor: Andre Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Falk

Hmm, das seltsame ist, die Schaltung läuft ansonsten 24/7 problemlos, 
der Strom scheint also deutlich unter 100 mA zu liegen.

Also siehts wohl so aus, das spontaner großer Strombedarf zur 
thermischen Überlastung führt... Ein reset behebt das wohl, wird also 
ein Software Problem sein?

Auch seltsam, denn der Controller läuft mit der Software schon seit 
Jahren problemlos...

Schade, wenn das das regelverhalten bei Überlastung ist, wird ein 
einfacher Austausch des 7805 nicht helfen. Ein Kühlkörper beseitigt zwar 
die Symptome, aber wieso das Teil plötzlich so viel Strom braucht ist 
weiter unbekannt...
doof...

Aber danke für die Aufklärung!

Autor: STK500-Besitzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wann werden diese 7805-Threads mal verboten ?

Wenn LED-Dimm-Threads die Macht ergriffen haben...
Und man 7805 mit einem Anschluß für die Wasser- oder Stickstoffkühlung 
ausgerüstet hat.

>Das schafft ein TO220 Gehäuse nicht mehr ohne Kühlkörper, 1W ist so in
>etwa die Obergrenze.

>>nicht helfen, einfach einen neuen, evtl. größeren (2A) 7805 einzubauen,

Die "verbratbare" Leistung hängt nämlich nicht vom Innenleben des IC ab, 
sondern von der Verpackung. Ein TO220-Gehäuse wird alleine nie mehr als 
1W vertragen. Dafür ist dessen "Kühlfläche" viel zu klein.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kondensator 2*100 nF von Eingang und Ausgang gegen Masse vorhanden?
kleiner Kühlkörper muß sein! Fehler sieht nach schwingen des 7805 aus.
er wird dadurch noch wärmer.

Autor: Andre Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry erstmal, das ich einen weiteren der verabscheuten 7805er Threads 
aufgemacht habe, aber die "typischen" Fehler meine ich ausgeschlossen zu 
haben, denn wie gesagt, in 99,9% der Zeit arbeitet die Schaltung 
einwandfrei, ohne Kühlkörper am 7805, und das seit Jahren. Erst seit 
einiger Zeit zeigt es Dieses Verhalten, etwa einmal pro Woche behaupte 
ich mal, ohne das Die Schaltung/das Programm auf dem Controller geändert 
weurden...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Andre Z. (Gast)

>Hmm, das seltsame ist, die Schaltung läuft ansonsten 24/7 problemlos,
>der Strom scheint also deutlich unter 100 mA zu liegen.

MESSEN!

Mfg
Falk

Autor: Obelix X. (obelix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> denn wie gesagt, in 99,9% der Zeit arbeitet die Schaltung
> einwandfrei

... aber evtl im Grenzbreich, wo es mehr oder weniger Zufall ist.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oszi ran und >MESSEN!<
was anderes hilft dann nicht.

Autor: Andre Z. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar, ich werd mal nachprüfen wieviel Strom die Schaltung 
normalerweise zieht!

Danke einstweilen, ich melde mich dann wieder ;)

Andre

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.