www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Modelsim: Auflösung von ps auf ns oder ms umstellen


Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Die Frage gab es sicher schon öfters, aber in der Suche fand ich kaum 
etwas treffendes auf mein Problem.

Nun, wenn ich in Modelsim etwas simuliere klappt das recht gut. Das 
Problem ist nur, dass mir Modelsim ALLES nur in ps ausgibt, gerade wenn 
man jedoch im ns oder gar ms-Bereich arbeitet ist das sehr nervend mit 6 
oder 9-stelligen Zahlen zu arbeiten ;)

Wie stellt man das um?
Bitte beachtet, ich kann die maximale Simulationszeit schon einstellen, 
das funktioniert, nur die Zeiteinheiten sind immer ps.

Autor: Gabriel Wegscheider (gagosoft)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst die "Resolution" also die Auflösung Deiner Simulation 
einstellen währent Du die Simulation beginnst. Also nach dem drücken des 
Simulations-Buttons erscheint ein Dialog, in dem Du den File, den Du 
simulieren willst auswählst, hier kannst Du auch die Resultion 
einstellen.
Normalerweise ist hier "default" eingestellt, Du kannst aber auch eine 
andere einstellung nehmen.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also in den options beim wave kann man cursor properties einstellen. 
dort in der gegend gab es auch etwas für die zeitachsen. aber ich habe 
da auch schon herum probiert und nicht das erreicht , was ich wollte.

was mich ja immer nervt, ist der measuer (distanz) der auch in ps 
dargestellt wird. kaum zu lesen.

aber mir scheint, daß die programmierer das tool nicht nutzen, sonst 
würden sie in der ersten test minuten darauf kommen, daß das ein großer 
mist ist, was sie dort an user oberfläche haben

beschwerden über die disfunktio bitte hier in die schweiz an herrn 
stättler stefan at mentor com. der freut sich über jede support anfrage

Autor: Gabriel Wegscheider (gagosoft)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
also wenn ich in ps-Auflösung simuliere, dann WILL ich auch 
ps-Auflösung in der Wave, wenn mir eine geringe Simulationsauflösung 
reicht, dann darfs auch geringer aufgelöst in der Waveform sein.

Autor: Thomas Reinemann (Firma: abaxor engineering) (abaxor)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

unter Tools-> Window Preferences -> Tab "Grid & Timeline" Häckchen bei 
"Use commas in time values". Nur merkt sich das Modelsim nicht. Dort 
kann man sich auch die Frequenz anstelle der Zeit anzeigen lassen.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank!

Nun hats funktioniert ;)
Das kleine Feld muss man erst mal wahrnehmen ;)

Autor: guest (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gelegentlich muss man aber in ps-auflösung simulieren!

Autor: Frank Ungermann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe neuerdings das Problem, daß Modelsim öfters mal seine 
Einstellungen verliert und mit Standardsettings wieder hochkommt. Im MPF 
stehen dann plötzlich wieder ns drin obwohl ich zuvor bereits auf ps 
umgestellt und mehrfach simuliert hatte.

Woher kommt sowas ?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.