www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega162 USART??


Autor: Andreas Auer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi.

Ich hab hier einen ATMega162. Das Problem das ich habe, ist folgendes:
Ich betreibe die 2. serielle Schnittstelle (also USART1). Außerdem
hängt ein externes SRAM dran. Wenn ich auf die serielle Schnittstelle
schreibe, funktioniert das einwandfrei (Übertragung zum PC funktioniert
ohne Probleme).
Ich weiß jetzt nur nicht, ob das RAM so funktioniert wie es soll (wenn
auch die serielle eingeschaltet ist). Ich hab mal versucht was
rauszuschreiben und wieder reinzulesen. Er liest und schreibt das selbe
(tat dies zumindest bei meinem Test). Leider tat er dies auch noch ohne
SRAM!!!
Wenn das externe RAM eingeschaltet ist und die serielle Schnittstelle
dazu und ich lese dann von UDR0 bzw. schreibe auf das Register, so wird
komischerweise der PIN PC2 (Adressleitung A10) HIGH. Und ich denke mal,
dass dies nicht so sein sollte!

Falls sich jemand mit diesen Fehlern auskennt, bitte melden!!!
Meine USART habe ich wie es das Beispielprogramm von ATMEL beschreibt,
initialisiert.

mfg
Andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.