www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 7805 - reichen diese Kondensatoren?


Autor: Christian T. (shuzz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich möchte einen 7805 verwenden und möchte gerne wissen ob die von mir 
vorgesehenen Kondensatoren ausreichen oder ob ich lieber größere 
verbauen sollte.

Die Schaltung sieht so aus:
                       1N4004
                   .----|<----.
                   |   ____   |
  +8,5V            |  |    |  |           +5V
      o-------o----o--|7805|--o----o------o
              |    |  |____|  |    |
              | +  |    |     |    | +
             ###  ---   |    ---  ###
             ---  ---   |    ---  ---
          220µ|    |100n| 100n|    |47µ
      o-------o----o----o-----o----o------o
   GND                                    GND


Sind die 47µF am Ausgang zu klein?
Oder sollten die eigentlich reichen?
Wie dimensioniert man sowas eigentlich?
(Testaufbau aufm Steckbrett funzt wunderbar, aber bisher werden da auch 
nur ne kleine Handvoll LEDs versorgt)

Der 7805 soll nen Mega8 und eine (zunächst kleine, später größere) 
LED-Matrix im Multiplexbetrieb versorgen, die Schaltung insgesamt sollte 
nicht mehr als 400-500mA ziehen.

Der Grund für die "krummen" Werte der Kondis ist einfach: ich habe in 
meinem "Friedhof" erstmal keine anderen Werte gefunden und muss deshalb 
mit dem Vorlieb nehmen was ich mir auslöten konnte... ;)

Hoffe ihr könnt mir weiterhelfen.

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die "8.5V" schon gesiebt, oder kommen die so aus dem Gleichrichter? 
Wenn ja, dann muss da VIEL mehr hin, eher Richtung 1000µF.
Den Ausgangselko (47µF) kann man auch weglassen.
Und den Kühlkörper nicht vergessen!

Autor: Christian T. (shuzz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 8,5V stammen aus einem "stabilisierten" Steckernetzteil (5V, 500mA) 
welches einst mein altes Siemens-Handy mit Saft versorgte und nun 
kastriert (d.h. ohne Stecker) mein Steckbrett mit Saft versorgt.

Die endgültige Schaltung (auf Lochraster) soll aber ebenfalls mit einem 
Steckernetzteil betrieben werden.

In dem Fall brauche ich keine allzu große Siebung, oder?
(Oder anders gesagt, die 220µF sollten reichen.)

Kühlkörper ist bereits drauf, allerdings auch Marke Eigenbau: Ein alter 
Kronkorken, schön geschliffen und mit Wärmeleitpaste vom PC an den 7805 
geschraubt, mal sehen ob das ausreicht... ;)

Danke für die Antwort!

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kronkorken-Kühlkörper ist mal was anderes, zuerst mit dem Bier den User 
abkühlen, und dann den 7805 mit dem Korken ;)

Einfach mal ausprobieren ob der reicht (ich glaub eher weniger bei 
500mA). Die 7805 haben aber üblicherweise eine Übertemperatursicherung 
eingebaut, d.H. gleich kaputtgehen sollte er nicht.

Bei deinem Steckernetzteil mal nachmessen, ob das bei 500mA Last auch 
wirklich noch die 8V liefert, sonst hat der 7805 nicht mehr genug "Luft" 
zum regeln.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
3,5V Differenz bei 500mA = 1,7W. Das könnt der Kronkorken grad noch 
schaffen. Wird halt ein bissel warm.

Autor: Christian T. (shuzz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo, das wollte ich sowieso mal testen ab wann bei dem Teil die Spannung 
einbricht.
Hatte mal ca. 200mA direkt aus dem NT gezogen, da blieb die Spannung bei 
8V oben, den Test musste ich aber aufgrund eines zu schwachen 
Messwiderstands recht schnell abbrechen. ;)

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
den kühlkörper würd ich irgendwie gern mal sehen =)

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich finde deinen Aufbau ganz ok, am Eingang kannst du vor dem Elko noch 
ne Drossel mit. mind. 47mH in Reihe reinmachen damits keine Probleme 
unter verschärften Bedingungen gibt.

Denn Eingangselko würde ich auf 1000µF erhöhen und den Augansgselko 
nicht weglassen, habe schon oft bei Spannungreglern exotischer 
Hersteller wie sie Reichelt immer öfter vertreibt die Ausgangsspannung 
zu hoch ist. Letzens hatte ich ein Teil das 5,5V lieferte erst mit einem 
kleinen Elko gings dann auf 5,05x V runter, wobei ich mir die 
Ausgangsspannung nciht mit dem Oszi angeschaut habe sondern nur mit 
einem billigem Multimeter, welches vielleicht auch durch die 
Schwingungen am Ausgang Mist angezeigt hat.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein 5,0V-Regler der bei korrekter Beschaltung ohne zu schwingen 5,5V 
liefert gehört umstandslos in die Tonne, nicht in die Schaltung.

Wenn der Elko dann was bringt, dann wahrscheinlich weil er sonst 
schwingt. Und dann zeigt ein Multimeter ohnehin nur Blödsinn an. Und 
gegen die Schwingungen wird ein 10µF ebenso abhelfen wie ein 100µF.

Wobei ich mich hier auf 78xx-Typen beziehe. LDOs arbeiten anders und 
sind was Ausgangselkos angeht mitunter recht sensibel.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bin mir jetzt nicht mehr sicher obs ein LM2940 oder LM2950 war. Bei 
meiner vorletzten Bestellung war das noch ein anderer Hersteller bei der 
letzen Bestellung waren die Teile von UCS oder USC. Kann daheim nochmal 
genau nachschauen wenns interessiert.

Normalerweise halte ich mich immer an die Datenblätter der jeweiligen 
Hersteller da hier die Empfehlungen für den Ausgangselko sehr 
unterschiedlich sind.

Wie größ der Ausgangselko dann war den ich reingemacht habe weiß ich im 
Moment auch nicht war auf jedenfall ein kleineres Miniaturxxemplar 
entweder 1µF oder 10µF weil ich diese immer gerne für die RS232 
beschaltung verwende und vorrätig habe.

Ich hatte es aber auch schon das die Spannungsregler ohne Ausgangselko 
zu wenig Spannung lieferten, da waren es dann ca. 4,7V was sich erst mit 
Elko beseitigen ließ.

Autor: Christian T. (shuzz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gast wrote:
> den kühlkörper würd ich irgendwie gern mal sehen =)

Hehe, ich versuche nachher mal ein Foto zu machen... ;)


 Thomas O. schrieb:
>ich finde deinen Aufbau ganz ok, am Eingang kannst du vor dem Elko noch
>ne Drossel mit. mind. 47mH in Reihe reinmachen damits keine Probleme
>unter verschärften Bedingungen gibt.

Was genau verstehst Du denn unter verschärften Bedingungen?

An Alle: Danke für die guten Anregungen! :)

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. wrote:

> bin mir jetzt nicht mehr sicher obs ein LM2940

Das wäre ganz was anderes als ein 7805! Der Original-LM2940 benötigt 
laut Datasheet einen low-ESR Elko mit einem ESR zwischen 0,1 und 1,0 
Ohm, sonst nix stabil.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

meine Erfahrung bei 78xx-Reglern: die je 100n baur ich immer direkt am 
Regler ein, egal, ob Kondensatpren in relativer Nähe sind oder nicht.
Sie schaden auch dann nicht und so teuer sind sie auch nicht.

Der Elko vor dem Regler hänht stark von der Spannungsquelle ab, bei 
geregelten Netzteilen nehme ich meist 220µ, sonst nach der Fausregel 
1000µ pro A, unter 470µ gehe ich allerdings auch bei relativ kleinen 
Strömen nicht.

Ausgangsseitig sind auf der eigentlichen Schaltung je nach 
Leitungslängen/-führung meist noch 1-2 47µ verteilt, das reichte bisher 
immer. Rückstromdiode habe ich bei diesen Elkos am Ausgang bisher noch 
nie bestückt.

Eingangsspannungen möglichst 8-9V bei Strömen max. ca. 0,5A, damit ein 
Standardkühlkörper reicht. Meist nur diese recht kleinen 
Anschraub-/Aufsteckkühlkörper, Temperaturen von 70 Grad am Kühlkörper 
kann die 78xx-Reihe ohne weiteres. Da eben aufpassen, daß die Wärme auch 
weg kann und nicht unnötig andere Teile heizt.

Gruß aus Berlin
Michael

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael U. wrote:

> Rückstromdiode habe ich bei diesen Elkos am Ausgang bisher noch
> nie bestückt.

Ob ich die verbaue oder nicht hängt von dem Umfeld ab. Der kritischste 
Fall ist ein Kurzschluss vor dem Regler. Wenn der Kabel/Steckersalat das 
prinzipiell zulässt, gehe ich lieber auf Nummer sicher. Und da ich eine 
Tüte mit zig 1N4000ern rumliegen habe stört das auch nicht wirklich.

Naturgemäss steigt das Risiko mit steigender Kapazität hinter dem 
Regler. Sind da bloss 3x 10µF verbaut, passiert wohl kaum etwas. Hat da 
jemand wohlmeinend 470µF versenkt, dann wär's besser man baut eine Diode 
ein (oder den 470er aus).

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Andreas Kaiser: ist ja auch völlig richtig, die einzubauen.
Mit Eingangskurzschlüssen rechne ich bei mir normalerweise nicht, weil 
entweder ein Steckernetzteil mit passender Buchse benutzt wird oder der 
Kram mit auf der Leiterplatte ist. Ein Kurzschluß vor der Graetzbrücke 
stört dann ja den 78xx nicht.

Dicke Elkos dahinter habe ich eigentlich nie, meine maximal 200µ 
dahinter haben die Teile bisher gut weggesteckt.
Aber eigentlich sollte ich mir die Diode genauso zur Gewohnheit machen, 
wie die 2x 100n, stimmt schon. Genug SY360/05 liegen hier auch noch...

Gruß aus Berlin
Michael

Autor: Christian T. (shuzz)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

da der eine Gast gerne mal Bilder meines Eigenbau-KKs am 7805 sehen 
wollte habe ich mal meine Kamera bemüht.

Die Bilder sind entstanden als ich gerade den 7805 für mein Steckbrett 
aufbereitet habe, die Miniplatine ist mittlerweile auch funktionstüchtig 
sieht aber so schlimm aus daß ich sie hier lieber nicht posten möchte... 
;)

http://www.imagehosting.com/show.php/1683450_DSCF2...
http://www.imagehosting.com/show.php/1683451_DSCF2...
http://www.imagehosting.com/show.php/1683452_DSCF2...

Der Kronkorken lag noch von ner Party rum, das Messingteil war mal ein 
Mainboardhalter aus irgend nem uralten Rechner.

Da der 7805 auf meinem Steckbrett eigentlich nie mehr als 1,5W verbraten 
muss gehe ich davon aus, daß dieser KK dicke ausreichen sollte.

Falls jemand die Möglichkeit hat mal zu testen wieviel Leistung man mit 
so nem Billigkühler abführen kann wäre ich sehr interessiert an den 
Ergebnissen... ;)


Grüße,

Christian

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du kannst auch ne kleine Spule in Widerstandsbauform mit 50 oder 100µH 
vor den Regler in Reihe anschließen das Filtern dann auch kurze Impulse 
an der Eingangsseite, ich habe so letztens mit einen ATTiny eine 
Zündspule schalten lassen die an der 12V Versorgung vor dem 
Spannungsregler angeschlossen war.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.