www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Relais fällt nicht ab


Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich hab eine kleine Zeitschaltung für ein Terrarium, und steuere damit 
zwei Lüfter und eine 230V Last. Die gesamte Schaltung funktioniert. Die 
Lüfter sind per Optokoppler getrennt und haben 12V. Ich weiß, dass ich 
sie nicht unbedingt brauch, hab sie aber gehabt und mir wird 100% nicht 
der uC zerschossen.

Jetzt zum eigentlichen Problem. Die Relais mit der ich die 230V Last 
schalte, schaltet zum richtigen Zeitpunkt ein, das Problem ist nur noch, 
dass sie nicht mehr abfällt. Der Port geht auf 0, und es liegen auch, 
hab ich mit nem billigen Voltmeter gemessen, keine 12V mehr an. Kann mir 
das wer erklären?

Der Optokoppler der die Relais ansteuert ist ein MOC3021, das Relais ist 
ein M15F A H 001. Es wär schön wenn es ne relativ einfache Lösung gibt, 
die Lüfter gehen ja auch aus. ist schon ein bisschen komisch.

Danke für eure Hilfe!!!
Grüße Dominik

Autor: Frank L. (hermastersvoice)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mal mal deine Schaltung auf. Wenn der MOC z.B. eine Gleichspannung 
schaltet, dann geht er freiwillig nicht mehr aus.

bye

Frank

Autor: Schwurbl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann die Daten zu dem Relais nicht finden. Welcher Hersteller ist das? 
Falls die Spule des Relais an Gleichspannung gehängt wird, brauchst Du 
Dich nicht wundern, da Dein Optokoppler einen Triac enthält, der vom 
Controller gezündet wird. Zum Ausschalten muss aber sein Haltestrom 
unterschritten werden. Deswegen setzt man so ein Teil normalerweise nur 
bei Wechselspannungsanwendungen ein.

Autor: Roland (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fällt das Relais nicht ab weil an der Spule Spannung anliegt, oder klebt 
evtl. der Schaltkontakt ?

Autor: Marius S. (lupin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder du hast ein bistabiles Relais erwischt :)

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Nein nein, kein bistabiles Relais, und auch kein Kontakt der klebt. Da 
ich es jetzt auch von euch höre, dass das mit dem MOC Opto mit Triac 
drinnen, dem Relais und mit Gleichspannung nicht geht. Ist irgendwie 
klar, das das nicht gehen kann. Ich löt halt dann den Transistor direkt 
an die Relais, muss nur schauen wo ich die 12V herbekomme. Mit nem 
Optokoppler, der ne Diode hat, sollte das aber schon gehen oder?

Grüße Dominik

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es geht mit jedem geeigneten Optokoppler, der einen Ausgangstransistor 
enthält.....

Gruss Otto

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.