www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik oscillator schwingt nicht


Autor: noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo hallo

hab mir soeben eine kleine schaltung mit einem atmel16 gebastelt.
spannungen sind überall vorhanden, ebenso liegt der reset auf 5 volt.
hab ausgeschalten den chip reingesteckt wieder angeschalten und über 
jtag wollte ich jetzt ein programm einspielen. geht aber leider nicht. 
die jtag verbindung ist 100% korrekt alles mal durchgepfeift ebenso die 
spannungen und auch der oszillator. jetzt mess ich mit meinem oszi aber 
nicht die 4 MHz die anliegen sollten... Ich bin anfänger deshalb gleich 
ma ne blöde frage: sind die atmel chips grundsätzlich auf internen rc 
oszillator geschalten oder nicht??? damit ich dieses problem 
ausschließen kann.
andererseits wüßte ich nicht warum er nich kommunizieren will :(
hab noch ein orginalboard da klappt die verbindung einwandfrei. achso 
mit dem squid kabel von jtag auf isp gehts leider au nich :(((

vielleicht hat jemand einen tipp... thx im voraus.

mfg noob

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auslieferungszustand ATMEGA16 ist interner Oszillator.

> ebenso liegt der reset auf 5 volt

Wenn der fest auf 5V liegt, funktioniert das ISP nicht

Otto

Autor: noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok thx... die 5 volt liegen nicht direkt über pull up damit isp ihn 
runterziehen kann...

blöd das es trotzdem noch nich geht :(

Autor: noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bin ich auch richtig der annahme das so ein frischer atmega16 vorerst 
nur über isp programmierbar ist??? also das jtag enable fuse nicht 
gesetzt ist??

ich benutze ein jtagice mk2 mit dem squid cable geh ich dann auf die isp 
schnittstelle. sollte ja soweit alles richtig sein und wenn er eh mit 
einem internen rc beim erstkontakt arbeitet sollte es ja kein problem 
sein den zum laufen zu bringen... :(

futsch sollte der prozessor eigentlich nicht sein da ich ein esd armband 
trage....

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JTAG ist initial auch freigeschaltet.

Warum guckst du nicht einfach ins Datenblatt?  Steht alles drin.

Die Tasten links und rechts neben dem Haupttastenblock sind übrigens
für die Darstellung der Großbuchstaben zuständig.  Du solltest sie
hin und wieder benutzen.

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wahrscheinlich stimmt die ISP-Schnittstelle doch nicht so 
ganz....passiert mir auch immer wieder mal.

Gruss Otto

Autor: noob (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
loool kkkk
Ich werde mich in Zukunft daran halten.
^                 ^

Trotzdem danke für den Tipp. Falls es ma laufen sollte meld ich mich.
Wenn nicht dann klebt der Chip vermutlich an der Wand.

mfg noob

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.