www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Spannungsdifferenz Laptop - Veroboard Aufbau


Autor: Marcel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

ich habe folgendes Problem:

Es geht um einen Veroboard Aufbau (siehe Anhang) welchen ich mittels 
eines Traco AC/DC Wandlers mit+5V und +/-15V speise (ab Netz). Was auf 
dem Schema fehlt ist ein 4x20 Zeilen Display mit I2C Adapter welches ca. 
1 Ampere für die Hintergrundbeleuchtung benötigt. Nun ist es so dass die 
Hintergrundbeleuchtung mit ca 1 Hz schwach blinkt (d.H die +5V schalten 
sich im selben Takt ein und aus) sobald ich den ISP Port via AVRisp mkII 
mit dem Laptop verbinde. Wenn ich den reinen USB Stecker (am FT232) 
benutze wird die Hintergrundbeleuchtung merklich schwächer. Es scheint 
also so das die Schaltung vom Laptop her gespiesen wird sobald ich 
diesen anschliesse was natürlich bei einem 500mA Port nicht reicht und 
dem Laptop sicher auch nicht gefällt.

Beide Probleme treten nur auf wenn der Laptop am Netzteil läuft, läuft 
er ab Akku tritt beides nicht auf da er ja floatend ist.

Ich habe die Spannungsdifferenz zwischen Laptop und Schaltungsground 
gemessen und diese beträgt in etwa 5V.

Wie kann ich diese Problematik lösen?

Gruss

Marcel

Autor: Sven T. (svent)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marcel,
was ich im Schematic sehe und was mich stutzig macht :

Die USB Versorgung und die Versorgung des TRAVO Wandlers sind 
miteinander verbunden....
Ist das Absicht oder ein Versehen ?

Wenn das Board nicht über USB versorgt werden soll, dann sollte die VCC 
Geschichte am FT232 geändert werden.
Ich hab den FT232 bisher selbst noch nicht eingesetzt, aber bei "echten" 
USB Controllern wird in dem Fall üblicherweise V_IO mit der USB 5V 
verbunden und VCC des USb Bausteins mit den VCC des Boards.....

Check das mal ob eventuell da der Hund begraben ist.

Diese 1Hz Blinkerei der +5V....
Welche schalten sich denn da ab ?
Die der TRACOs ?
Mir scheint hier irgendwo auch noch ein Schluss zu sein.

Sven

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Sache mit der Verbindung USB Versorgung - Traco Versorgung war 
Absicht, aber ohne bestimmten Grund. Ich werde das mal trennen und meld 
mich dann wieder.

Autor: 3348 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1A Hintergrundbeleuchtung fuer eine 4 x 20 LCD ? Ist viel zuviel. Hast 
unter maximum Rating geschaut? Dann raucht das ding ab. Probier mal 
30mA. Das sollte reichen.

Autor: Sven T. (svent)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel wrote:
> Die Sache mit der Verbindung USB Versorgung - Traco Versorgung war
> Absicht, aber ohne bestimmten Grund.

Hihi....Absicht ohne Grund....
Bei meinen Kollegen sag ich da immer "Absicht ohne Grund ist wie 
Schwanger ohne Mann" :-)

Was war denn die Intention an der Stelle ?

Haste mal durchgemessen ob ein Schluss zwischen GND und VCC hergestellt 
wird ?
Was ich noch nicht so ganz verstanden habe....
Wie ist denn das Verhalten bei den unterschiedlichen Permutationen der 
Verbindungen ?
Es gibt ja die Verbindungen :
USB
ISP
Netzteil Notebook

Gibts ne Kombination die tut ?
Wie verhält sich das ganze in den 8 möglichen Kombinationen ?

Sven

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So habe USB VCC jetzt an V-IO und und an VCC die Traco Versorgung, hat 
leider nichts gebracht. Zu dem ~1 Hz blinken, das scheint irgend ein 
Schutzmechanismus des Traco Schaltnetzteils zu sein, jedenfalls schaltet 
dieser in dem Takt jeweils kurz ~0.5V ein und aus.

@3348 1A passt schon, das Display ist 130x50mm gross und die 
Hintergrundbeleuchtung benötigt 800 - 2000 mA.

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Sven

Habe den Schaltungsteil aus einem früheren Projekt übernommen bei 
welchem der Aufbau via USB gespiesen wird. Das Traco Netzteil kam erst 
später hinzu als der Aufbau mit dem Display und dem RCV420 ergänzt wurde 
und +/-15V und höhere Ströme bei den +5V benötigt wurden.

Zu den Kombinationen:

Wenn USB und ISP nicht verbunden sind läuft alles prima.

Wenn ich nun USB und/oder ISP verbinde und diese an den Laptop 
(AKKUBETRIEB) hänge läuft immer noch alles prima. Terminal läuft und 
Programmieren klappt ebenfalls.

Probleme gibt es nur wenn der Laptop am Netzteil hängt und somit nicht 
mehr floatend ist.

Verbinde ich USB mit dem Laptop (NETZBETRIEB) so wird die 
Hintergrundbeleuchtung merklich schwächer aber alles läuft noch. Die +5V 
Speisung des Tracos fällt aber von 5.04V auf 4.92V ab, die +/-15V 
bleiben unverändert.

Verbinde ich ISP mit dem Laptop (NETZBETRIEB) so läuft nichts mehr 
ausser einem schwachen aufblinken der Hintergrundbeleuchtung im ~1Hz 
Takt. Sowohl +5V wie auch +/- 15V schalten sich im selben Takt kurz ein 
wobei sie nur etwa 10% der Spannung erreichen also ~0.5V und +/-1.5V.

Habe keine Verbindung zwischen Laptop (NETZBETRIEB) und dem Aufbau so 
messe ich eine Spannungsdifferenz von -5V wenn ich die Grounds 
zueinander messe (Aufbau +/Laptop -).

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich denke ich habe das Problem gefunden. Ich habe eine 5V Differenz 
zwischen den Traco Ausgangsspannungen und der Schutzerde ich werde mal 
schauen ob ich den Fehler finde.

Mahlzeit

Autor: Sven T. (svent)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermute du hast irgendwo ne Verbindung der Primärseitigen Masse 
und/oder Schutzleiters der TRACO Wandler zu den 5V.

Autor: Marcel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
War wirklich so hatte die Bahnen zu den Metall-Distanzbolzen nicht 
sauber unterbrochen -.-

Besten Dank für die Hilfe

Marcel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.