www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio hängt sich auf


Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute

Ich habe ein echt nerviges Problem und bräuchte mal wieder eure Hilfe.
Ich versuche gerade meine ersten Schritte mit dem AVR Studio 4 zu machen 
und scheitere schon am wohl einfachsten Tutorial im Netz.
Ich gehe immer Schritt für Schritt alles durch wie im Tutorial 
beschrieben.
Und immer wenn ich aus dem Menü „Debug“ die Option „Start Debugging“: 
drücke hängt sich das Programm auf und es kommt folgende Fehlermeldung.

Schwerwiegender Fehler AVR Studio muss beedet werden !

Ich nun das Projekt schon X mal neuangelegt ohne Erfolg auch das 
deinstalllieren und neu installieren habe ich schon x mal durch 
ebenfalls ohne Erfolg.Ich hoffe jemand vonn euch kennt das Problem 
und/oder kann mir Tips geben wie ich das beheben könnte.

MFG

Vincent


Hier noch der Link zum Tutorial.

http://www.robomodules.de/portal/index.php?id=199&type=1

Autor: Condi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal in der Ereignisanzeige im Anwendungs und Systemlog nach gelben 
und roten Meldungen

Start->Ausführen->eventvwr

Autor: Dipl. Ing. Peter Schwarz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probiest du vielleicht ohne JTAG zu debuggen? Eigentlich sollst du 
kompilieren und das hex file raufladen.

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Dort steht folgende Fehlermeldung

http://safarof.de/Fehler.JPG

Autor: Condi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keine anderen?

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Was genau ist JTAg und wofür brauche ich das ?
Im Tutroial steht nichts davon sondern nur das ich speichern soll und 
dan um das Programm zu übersetzen (assemblieren ).Mitlerweile bleibt es 
sogar schon beim speichern hängen und muss beendet werden.

Leider gibt es keine weiteren Fehlermeldungen sry.
ich ahbe mal den text aus dem scrollbereich eingefügt den man auf dem 
Bild nicht lesen kann.

Was meint ihr an was das noch liegen könnte.
Alle andere was ich an Software habe funtioniert bestens.
ZBSp Photoshop , Inventor , AutoCad , usw.





0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 61 76 72   ure  avr
0018: 73 74 75 64 69 6f 2e 65   studio.e
0020: 78 65 20 34 2e 31 34 2e   xe 4.14.
0028: 30 2e 35 38 39 20 69 6e   0.589 in
0030: 20 61 76 72 73 74 75 64    avrstud
0038: 69 6f 2e 65 78 65 20 34   io.exe 4
0040: 2e 31 34 2e 30 2e 35 38   .14.0.58
0048: 39 20 61 74 20 6f 66 66   9 at off
0050: 73 65 74 20 30 30 31 34   set 0014
0058: 33 34 32 62 0d 0a         342b..

Autor: Thomas W. (thomasw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von was für einem Betriebssystem sprechen wir eigentlich?

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Windows XP Pro

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Version von Avr Studio ist folgende:

Version 4.14 Build 589

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So um alle Daten zu vervollständigen hier die Angaben welche ich 
angezeigt bekomme wenn ich auf Version klicke.

AVR Studio    4.14.589
GUI Version    4, 14, 0, 589



Operating System
Major      5
Minor      1
PlatformID    2
Build      2600
Service Pack 2

Plugins:

AvrPluginAvrAsmObject  1, 0, 0, 46
AvrPluginavrgccplugin  1, 0, 0, 9
Stk500Dll      1, 0, 1, 10

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Hat irgendjemand eine Lösung für mein Problem bzw hat/hatte das selbe 
auch schon einmal

MFG

Manfred

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus habe das selbe Problem wäre klasse wenn jemand helfen könnte

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Ich habe vor kurzem mit der aktuellen Version upgedatet:

AVR Studio    4.14.589
GUI Version    4, 14, 0, 589

Operating System
Major      5
Minor      0
PlatformID    2
Build      2195
Service Pack 4

Plugins:

AvrPluginAvrAsmObject  1, 0, 0, 46
AvrPluginavrgccplugin  1, 0, 0, 9
Stk500Dll      1, 0, 1, 10

Sieht irgendwie anders aus. Hast du vielleicht eine Beta-Version?

MfG Spess

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Stimmt sieht irgenwie anders aus !
Welches XP Servise Pack hast du ?
Welche Version hast du dir runtergeladen , und wo.
Kannst du mir mal sagen was du auf der Seite hier genau runtergeladen 
hast.

http://www.atmel.com/dyn/Products/tools_card.asp?t...

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

W2K. Kann natürlich daran liegen. Aktuelle Version von der 
Atmel-Webseite.

MfG Spess

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Also langsam aber scher bin ich aber verzweifeln.
Ich ahbe den Pc gereinigt die Regestrie gecleant das neuste 
ServisePack(3) für WinXp runtergeladen und installiert und immer noch 
der selbe Fehler.Das kann doch echt nicht sein.Auch im Web findet man 
diesbezüglich nicht wirklich brauchbares ausser das mir aufgefallen ist 
das ich nicht der einzigste bin.Bitte Bitte versucht mir zu helfen , 
jeder Tip könnte Gold wert sein.

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Also ich habe das Problem nun nach langem hin und her gelöst.
Anscheinend lag es an der Version.
Ich kann das ganze zwar nicht wirklich verstehen aber ist halt so.
Also für alle die das selbe Problem haben bei mir hat folgendes 
geholfen.


AVR Studio 4.14 deinstallieren , Registry reinigen
AVR Studio 4.13 installieren und spass haben


vincent

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.