Inhalt

EleLa - Elektronik Lagerverwaltung Hilfe

Inhaltsverzeichnis

Verwaltung von elektronischen Bauteilen oder Warenlager. Speichermöglichkeit von Bildern, anlegen von Gehäuse, Bestellungs-Verwaltung, Stückzahlen und Preise. Projektverwaltung mit Stückliste und Historie sowie eine Wissens-Datenbank. Etikettendruck-Funktion der Lagerplätze auch mit Barcode. Viele "GoTo"-Tasten und Auswahldialoge vereinfachen das schnelle Arbeiten und Finden der Bauelemente. Unterstützt unterschiedliche Datenbank-Systeme.

Nr | Beschreibung
100 | Installation
150 | INI Datei Parameter
500 | Allgemeine Infos Programmbedienung
1000 | Bauteil Verwalten
1100 | Bauteile Verwalten - Lager / Gehäuse
1200 | Bauteile Verwalten - Lieferanten
1300 | Bauteile Verwalten - Bestellungen
1400 | Bauteilzuordnung in Kiste / Fach verwalten
1500 | Etikett drucken
2000 | Projekte verwalten
2050 | Prüfe Menge für Produktion
2100 | Projektpositionen verwalten
2200 | Projekt Historie
2500 | Projektpositionen Schnelleingabe
2600 | Projektpositionen aus CAD CSV / STK Datei importieren
3000 | Bestellung
3500 | Bestellung Bauteile mit Min-Mengen Unterschreitung
4000 | Suchen
5000 | Gehäuse Verwalten
6000 | Kiste
7000 | Typ, Kategorie der Bauteile
8000 | Adressen
8100 | Telefoneinstellungen
9000 | Extras
9100 | Rechner / Timer
9200 | Historie - über alle Projekte
9300 | Wissen
9400 | Logbuch
9500 | Datenbank
9550 | Importieren / Exportieren der Datenbank (nur MySQL)
9600 | Info/Übersetzung
 | Externe Links, Formelsammlungen

Stand 1.2.11702
(c) 2010-2011 by Markus Müller E-Mail: mm@MmVisual.de


Installation

Installation

EleLa ist als Windows EXE und native Linux Anwendung verfügbar. Mit dem Tool "CrossOver" kann die Windows-EXE auch unter MAC-OSX gestartet und benutzt werden.

1. Entscheidung Art der Installation

Diese Software benötigt für den Betrieb eine Datenbank. Welche Sie einsetzen hängt von der Nutzungsart ab. Haben Sie nur einen Rechner, so können Sie SQLite als Datenbank nutzen. Wollen Sie hingegen mehrere PC's benutzen oder haben einen Server so muss MySQL oder PostgreSQL verwendet werden. MySQL sowie PostgreSQL bietet auch ein Passwortschutz. Dafür ist der Installationsaufwand etwas größer.

Der Tipp:

Verwenden Sie am Anfang die Variante mit der SQLite Datenbank. Wenn Ihnen das Programm zusagt kann die Datenbank später mit der Programmfunktion "Import/Export Datenbank" in eine MySQL oder PostgreSQL Datenbank transferiert werden.

Für die Installation wird der Download "Setup_EleLa.exe" benötigt. Darin sind alle DLL's sowie eine zum Teil gefüllte Start-Datenbank enthalten. Das Setup Paket erkennt automatisch ob es sich um ein Update oder eine Neuinstallation handelt. Zudem kann jederzeit durch erneutes Ausführen des Setups die grundlegende Parametrierung von EleLa abgeändert werden.

Unterschiede Datenbanken, Entscheidungshilfe:

Bemerkung | SQLite | MySQL | PostgreSQL
Sie kennen sich mit der Einrichtung einer Datenbank nicht gut aus | X | nicht verwenden | nicht verwenden
USB-Stick tauglich, EleLa kann auf einen USB-Stick mitgenommen und ausgeführt werden | X | - | -
Geschwindigkeit | schnell | schnell | ca. 20% schneller als SQLite oder MySQL
Einfache Administration / Datensicherung | Datei EleLa.sq3 kopieren | Import/Export-Funktion von EleLa, anschließend kann die Datei gesichert werden.
Netzwerkfähig mit mehreren Arbeitsplätzen | - | Ja | Ja
Extra Datenbankserverinstallation / Konfiguration erforderlich | - | Ja | Ja
Homepage der Datenbank / Bezugsquelle * | www.SQLite.org | www.apachefriends.org | www.postgresql.org

* Ich möchte ausdrücklich betonen, dass ich keinerlei Einfluss auf die Gestaltung und die Inhalte der gelinkten Seiten habe. Deshalb distanziere ich mich hiermit ausdrücklich von allen Inhalten aller gelinkten Seiten dieser Hilfedatei und mache ihre Inhalte nicht zu Eigen. Diese Erklärung gilt für alle in dieser Hilfedatei angebrachten Links und für alle Inhalte der Seiten, zu denen die bei mir angemeldeten Links führen.
Insbesondere müssen die Nutzungsbedingungen sowie alle anderen Bedingungen der jeweiligen Datenbankhersteller beachtet werden.

2.a Installation mit SQLite

Für SQLite verwenden gibt es nichts zu berücksichtigen, einfach die EXE starten.
Hier kann die Original INI-Datei "EleLa.ini" geladen werden, falls Sie unbeabsichtigt Änderungen vorgenommen haben.

Die SQLite-Version verwendet die Datenbank-DLL von der Seite "www.SQLite.org".

2.b Installation mit MySQL

2.b.1 Laden von MySQL, wenn Sie es noch nicht installiert haben

Der Windows-Download XAMPP kann von der Seite "www.apachefriends.org" geschehen. Installiert wird mit dem Setup "Apache" und "MySQL". phpMyAdmin ist ein Webbasiertes Konfigurationstool für MySQL, daher sollte das gesamte XAMPP installiert werden.

2.b.2 Einrichten neuen User

  • Internet-Browser http://localhost/phpmyadmin/ eingeben
  • Rechte
  • Neuer Benutzer hinzufügen
  • Benutzername MyElektronik
    • Host "Lokal" auswählen ("Jeder") bei Benutzung mit mehreren PC's
    • Passwort 2x MyElektronik
    • alle Häkchen bei "Daten"
    • alle Häkchen bei "Struktur"
    • OK Taste

2.b.3 Einrichten neue Datenbank

  • Zurück auf die Hauptseite, Klick auf das Symbol "phpMyAdmin" links oben
  • Im Feld "Neue Datenbank" der Name "elela" eingeben
    • Kollation "utf8_unicode_ci" auswählen (letzter Eintrag)
    • Taste Anlegen

2.b.4 Struktur in Datenbank importieren

  • links die Datenbank "elela" auswählen
  • Importieren klicken und die SQL-Datei "elela_MySQL_Start.sql" auswählen
  • OK Taste

2.b.5 INI-Datei anpassen

  • Diese "EleLa.ini" Datei kopieren.
  • Im Abschnitt [DB] evt. anpassen "User=" und "Passwort=" und "HostName=" wenn Sie einen Server haben hier der Name oder IP-Adresse.
  • Alternativ das Setup-Paket erneut ausführen und die Verbindungsdaten anpassen.

2.b.6 Erste Daten importieren

Viele Gehäuse und eine Typ-Struktur ist bereits vorgefertigt und sind in der Datei "EleLa.sq3" hinterlegt. Diese Datei kann nun in die MySQL Datenbank importiert werden indem man die EXE Startet und unter "Extras" > "Datenbank" > "Exportiere/Importiere Datenbank" auswählt. Als Datei wählt man nun die "EleLa.sq3" aus und drückt die Taste "Import". Innerhalb weniger Sekunden sind die Daten importiert und sofort verfügbar. "Schließen schließt den Dialog".

Tipps zu MySQL Installation: Im Forum Mikrocontroller.net

Tipps zu MySQL Installation unter Linux/Ubuntu 64Bit: Im Forum Mikrocontroller.net

2.c Installation mit PostgreSQL

2.c.1 Laden von PostgreSQL, wenn Sie es noch nicht installiert haben

Der Windows-Download der Version V9.0 kann von der Seite "www.postgresql.org" geschehen.

2.c.2 Einrichten neuen User

Nach der Installation ist im Startmenü eine Programmgruppe PostgreSQL mit dem enthaltenen Programm "pqAdmin III". Sobald dieses zum ersten mal gestartet wird fragt es das Datenbank-Passwort ab.

2.c.3 Einrichten neue Datenbank

Links im Baum sind alle Server ersichtlich, öffnen Sie den lokalen Server und "Datenbanken". Mit der rechten Maustaste kann eine neue Datenbank hinzugefügt werden.
Geben Sie als Name "EleLa" und Kodierung "UTF8" ein und drücken Sie die OK Taste.

2.c.4 Struktur der Datenbank importieren

  • Links im Baum Doppelklick auf die Datenbank EleLe
  • Oben gibt es eine Taste "SQL", daraufhin öffnet ein SQL Eingabefenster
  • Mit Datei Öffnen kann die SQL Datei "elela_Postgres_Start.sql" ausgewählt werden.
  • Mit der Taste "Abfrage Ausführen" werden alle Befehle ausgeführt und die Tabellen angelegt.

2.c.5 INI-Datei anpassen

Um die Einträge korrekt vor zu nehmen kann das Setup von EleLa erneut ausgeführt werden, damit kann bequem die Parametrierung vorgenommen werden.

2.c.6 Erste Daten importieren

Siehe 2.b.6.

3. Fertig, EXE starten.

Sollten dennoch Probleme auftreten, so werden diese unter "Extras" / "Log" alle protokolliert und können MmVisual mitgeteilt werden.

4. Erste Einträge...

Bevor man Bauteile anlegt sollte erst einmal zumindest ein "Typ" eingerichtet werden um das Bauteil zuordnen zu können. Bei der Installation sind hier schon einige angelegt.

Dann unter "Adressen" Lieferanten und Hersteller anlegen, wie Reichelt, Conrad, ST, TI usw.

Dann unter "Kiste" Sortierkästen und andere Lagerplätze

Dann unter "Gehäuse" Bauteilgehäuse wie DIP8, SO8, TO92 usw.

Jetzt kann ein "Bauteil" mit allen Eigenschaften angelegt werden.

5. Datensicherung

5.a Bei SQLite einfach die Datei "EleLa.sq3" sichern

5.b Bei MySQL und PostgreSQL kann mit der Funktion "Import/Export Datenbank" die Datenbank in eine Datei gesichert werden.

Kommandozeilenparameter:

Ein Kommandozeilenparameter kann in der Konsole / Terminal eingegeben werden, z.B.

EleLa -h

Dies funktioniert unter Linux. Unter Windows muss man sich im Verzeichnes von EleLa befinden.

Parameter | Funktion
-h /h --help | EleLa startet die Hilfedatei EleLa.chm. Unter Linux muss der "KChmViewer" installiert sein, ansonsten kann die Hilfe nicht gezeigt werden.
-k /k --konfig | EleLa startet den Konfigurationsdialog mit dem die Datenbankverbindung parametriert werden kann. Wenn der Dialog geschlossen wird, so wird EleLa beendet
-uninstall | Hilfs-Funktion um bei Deinstallation unter Linux alle Dateien löschen zu können. Dabei öffnet eine Message-Box mit der abgefragt wird ob man die Konfigurationsdateien mit Datenbank löschen möchte.

Datenbanksysteme:

Die SQL Datenbankkomponente dieser Software unterstützt direkt verschiedene Datenbanksysteme, allerdings sind von mir nicht alle getestet, nur die Fett geschriebenen Protokolle. Hier die Liste:

  • asa7, asa8, asa9
  • firebird-1.0, firebird-1.5, firebird-2.0, firebird-2.1
  • firebirdd-1.5, firebirdd-2.0, firebirdd-2.1
  • interbase-5, interbase-6
  • mssql
  • mysql, mysql-4.1, mysql-5, mysqld-4.1, mysqld-5
  • oracle, oracle-9i
  • postgresql, postgresql-7, postgresql-8
  • sqlite, sqlite-2.8, sqlite-3
  • sybase

Firebird funktioniert mit EleLa nicht korrekt.


INI Datei Parameter

INI Datei Parameter

Konfigurationsdatei (EleLa.ini):

Die Konfigurationsdatei (*.INI) muss den gleichen Name wie die EXE haben, jedoch mit der Endung .ini. z.B. die EXE heißt "EleLa.exe", so wird die Konfigurationsdatei "EleLa.ini" verwendet. Somit können in einem Verzeichnis mehrere EXE-Dateien und Konfigurationen existieren. (Die Hilfe-Datei muss ebenfalls der gleiche Name haben, jedoch mit der Endung .chm.)

Wenn man die Konfigurationsdatei nicht im gleichen Verzeichnis wie die EleLa.EXE haben möchte, so muss EleLa wissen wo diese Datei ist. Dazu liest EleLa die INI Datei die im gleichen Verzeichnis der EXE ist, wenn der Parameter [Programm] IniLocation= existiert und hier eine vorhandene Datei angegeben wurde, dann wird diese Datei als INI verwendet und alle Parameter daraus gelesen.

Sollte keine INI Datei existieren so legt EleLa automatisch ein im gleichen Verzeichnis wie die EXE ein an und füllt diese mit allen Standard Parametern.

Besonderheit bei Linux:
Unter Linux sucht EleLa zusätzlich an den Stellen:

  • $HOME/.elela
  • /etc/<Name der EXE>.ini (EleLa.ini)

nach der INI-Datei. Dies ist nötig da der Linux-User keine Schreibrechte auf das Installierte EleLa Verzeichnis hat.

Pfadangaben in der INI Datei:
In der INI Datei können verschiedene Pfade angegeben werden, z.B. "VorlageDir" oder "DefHandbuchDir". EleLa unterstützt dabei alle Variationen der Verzeichniseingabe:

  • Absolute Pfadangabe, z.B. D:\MeineDateien
  • UNC Pfadangabe, z.B. \\PC-Name\Freigabe\Verzeichnis
  • Relative Pfadangabe, z.B. ..\..\MeinProjekt
  • Umgebungsvariablen, z.B. %TEMP%\MeineDateien

Das Trennzeichen der Pfadangabe wird automatisch an das Betriebssystem angepasst, egal ob man ein / oder ein \ oder mischt.
Auch die Umgebungsvariablen werden mit der Windows und Linux Schreibweise unabhängig vom Betriebssystem alle erkannt. Bei Windows wird die Variable immer in % eingeschlossen: %<Variable>%. Bei Linux beginnt eine Variable immer mit $: $<Variable>.
Ich empfehle die Windows-Schreibweise, denn nur damit ist sichergestellt dass es keine Verwechslung mit anderen Variablen gibt. Außerdem geht das Erkennen der Windows-Schreibweise deutlich schneller.
Welche INI Parameter diese Pfadangaben berücksichtigen ist in der unten stehenden Tabelle mit dem X in der Spalte "Datei Pfad" beschrieben.
Der von EleLa korrigierte Pfad wird nach der Korrektur (Relativ / Umgebungsvariablen) in das Log geschrieben und kann somit kontrolliert werden.

INI-Parameter | Defaultwert | Beschreibung | Datei Pfad
[Programm] | Allgemeine Programmeinstellungen
Version | 1.2.11303 | Versionsnummer der EXE. Wird automatisch von der EXE überschrieben
Caption | MyExeName | Hier kann ein frei definierbarer Text eingegeben werden was als Titelleiste in der EXE gezeigt wird.
LogInFile | 0 | Mit 1 wird unter dem Ordner "Log" eine Log-Datei geschrieben, der Log ist ebenfalls unter "Extras" > "Log" ersichtlich.
LanguageFile | Lang_DE.txt | Datei der Übersetzung aller Programm-Texte | X
LanguageFileLCL lclstrconsts.pl.po Datei der Übersetzung aller Default Systemdialoge die vom Compiler kommen.
Für Englisch muss der Wert leer gelassen werden. 		X
TableFile Tables.txt Datei in der Tabellen-Infos (Spaltenbreite/Spaltenposition/Sichtbarkeit) gespeichert werden.
Wenn der Dateiname leer gelassen wird, so werden keine Tabellen-Infos gespeichert. 		X
TableSaveSort | 0 | Speichert in der Datei "TableFile" die Sortierreihenfolge mit, wenn der Parameter 1 ist.
StartCopy

Hier kann die SQLite Datenbank-Datei vor dem Start von EleLa kopiert werden. EleLa kopiert die Datenbank-Datei in diese Datei.

Beispiel: StartCopy=.\Backup\EleLa.sq3

Damit wird die Datenbank in das Verzeichnis Backup kopiert. (Das Verzeichnis muss vorher schon existieren)
Der Befehl funktioniert nur mit dem Datenbank-Typ SQLite.
Tipp: Bei Verwendung mit einem USB-Stick wird die Datenbank vor der Benutzung kopiert was die Datensicherheit erhöht.

X
StartRun

Hier kann ein Befehl nach dem Kopieren der Datenbank (StartCopy) ausgeführt werden. Dabei wird ein neuer Prozess gestartet.

Beispiel: StartRun=.\Backup\Backup.bat

Damit wird die Batch-Datei gestartet. In dieser Batch kann z.B. eine Funktion hinterlegt sein, die die Datenbank komprimiert und in einen separaten Ordner ablegt.

Demo-Script: Backup.bat mit 7ZIP.

 X
VorlageDir | .\Vorlage | In diesem Verzeichnis befinden sich Vorlage-Dateien für Ausdrucke. | X
TempDir . Dieses Verzeichnis nutzt EleLa um Dateien zu speichern. Bei Ausdrucke wird immer eine HTML Datei erzeugt, die dann hier gespeichert wird. Auch die Sprach-Datei bei der Funktion "Speichere Texte" wird hier rein exportiert. X
IniLocation

Wenn dieser Parameter in der INI-Datei existiert und die angegebene Datei vorhanden ist, dann werden alle Parameter aus dieser angegebenen Datei geladen und nicht aus dieser. Damit kann die eigentliche EleLa INI Datei an einem anderen Ort stehen.

 X
StartRO 0

Mit diesem Parameter kann bei Programmstart der Read-Only-Modus aktiviert werden indem der Parameter auf 1 gesetzt wird. Dieser Modus kann mit Doppelklick auf die Statusleiste deaktiviert werden. Der Parameter ist optional.
QueryCancel 0

Wenn der Parameter auf 1 gesetzt wurde, so wird bei jedem Abbrechen einer Eingabe eine Sicherheitsabfrage gemacht.
[DB] | Datenbankverbindung
Protocol | sqlite-3 | mysql-5 | postgresql-8 | Art der Datenbankverbindung, "sqlite-3", "mysql-5" oder "postgresql-8". Andere Verbindungen wurden nicht getestet.
HostName n.b. localhost localhost Name oder TCP/IP-Adresse des Servers.
Bei Protocol=sqlite-3: nicht benutzt
Bei Protocol=mysql-5/postgresql-8: Server-Name
Port n.b. 3306 5432 Port des Servers.
Bei Protocol=sqlite-3: nicht benutzt
Bei Protocol=mysql-5/postgresql-8: TCP/IP Port
Database EleLa.sq3 elela EleLa Datenbank-Name
Bei Protocol=sqlite-3: (Pfad\)Datei
Bei Protocol=mysql-5/postgresql-8: Datenbank-Name 		(X, SQLite)
User n.b. MyElektronik postgres Benutzer-Name
Bei Protocol=sqlite-3: nicht benutzt
Bei Protocol=mysql-5/postgresql-8: Benutzer-Name
Password n.b. MyElektronik MyElektronik Passwort
Bei Protocol=sqlite-3: nicht benutzt, kein Passwortschutz möglich, da Datenbank dies nicht unterstützt
Bei Protocol=mysql-5/postgresql-8: Passwort. Wenn das Passwort leer gelassen wird so wird bei Start der EXE nach einem Passwort gefragt, ansonsten ist ein Verbindungsaufbau zur Datenbank nicht möglich.
[Bauteil]
DefHanbuchDir | .\Handbuch | Default-Verzeichnis, in dem die PDF-Dokumente aller elektronischen Bauteile sind. Unter "Bauteile" kann einem Bauteil ein PDF angehängt werden, dieser Datei-Auswahl-Dialog wird mit diesem Verzeichnis initialisiert. | X
[Projekt]
DefHanbuchDir | .\Projekt | Default-Verzeichnis, in dem die Handbücher aller Projekte sind. Unter "Projekt" kann einem Projekt ein PDF angehängt werden, dieser Datei-Auswahl-Dialog wird mit diesem Verzeichnis initialisiert. | X
[Telefon] | Parameter für Wählfunktion unter Telefoneinstellungen
Port | COM1 | COM Port zum Modem. Unter Linux tty0x
ATStart | ATX3 | Modem Initialisierungs Sequenz. X3 = Wählen ohne auf Freizeichen warten
DialPrefix | Präfix wird benötigt wenn man an einer Nebenstelle ist. Damit kann z.B. 0W für Amt holen und warten auf Freizeichen eingestellt werden.
[Linux] | Parameter der Linux-Version
ComboItemHeight 9 Hier kann festgelegt werden welche ItemHeight beim Drop-Down Auswahlfeld verwendet werden soll.
0 = Standard Desktop-Theme
1..x = ItemHeight der Drop-Down Felder. EleLa zeichnet die Items selbst.
Der Wert 9 ist ein Mittelwert mit dem es unter Gnome und KDE Desktop gut geht. Wobei bei KDE kann der Wert auch auf 0 gesetzt werden, bei Gnome auf 1.
FontHeight 11 Hier kann festgelegt werden welche Schriftgröße in allen Formularen verwendet werden soll.
0 <= Standard Desktop-Theme
1..x = Schriftgröße.
Der Wert von 11 macht eine gute Darstellung.
[Form] | Formularposition Main-Formular
[FormKisteTausch] | Formularposition Kiste-Tausch-Formular

Tipp, Konfiguration der INI-Datei mit EleLa:

Nahezu alle Parameter der Konfigurationsdatei können mit EleLa im Konfigurationsdialog bearbeitet werden:

Dieser Dialog öffnet sich unter "Extras" > "Log" > Taste "Optionen".

Alternativ kann der Dialog auch über Kommandozeilenparameter "-k" oder "--konfig" oder "/k" aufgerufen werden:

Dos Box oder Linux Terminal: C:\Programme> EleLa -k

Die grundlegende Einstellung von EleLa kann somit auch durchgeführt werden, falls sich EleLa wegen nicht funktionierender Datenbankverbindung nicht korrekt starten lässt, dabei wird nur der Dialog gezeigt und keine Datenbankverbindung her gestellt. Unter Linux wird ein zusätzlicher Reiter "Linux" eingeblendet mit dem man diese Parameter eingeben kann.

Konfiguration Datenbank:

Auf der Seite "Datenbank" können alle Parameter der Datenbankverbindung eingegeben werden. Anschließend kann mit "Teste Verbindung" geprüft werden ob der Datenbankserver erreichbar ist. Dabei wird nur die Verbindung geprüft, nicht ob auch alle Tabellen vorhanden sind. Bei korrekter Verbindung wird das Quadrat rechts grün, bei nicht korrekter Verbindung rot, während dem Verbindungsaufbau gelb.

Um Änderungen in der INI-Datei zu speichern muss unbedingt die Taste "Speichern" gedrückt werden. "Schließen" beendet die Konfiguration.

Aufbau der Datei TableFile:
<Formular>.<Query>=<Sortierspalte>;<Sortiertyp (0/1/2 Asc/Desc/Ignore)>
<Formular>.<Query>.<Spalte>=<DisplayWidth (Zeichen)>;<Index>;<Visible> (0 / 1)

Wenn <Sortierspalte> leer ist, wird nicht sortiert, bzw. nach EleLa Standard. Wenn man möchte, dass die Sortierung gemerkt wird, so muss in der INI Datei der Parameter "TableSaveSort" = 1 gesetzt werden.
<DisplayWidth> und <Index> können über EleLa direkt in der Tabelle geändert werden (Spaltenbreite/Spalte verschieben)
Mit <Visible> können nach belieben Spalten Aus-/Eingeblendet werden.

Wenn die Datei gelöscht wird, so ist beim nächsten Start von EleLa der Standard wiederhergestellt.


Allgemein

Allgemeine Infos

Hier ist beschrieben welche allgemeinen Funktionen eingebaut sind, die überall Gültigkeit haben.

Bei allen Text-Eingabefelder (außer Memo-Felder) werden die Leerzeichen zu Anfang und Ende beim Speichern automatisch gelöscht.

Tasten-Kurzbefehle:

Taste | Beschreibung
F1 | Diese Hilfe starten
F2 | Springe in Reiter "Bauteil"
F3 | Springe in Reiter "Projekt"
F4 | Springe in Reiter "Bestellung"
F5 | Springe in Reiter "Suche", markiere den Text in der Suchen-Eingabe.

F6

 Springe in Reiter "Gehäuse"
F7 | Springe in Reiter "Kiste"
F8 | Springe in Reiter "Typ"
F9 | Springe in Reiter "Adresse"
F10 | Springe in Reiter "Extra"

Strg+F2
: : :
Strg+F10

Wenn Reiter "Bauteil" ausgewählt, Auswahl der Unter-Reiter "Bauteil" / "Lager/Gehäuse" und "Lieferant"

Wenn Reiter "Projekt" ausgewählt, Auswahl der Unterreiter "Übersicht" / "Positionen" und "Historie"

Wenn Reiter "Extra" ausgewählt, Auswahl der Unter-Reiter "Rechner" / "Historie" / "Wissen" / "Log" / "Datenbank" und "Info"
F11 | voriger Datensatz auswählen aktuelle Ansicht, (bei "Bauteil" wird das Bauteil gescrollt / bei "Projekt" das Projekt)
F12 | nächster Datensatz auswählen aktuelle Ansicht, (bei "Bauteil" wird das Bauteil gescrollt / bei "Projekt" das Projekt)
Strg + F11 | voriger Datensatz auswählen bei "Lager / Gehäuse" oder "Lieferant" unter "Bauteil" / bei "Positionen" unter "Projekt"
Strg + F12 | nächster Datensatz auswählen bei "Lager / Gehäuse" oder "Lieferant" unter "Bauteil" / bei "Positionen" unter "Projekt"
Strg + A | Abbruch der Eingabe, verwerfen der Änderung
Strg + B | Sperren / Erlauben aller Eingaben (Blockieren). So wie Doppelklick auf die Statusleiste, siehe weiter unten in dieser Seite.
Strg + D | Lösche aktuellen Datensatz (Delete)
Strg + E | Öffnen Export-Popupmenü der jeweiligen Seite
Strg + F | Schnellsuche, setze Eingabefokus auf Schnellsuchenfeld der jeweiligen Seite
Strg + K | Öffne Bauteilzuordnung in Kiste / Fach verwalten
Strg + N | Neuer Datensatz
Strg + P | Drucke aktuelle Seite
Strg + R | Aktualisieren Tabelle (Refresh). Wenn Daten in einem anderen PC geändert wurden, so kann die Änderung sichtbar (neu einlesen der Daten) gemacht werden.
Strg + S | Speichere Änderung der aktuellen Seite
Strg + T | Gehe zur letzten Ansicht zurück, wählt den zuletzt gezeigten Reiter aus.
Play/Pause | Start/Pause Timer-Funktion (Multimediatastatur)
Stop | Stop Timer-Funktion (Multimediatastatur)
Unter "Bauteil" sind zusätzlich Funktionen aktiv:
Enter Wenn Schnell-Eingabefeld den Fokus hat, so wird der Filter auf die Schnelleingabe gesetzt.
Wenn Typ-Eingabefeld den Fokus hat, so wird die Filterung auf den Typ aktiviert.
Strg + Enter | Wenn Typ-Eingabefeld den Fokus hat, so wird die Typauswahl angezeigt.
Enter

Wenn Handbuch-Eingabefeld den Fokus hat, so wird das "Handbuch" aufgerufen.
Strg + Enter | Wenn Handbuch-Eingabefeld den Fokus hat, so wird der Öffnen-Dialog gestartet um ein Handbuch auswählen zu können.
Strg + + | Wenn Ansicht "Lager/Gehäuse" aktiv ist, wird zum Mengen Eingabefeld gesprungen mit dem man eine Menge mit +/- manipulieren kann
+ Wenn man im Mengeneingabefeld ist mit dem man eine Lagermenge um +/- korrigieren kann so wird diese Menge um den Wert erhöht
- Wenn man im Mengeneingabefeld ist mit dem man eine Lagermenge um +/- korrigieren kann so wird diese Menge um den Wert verringert
Unter "Suchen - F5" sind zusätzlich Funktionen aktiv:
Enter | Es wird zum Bauteil / Historie / Wissen gewechselt.
Pfeiltaste Up | Wechsel zum vorigen Datensatz.
Pfeiltaste Down | Wechsel zum nächsten Datensatz.
Unter "Adresse" sind zusätzlich Funktionen aktiv:
Enter | Wenn das Internet-Eingabefeld den Fokus hat, so wird Browser mit der hinterlegten Internetseite aufgerufen.

Tabellen-Funktionen:

  • Alle Tabellen können sortiert werden indem auf den Titel der Spalte geklickt wird. Die Sortierreihenfolge ändert wenn ein zweites mal auf die gleiche Spalte geklickt wird. Die Sortierung kann über zwei Spalten erfolgen, wobei immer die zu letzt angeklickte Spalte als erste Reihenfolge gilt.
  • Die Felder der Tabelle können verschoben werden in dem der Titel der Spalte mit Drag&Drop verschoben wird.
  • Eingabemöglichkeit direkt in der Tabelle. Drop-Down-Felder (ID-Verweise auf andere Tabellen) werden ebenfalls geöffnet.
  • Alle farblich hinterlegte Spalten sind nicht in der Tabelle änderbar. z.B. GPreis von Bestellung wird automatisch errechnet.
  • Farblich hinterlegte Bemerkung- / Bezeichnungsfelder sind nur in der Eingabemaske änderbar, denn in das Feld kann ein Text mit bis zu 64KB Größe eingegeben werden.
  • STRG + Entf. Taste löscht einen Datensatz (mit Sicherheitsabfrage).
  • Rechtsklick auf den Tabellentitel öffnet ein Popup-Menü mit dem alle Spalten aus und eingeblendet werden können.
  • Die Anordnung der Tabellenspalten sowie Breite wird in der Datei "Tables.txt" gespeichert (Parameter TableFile in der INI-Datei). Wenn der EleLa Grundzustand wieder her gestellt werden soll, so muss nur diese Datei gelöscht werden. Die Datei wird beim Beenden von EleLa beschrieben.

Memo-Feld Eingabefunktionen:

  • Öffnen eines Internet-Links oder Datei mit [Strg] + Mausklick auf dem aktuellen "Wort". Wichtig: Dateien/Links dürfen keine Leerzeichen enthalten, denn die Funktion sucht das "Wort" das angeklickt wird.
  • Bauteil-Querverweis, siehe hier: "Bauteile verwalten"
  • Funktioniert in den Memo-Boxen der Tabellen-Feldern bauteil.Beschreibung, bauteillager.Bemerkung, bauteiladr.Bemerkung, projekt.Beschreibung, bestellen.Bemerkung, case.Text, adr.Bemerkung, historie.Beschreibung, wissen.Beschreibung
  • Erkennung Handbuch Verweis auf ($H) oder ($P) Verzeichnis, siehe Abschnitt "Handbuch-Datei" in dieser Seite.

Bildansicht Funktionen:

Mit der Bild-Ansicht können mit Hilfe der Bild-Taste nahezu überall kleine Bilder hinzugefügt werden:

  • Die Bilder sind dann immer rechts neben den Eingabemasken zu sehen.
  • Oberhalb vom Bild ist eine Taste "Bild" mit der eine Grafik eingefügt oder kopiert oder gelöscht werden kann.
  • Mit der Funktion "Extra Bild hinzufügen" können beliebig viele Bilder angehängt werden (außer bei der Typ-Ansicht)
  • EleLa wandelt eine Grafik automatisch in das PNG oder JPG Format, dabei wird nach deren Komprimierung entschieden welches Format am besten geeignet ist und speichert das in der Datenbank ab.
  • Eine Grafik darf nach dieser Komprimierung nicht größer als 65000 Byte sein. Sollte die Datei dennoch größer sein, so verkleinert EleLa automatisch die Grafik bis sie in diese 64 KB passen. Die Begrenzung ist bedingt durch die Datenbank.
  • Wenn das gespeicherte Bild größer als die derzeitige Ansicht ist, so kann mit Doppelklick auf die Grafik ein Vorschaufenster geöffnet werden. Dieses Fenster öffnet nur wenn nicht die ganze Größe sichtbar ist. Sobald man mit dem Mauszeiger auf das Bild geht zeigt sich eine Lupe, sofern sich ein Vorschaufenster öffnen lässt. Dieses Fenster kann mit der ESC Taste oder Doppelklick im Bild wieder geschlossen werden.
  • Wenn die Grafik ohne Farbverläufe ist, z.B. Export aus CAD-Programm, dann sind z.B 1000x600 Pixel Größe kein Problem, denn dann kann das PNG Format sehr gut komprimieren.

Das aller erste Bild, das eingefügt wird, ist immer das "Hauptbild". Das "Hauptbild" wird immer dann gezeigt wenn der Datensatz wechselt. Es können beliebig viele "Extra Bilder" angehängt werden, die werden im Popup-Menü bei der "Bild" Taste als "Extra Bild n" (n = fortlaufende Nummer) gezeigt und so ausgewählt werden. Die Extrabilder können nur da ausgewählt werden wo es die "Bild" Taste gibt, in den Dialogen ohne diese Taste wird immer das "Hauptbild" gezeigt.

Wenn man das Hauptbild löscht, so wird automatisch "Extra Bild 1" zum neuen "Hauptbild". Die Reihenfolge ist immer aufsteigend so wie man die Bilder hinzufügt.

Vorgehensweise Einfügen mehrerer Bilder:

  • Menüpunkt "Extra Bild hinzufügen".
  • Das aktuell sichtbare Bild wird geleert.
  • Erneuter Klick auf die "Bild" Taste zeigt nun die Einträge "Hauptbild" und "Extra Bild n" wobei beim letzte extra Bild das Häkchen gesetzt ist.
  • Nun kann mit "Einfügen" das zusätzliche Bild eingefügt werden.
  • Zwischen den Bildern kann nun im Menü bei der "Bild" Taste umgeschaltet werden.

Handbuch Datei:

In verschiedenen Ansichten kann eine Datei oder ein Verzeichnis als Handbuch hinterlegt werden. Dabei öffnet immer das hinterlegte Standard-Programm. Wenn der Eintrag ein Internet-Link ist so öffnet der Internet-Browser. Ist noch keine Datei hinterlegt so kann mit Hilfe eines Öffnen-Dialoges eine Datei ausgewählt werden. Bei einem Internet-Link sollte immer ein "http://" oder ein "www." oder ein "ftp://" zu Anfang stehen, ansonsten wird der externe Link nicht korrekt erkannt und es öffnet nicht der Internet-Browser. Als Start-Verzeichnis bei Neuauswahl wird immer das Verzeichnis das in der INI Datei unter

[Bauteil]
DefHanbuchDir=.\Handbuch
[Projekt]
DefHanbuchDir=.\Projekt

Eingetragen wurde ausgewählt. Wobei .\ zu beginn definiert, dass das Verzeichnis ab dem Ordner ist indem EleLa ausgeführt wird, somit ist EleLa portabel mit USB-Stick.
Man kann .\ oder ..\ als Erkennung für einen relativen Pfad angeben wobei EleLa damit automatisch ab dem Verzeichnis der EXE rechnet und diese .\ (aktuelles Verzeichnis) und ..\ (überliegendes Verzeichnis) automatisch berechnet und somit den absoluten Pfad in der Tabellen-Ansicht zeigt. Somit ist die Darstellung der Pfadangabe deutlich kürzer. Es können beliebig viele .\ und ..\ als Pfad-Angabe enthalten sein.

Wenn nun eine Handbuch Datei ab dem definierten Ordner der INI Datei ausgewählt wurde, so wird der in der Datenbank automatisch dieser definierte Präfix zu ($H) ersetzt. Beispiel:

INI-Datei: [Bauteil] DefHanbuchDir=D:\Handbuch
Auswahl Datei: D:\Handbuch\MeinBauteil\Demo.pdf
Eintrag Datenbank: ($H)\MeinBauteil\Demo.pdf
Ansicht in EleLa: D:\Handbuch\MeinBauteil\Demo.pdf

Tipp: Wenn man nun alle Handbücher an einen anderen Ort verschieben möchte, z.B nach H:\Handbuch, dann muss man nur die Konfigurationsdatei abändern:

INI-Datei: [Bauteil] DefHanbuchDir=H:\Elektronik

Dabei wird in EleLa die Ansicht automatisch so aussehen: H:\Elektronik\MeinBauteil\Demo.pdf und alle eingetragenen Links funktionieren weiterhin. Daher ist es hilfreich dass bereits zu Anfang dieser Parameter in der INI Datei korrekt gesetzt wird, denn man weiß nie ob man irgend wann einmal die Struktur ändern möchte.

In den Memo-Feldern können ebenfalls Handbücher eingetragen werden, hier muss allerdings von Hand der automatische Präfix eingetragen werden:

($H)\MeinBauteil\Demo.pdf
($P)\MeinProjekt\Demo.pdf

EleLa erkennt den Präfix ($H) oder ($P) zu Beginn und ersetzt den automatisch zum in der INI Datei eingegeben Präfix und startet dann das entsprechend installierte Standard-Programm.

INI-Datei Parameter | Präfix
[Bauteil] DefHanbuchDir= | ($H)
[Projekt] DefHanbuchDir= | ($P)

Achtung: Sollten andere Programme das Handbuch-Tabellenfeld der EleLa Datenbank benutzen, so sollte dieses Programm ebenfalls die Konvertierung des Präfixes beherrschen.

Drucken [image]:

Mit Drucken werden die Tabellen so wie in der aktuellen Ansicht von EleLa ausgedruckt. So die momentan sichtbaren Spalten und die Sortierreihenfolge. Wenn die Spalte "Foto_ID" mit gedruckt wird, dann wird nach der Datenzeile eine extra Zeile mit dem Bild hinzugefügt, sofern dem Datensatz ein Bild zugeordnet ist. Das Bild wird in die HTML Datei eingebettet.
Wenn Spalten mit den Namen Aufwand, Menge, GPreis, ID, Lief1_GPreis, Lief2_GPreis, Gewicht in der Tabelle vorhanden sind wird automatisch eine Summen-Zeile generiert, wobei bei eingeblendeter ID Spalte anstatt der Summe die Anzahl der Datensätze gezeigt wird.
Der Ausdruck erfolgt immer in eine HTML Datei, die im Ordner "TempDir" gespeichert wird und es öffnet sich der Internet-Browser. Anschließend kann mit Hilfe des Internet-Browsers der Ausdruck erfolgen oder man kann die Datei auch weiter verwenden.

Bei manchen Programmteilen können extra Ausdruckfunktionen mit rechtsklick auf diese Drucken-Taste gestartet werden.

Sperren aller Eingaben:

Mit der Funktion Sperren aller Eingaben werden alle Tabellen vor Änderungen geschützt, somit hat man mehr Sicherheit dass die Daten nicht unbeabsichtigt geändert werden. Mit Doppelklick auf die Statuszeile wird der Modus aktiviert und wieder deaktiviert.

Text | Beschreibung
RW | Alle Daten sind Änderbar, Daten können hinzugefügt und gelöscht werden
RO | Alle Datenmanipulationen sind gesperrt.

Tasten-Funktionen der Buttons:

Diese Funktionen sind standardmäßig hinterlegt, Details sind im jeweiligen Abschnitt der Hilfe beschrieben.

Taste | Beschreibung
 | Neue Position
 | Position kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Druck Etickett
 | Export
 | Bauteile in Kiste/Fach verwalten
 | Warenkorb-Taste, Eintrag in Bestellen
 | Auswahl eines Typs / einer Datei
 | Filtern Funktion, anhand aktuell ausgewähltem Datensatz
 | Öffnen der Datei / Internet Browser / Sprung zu Quell-Eintrag
 | Wählen Telefonnummer, Rechtsklick für Konfiguration


Bauteile Verwalten

Bauteile verwalten

In der Bauteilverwaltung werden alle Bauteile angelegt, Lager und Gehäusevarianten verwaltet und Lieferanten eingetragen.

In der Bauteil-Übersicht wird von einer Bauteilvariante nur der Haupt-Typ eingetragen, z.B. 7400. Die Untertypen wie z.B. 74HC00, 74LVX00 unter "Lager / Gehäuse". Oder unter Bauteil wird nur der Widerstandswert "R 4,7 KOhm" eingetragen, alle Leistungsklassen und Gehäuseformen kommen nach "Lager / Gehäuse".
Der Vorteil liegt auf der Hand, die Bauteileliste enthält dadurch viel weniger Einträge und ist somit übersichtlicher. Gleichzeitig sieht man unter "Lager / Gehäuse" alle Typen mit der gleichen Funktion.

Um ein Bauteil schnell auswählen zu können kann die Bezeichnung im Schnellsuchen-Feld neben dem Datum eingegeben werden. Dabei springt der Datensatz in den Tabelleneintrag. Zusätzlich können die Datensätze mit der [image] -Taste gefiltert werden, dabei kann auch das Wildcard-Zeichen "*" für beliebigen Text eingegeben werden um die Ansicht ein zu grenzen. Bei der Suche mit gedrückter "Y" Taste wird in den Feldern Bezeichnung und Beschreibung gesucht.

Mit der "Warenkorb-Taste" kann der Artikel in die Bestell-Vorschlagliste übernommen werden. Dabei wird gleich der Reiter "Bestellung" geöffnet und in das "Menge" Eingabefeld gesprungen. Wenn nur ein "Lager / Gehäuse" und ein "Lieferant" hinterlegt ist, so werden diese Daten ebenfalls automatisch in die Bestell-Vorschlagliste übernommen. Wenn mehrere Positionen unter "Lager / Gehäuse" bestehen, sollte die "Warenkorb- Taste" besser unter "Lager / Gehäuse" mit der richtigen Variante gedrückt werden.

Wenn ein Neues Bauteil angelegt wird, so muss eine Typ-Zuordnung mit der Taste "..." ausgewählt und eine "Bezeichnung" eingegeben werden. Mit der "Y" Taste kann auf den momentan gezeigten Typ gefiltert werden. Mit rechtsklick auf die "Y" Taste kann ein Dialog geöffnet werden, mit dem man ein Typ für die Filterung auswählen kann, dabei wird nicht nur nach dem gezeigten Typ, sondern auch alle Untertypen gefiltert/angezeigt. (Alternativ kann auch die Typ-Ansicht unter "Typ-F8" verwendet werden.)

Der Link zum "Handbuch" kann eine Datei sein oder man kann auch eine Internet-Adresse angeben, dabei muss ein "http://" voran stehen. Mehr kann unter "Allgemeine Infos" nachgelesen werden.

Im Textfeld unterhalb von "Library" kann eine Beschreibung des Bauteils eingegeben werden.

Ein Bild kann mit Hilfe der Taste "Bild" eingefügt, kopiert oder gelöscht werden. Es ist insbesondere darauf zu achten, dass es mit einem Zeichenprogramm verkleinert, bzw. optimiert wird. Es wird in der Datenbank in PNG Format abgelegt und sollte auf der Festplatte nicht mehr als 32KB haben. Nur so ist sichergestellt, dass es nicht zu großen Verzögerungen beim Laden von Bildern aus der Datenbank kommt.
Wenn das Bild in der Vorschau nicht ganz dargestellt werden kann, da das Mini-Fenster zu klein ist, so kann mit Doppelklick ein Vorschau-Fenster geöffnet werden.
Wenn man kein Bild hinterlegt hat, so such EleLa anhand der Typ-Zuordnung das Bild aus "Typ - F8". Wenn hier ein Bild hinterlegt wurde so wird das Bild angezeigt. Diese Funktion ist vor allem bei Widerständen oder Kondensatoren sehr Hilfreich, damit wird nur einmal ein Bild unter Typ in der Datenbank abgelegt und man braucht nicht für jeden Widerstand extra ein Bild einfügen. Wenn dem Typ kein Bild zugeordnet wurde, so wird im übergeordneten Typ das Bild gesucht.

Wenn der Datensatz kopiert wird, so wird das Bild nicht mit kopiert.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils gelöscht. Bei der Bestell-Liste wird die Bauteil-Zuordnung gelöscht, der Eintrag bleibt jedoch erhalten.

Export kann in ein CSV oder XML Format erfolgen. Wobei das CSV Format nicht alle Informationen enthält. Bei XML Export wird die Tabelle "Bauteil" sowie als Unterdatensätze alle "Gehäuse / Lager" sowie "Lieferanten" angehängt.

Unter Export können ebenfalls "Etiketten" gedruckt werden.

Unter Export kann ein Dialog gestartet werden, der zeigt alle Projekte in dem das aktuell ausgewählte Bauteil verwendet wird. Dabei werden unabhängig von der "Lager/Gehäuse" Variante alle Projekte gezeigt. Mit doppelklick im Dialog wird die Projektposition angewählt und zum Datensatz gesprungen.

Das Feld "Kennz" in der Tabelle ist ein frei verfügbares Zahlenfeld, in dem Sie das Bauteil speziell kennzeichnen können. Es kann z.B. dafür benutzt werden, wenn man sich das Bauteil für eine spätere Bearbeitung mal vormerken möchte, dass man es nicht vergisst. Das Feld wird nur in der Tabelle eingegeben.

Bauteil-Querverweise

Mit dieser Funktion können Querverweise zu anderen Bauteilen hergestellt werden, z.B. Identische Funktionen, oder Ersatztypen.
So geht es:
In Memo-Eingabefeldern kann der Text "bauteil.XXX" oder "bauteillager.XXX" eingegeben werden. Dabei ist XXX mit der ID-Zahl der Datenzeile zu ersetzen (rechts neben dem Drucken-Symbol ersichtlich). Wenn EleLa unter Bauteil oder Lager/Gehäuse (bauteillager) die ID findet, dann wird der Reiter Bauteil geöffnet und zum Bauteil gesprungen. Dabei wird eine Filterung auf einen Bauteil Typ deaktiviert.
Angewählt wird das Bauteil mit STRG + Mausklick auf das Wort "Bauteil.XXX" oder "Bauteillager.XXX".

Beispiel:

Dieser Bauteil-Querverweis geht bei allen Memo-Feldern.

Tipp:

Die Bauteilbezeichnung muss immer eindeutig sein. So kann als Bezeichnung nur z.B. ein "C 1uF" existieren. Alle Variationen des Bauteils müssen somit unter "Lager/Gehäuse" angelegt werden. Variationen sind z.B. die Typen Elko, Kerko oder Tantal und die verschiedenen Gehäuse-Varianten.
EleLa lässt nicht zu dass als Bauteilbezeichnung zwei mal der selbe Eintrag existiert, auch nicht wenn dem neuen Bauteil ein anderer Typ zugeordnet wurde.
Schlussendlich hat man somit einen besseren Überblick über alle Variationen des Wertes "C 1uF" und kann schneller einen passenden Ersatztyp finden sollte ein Bauteil mal leer sein.
Möchte man dennoch Elkos und Kerkos getrennt aufführen, so kann das Bauteil "C 1uF Elko" und "C 1uF Kerko" angelegt werden.

Taste Beschreibung

Neue Position

Position kopieren

Wenn auf diese Taste mit der rechten Maustaste geklickt wird, erscheint ein Popup-Menü mit dem man das ausgewählte Bauteil mitsamt "Lager/Gehäuse" Varianten kopieren kann. Dabei wird die Menge leer gelassen. "Lieferanten" werden nicht kopiert. Das so kopierte Bauteil erhält den Bezeichnungstext mit dem Zusatz " (Copy)", wenn dieser Name bereits existiert, so wird ein Eintrag "(Copy xxx)" generiert, wobei xxx die fortlaufende Nummer ist.
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle
Export von Bauteile
Druck Etickett
Warenkorb-Taste, Eintrag in Bestellen
Auswahl eines Typs / einer Datei
- Filter anhand Suchmaske Schnellsuchen-Feld.
- Filtern von Positionen anhand aktuellem Typ
Rechtsklick öffnet ein Popup-Menü, in dem man einen anderen beliebigen Typ auswählen kann nach dem gefiltert werden soll.
  • Öffnen der Datei / Internet Browser
  • Öffne "Kiste" mit Anzeige Eintrag
  • Öffne "Gehäuse" mit Anzeige Eintrag
  • Öffne Hersteller/Lieferant "Adresse" mit Anzeige Eintrag
  • ...

Das grau hinterlegte Feld in der Tabelle "Bauteil" kann nur über die Eingabemaske editiert werden.


Bauteile - Lager / Gehäuse

Bauteile verwalten - Lager / Gehäuse

Hier werden die Bauteilvarianten, Lagermengen und Gehäuseformen gespeichert. Das angezeigte Bild ist dem Gehäuse zugeordnet.

Die Eingabefelder müssen nicht ausgefüllt werden, nur das was man möchte.

Neben dem Mengen-Feld gibt es die Korrektur-Berechnung. Wenn z.B. 43 Stück aus dem Lager entnommen wurden und der Lagerbestand ist 821, dann ist es doch umständlich dies von Hand zu rechnen. Hier kann rechts neben dem Menge-Eingabefeld die Korrektur-Menge eingegeben werden und mit der - / + Taste der Bestand geändert werden. Die Menge wird bei der Minus-Taste auf 0 begrenzt. Wenn das Eingabefeld leer ist, so wird bei +/- mit der Menge 1 gerechnet.

Mit der "Warenkorb- Taste" wird der Artikel in die Bestell- Vorschlagliste übernommen. Ist zu dem "Lager / Gehäuse" Eintrag auch ein "Lieferant" hinterlegt so wird diese auch mit in die Bestell- Vorschlagliste übernommen. Wenn ein zweiter Lieferant gefunden wird, dieser ebenfalls.

Wenn als "Kiste" z.B. der "Sortierkasten" eingegeben wurde, so kann im Feld "Lager-Nr/Fach" die Box, z.B. "04 A" eingegeben werden. Als Eingabehilfe ist hier ein Drop-Down Feld, das alle "Lager-Nr" Eingaben der ausgewählten Kiste zeigt. Die Lager-Nr kann frei definiert werden. Lesen Sie über Etikettendruck, bevor Sie die Lagernummer festlegen, denn die Lagernummer bezeichnet z.B. eine Schublade aus einem Sortierkasten.
Zuordnen von Bauteile in Fächer einer "Kiste", z.B. eines Sortierkastens in die Schubladen kann mit dem Dialog Bauteile in Kiste/Fach verwalten gemacht werden. Damit können auch alle Bauteile eines Faches innerhalb eines Sortierkastens verschoben werden. Die Eingaben von "Bauteile in Kiste/Fach verwalten" werden in den Feldern "Kiste" und "Lager-Nr/Fach" gespeichert. Wenn ein Bauteil in mehreren "Kisten"/"Fächer" verteilt ist, so muss hier entsprechend viele Positionen vorhanden sein, denn jede Position kann nur ein Lagerfach merken.

Als Gehäuse können die Gehäuse ausgewählt werden die unter "Gehäuse" angelegt wurden. Mit der "..." Taste kann mit Hilfe eines Suchen-Dialogs ein Gehäuse ausgewählt werden:

In diesem Dialog kann gefiltert werden nach Typ (Baum links), sowie anhand einem Text im Suchen Feld die Eingabe begrenzt werden. Angezeigt wird auch das Bild das unter "Gehäuse" hinterlegt ist. Mit "OK" oder Doppelklick in die Tabelle wird der Dialog geschlossen und der Auswahl übernommen. Mit "Abbrechen" oder die ESC-Taste wird der Dialog ohne Änderung geschlossen.

Der Link zum "Handbuch" kann eine Datei sein oder man kann auch eine Internet-Adresse angeben, dabei muss ein "http://" voran stehen. Mehr kann unter "Allgemeine Infos" nachgelesen werden.

Im Eingabefeld unterhalb von Handbuch kann ein Beschreibungstext eingegeben werden.

Wenn um den Artikel in die Bestell-Vorschlagliste in diesem Reiter die "Warenkorb-Taste" gedrückt wird, dann wird automatisch auch die Information "Lager/Gehäuse" im Bestellvorschlag gespeichert. Damit wäre bei Status "geliefert" ein "buchen in Lager" mit automatischer Mengen-Korrektur möglich.

In der Tabelle ist ein zusätzliches Eingabefeld "MengeMin". Sobald dies eingetragen ist wird es farblich hinterlegt bei Mengen-Unterschreitung. Unter "Bestellung" können diese Artikel mit Hilfe der Funktion "Bauteile mit Min-Menge unterschritten" in die Bestell-Vorschlagliste übernommen werden. Das Feld wird nur in der Tabelle eingegeben.

Neben dem Häkchen "SMD" ist ein Eingabefeld für den SMD Marking-Code Aufdruck. Viele kleine Bauteile habe nur einen Marking-Code aufgedruckt anstatt der Typbezeichnung, dieser kann hier eingetragen werden. Sollte ein Bauteil mehrere unterschiedliche Marking-Codes haben, so können diese mit Semikolon ";" getrennt eingegeben werden. Unter "Extras > Rechner" werden alle Bauteile gefunden, die in diesem Eingabefeld hinterlegt werden.

In der Tabelle ist ein zusätzliches Eingabefeld "Haltbar". Sobald dies eingetragen ist wird es farblich hinterlegt. Hier kann ein Haltbarkeitsdatum für einen Artikel hinterlegt werden. Neben dem Eingabefeld kann mit der "..."-Taste ein Datum mit Hilfe eines Dialoges ausgewählt werden. Mit "Suchen" können alle Artikel gefunden werden, indem in die Suchen-Eingabe ein "**" eingegeben wird. Anschließend nach der Spalte "Haltbar" sortieren und man sieht sofort welche Artikel nicht mehr so lange haltbar sind.

In der Tabelle ist ein zusätzliches Eingabefeld "BWare". Damit kann definiert werden welchen Zustand das Bauteil hat. Bei Anwahl öffnet sich eine Liste in der man zwischen Neu, 2. Wahl, gebraucht, unbrauchbar und defekt auswählen kann.

In der Tabelle ist ein zusätzliches Eingabefeld "RoHS". Bei Anwahl öffnet sich eine Liste:

Ja | Artikel ist Rohs-konform
Ja-x | RoHS-konform da Ausnahmeprodukt laut Legislative
Nein | nicht RoHS-konform
nicht Relevant | Bestimmungen treffen für diesen Artikel nicht zu

Die Auswahlpunkte können mit der Übersetzen-Funktion beliebig erweitert oder geändert werden. Dabei stehen die Texte unter "Strings.63". Die einzelnen Texte sind mit "|" getrennt. Wenn in einer Auswahloption ein Leerzeichen enthalten ist, dann muss der Text in Anführungszeichen (") geschrieben werden. Die Optionen sollten im Nachhinein nicht mehr verschoben werden da diese nur als Zahl in der Datenbank gespeichert werden.
Auch die Auswahloptionen für das Feld "BWare" können mit der Übersetzen-Funktion geändert/erweitert werden, dabei ist der Text unter "Strings.67" abgelegt.

Das Feld "Kennz" in der Tabelle ist ein frei verfügbares Zahlenfeld, in dem Sie das Bauteil speziell kennzeichnen können. Das Feld wird nur in der Tabelle eingegeben.

Im Feld E-Preis kann der Einkaufspreis der Position eingegeben werden, falls man keinen Lieferant eingeben möchte. Dafür kann hier kein Lieferant/Bestell-Nummer eingegeben werden. Wenn man unter "Bestellung - F4" nach der Anlieferung des Bauteils "Buchen in Lager" ausführt, so wird auch dieses EPreis Feld mit dem Einkaufspreis gefüllt. Das Feld rechts neben EPreis ist der GPreis und wird automatisch anhand der Menge * EPreis gerechnet.

Barcode

Das Feld Barcode kann für unterschiedliche Dinge verwendet werden. Zum einen kann hier der Code des Artikels eingegeben werden, aber EleLa kann auch selbst anhand einer Mustervorgabe einen Barcode erzeugen. Der "Barcode" kann auch als Strichcode auf einem Etikett ausgedruckt werden.

Neben dem Eingabefeld vom Barcode können mit der "..." Taste die Funktionen "Erzeuge Barcode" und "Prüfe Barcode" ausgeführt werden. Bei der Erzeugung des Barcodes wird anhand der vorgegebenen Formatierung der Barcode erstellt. Mit "Prüfe Barcode" werden alle Bauteile in "Suchen - F5" gezeigt, die den gleichen Barcode haben. "Prüfe Barcode" ist nur aktiv, wenn tatsächlich doppelte Barcodes in der Datenbank existieren.

Formatierungscodes Barcode:

Zeichen | Beschreibung
# | ID des Lager/Gehäuse Eintrages
+ | Fortlaufende Nummer
B | ID des Bauteils
T | ID des Typs
K | ID der Kiste

Die Anzahl der Zeichen steht für die Anzahl der Stellen, die für den Code verwendet werden. Es können beliebig andere Zahlen und Buchstaben in der Formatierung verwendet werden.

Beispiel 1:
Ein Bauteil hat die Gruppen-Nummer 100 und soll eine 4 stellige fortlaufende Nummer erhalten.
Format: 100++++
Ergebnis: erstes Bauteil: 1000001, zweites Bauteil: 1000002, letzt mögliches Bauteil: 1009999, beim 10000sten erscheint eine Fehlermeldung.

Beispiel 2:
Es soll ein 6-stelliger möglichst einfacher aber sicherer Barcode erzeugt werden, der garantiert nicht doppelt vorkommt:
Format: ######
Ergebnis: Bei jedem Bauteil wird die ID-Zahl der Datenbank verwendet. Dabei werden führende Nullen automatisch hinzugefügt: 000011

Eingabe des Barcode-Formats:

  • Default Barcode Format wird unter "Extras-F10" > "Log" > "Optionen" > "Extras" im Feld "Barcode-Format" eingegeben. Diese Einstellung ist für alle EleLa Benutzer gleichermaßen gültig.
  • Je Bauteil-Typ ("Typ - F8") kann eine Formatierung festgelegt werden. Dazu in der Baumansicht den jeweiligen Typ auswählen und unten im Feld "Barcode-Format" die Formatierung festlegen.

Die Reihenfolge, welche Formatierung EleLa verwendet: Zu erst wird anhand des Typs die Formatierung gesucht. Sollte der ausgewählte Typ keine Formatierung haben, so wird im überliegenden Typ gesucht. Sollte in den Typ Deklarationen keine Formatierung enthalten sein, so wird die Formatierung des EleLa Optionen-Dialogs verwendet. Default Format: "######".

Fehler bei der Barcodeerzeugung: Sollte die Zahl in der vorgegebenen Formatierung nicht hinein passen, so schreibt EleLa in der Statusleiste sowie im Logbuch eine Fehlermeldung. Beispiel: Format ist "###" aber die ID ist 1000, also eine Stelle zu viel.

Taste Beschreibung

Neue Position

Position kopieren

Rechtsklick auf diese Taste öffnet ein Popup-Menü. Damit kann dieser Lager/Gehäuse-Eintrag unter ein anderes Bauteil verschoben oder kopiert werden. Wenn der Eintrag verschoben wird, so werden auch die Einträge unter "Lieferanten", "Bestellungen" und "Projektpositionen" mit geändert.
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle. Zusätzlich wird im Ausdruck der GPreis errechnet und gezeigt.
Bauteile in Kiste/Fach verwalten
Warenkorb-Taste, Eintrag in Bestellen

Auswahl eines Gehäuses
Auswahl "Haltbar bis" Datum mittels Dialog
Erzeuge/prüfe Barcode
Auswahl einer Hilfe-Datei
Filtern von Positionen anhand aktuellem Typ
Rechtsklick öffnet ein Popup-Menü, in dem man einen anderen beliebigen Typ auswählen kann nach dem gefiltert werden soll.
  • Öffnen der Datei / Internet Browser
  • Öffne "Kiste" mit Anzeige Eintrag
  • Öffne "Gehäuse" mit Anzeige Eintrag
  • Öffne Hersteller/Lieferant "Adresse" mit Anzeige Eintrag
  • ...

Zusätzliche Tastenfunktionen:

  • Strg + +: Setzt den Eingabefokus auf das Mengen-Feld mit dem man mit +/- den Lagerbestand manipulieren kann
  • Wenn der Eingabecursor im Eingabefeld der Menge ist, mit der man mit +/- den Lagerbestand ändern kann, so kann mit der Tastatur mit den Tasten + / - der Bestand erhöht / verringert werden.


Bauteile Verwalten

Bauteile verwalten - Lieferanten

Hier wird dem Lager/Gehäuse ein Lieferant zugeordnet und der Einkaufspreis eingetragen.

Im Eingabefeld unterhalb von "Gehäuse/Lager" kann ein Beschreibungstext eingegeben werden.

Wenn um den Artikel in die Bestell-Vorschlagliste in diesem Reiter die "Warenkorb-Taste" gedrückt wird, dann wird automatisch auch die Information "Lager/Gehäuse" und "Lieferant/Lager/Gehäuse" im Bestellvorschlag gespeichert. Die hinterlegte Staffelpreis (> 1) Menge wird ebenfalls übernommen. Wenn für den ausgewählten "Gehäuse/Lager" Eintrag ein zweiter Lieferant hinterlegt ist, dann wird diese als Lieferant 2 übernommen. Damit wäre bei Status "geliefert" ein "buchen in Lager" mit automatischer Mengen-Korrektur und eine Übernahme des Einkaufspreises möglich.

Wenn eine Lager/Gehäuse Variante ausgewählt wird, so wird als Bestell-Nr die Bezeichnung aus Lager/Gehäuse einkopiert. Diese kann jederzeit überschrieben werden.

Mit der GoTo-Taste neben dem Warenkorb-Symbol kann zu der Lieferanten-Homepage gesprungen werden. Wenn unter "Adresse" in der Internetseite der Text "<BESTELLNR>" mit eingetragen ist, so wird dieser Text mit der Bestell-Nr ersetzt und man hat die Möglichkeit dass direkt der Artikel des Lieferanten aufgerufen wird. Beispiele sind unter "Adresse" hinterlegt.

Staffelpreise:

Mit "Ab Menge" kann definiert werden ab welcher Menge der Preis gültig ist. Hierfür wird der Eintrag mit der "Adresse", "Lager/Gehäuse" und "Bestell-Nr" kopiert und eine neue "Ab Menge" eingetragen sowie der Preis für diese Menge. Somit kann man für einen Artikel viele Staffelungen hinterlegen. Beispiel:

VPE - Verpackungseinheit:

Im Feld VPE kann die Menge die in der Verpackung ist eingetragen werden.
Beispiel Bestellung Schrauben: Eine Packung enthält z.B. 100 Stück. Somit wird als VPE 100 ein getragen. Wenn nun eine Packung bestellt wird und nach der Anlieferung unter "Bestellung" die Funktion "In Lager Buchen" aus führt, so wird die bestellte Menge * VPE Menge gerechnet und diese Menge wird dem Lager unter "Lager/Gehäuse" hinzugefügt.
Beispiel Projekt: Mit der Funktion "Prüfe Menge für Produktion" unter "Projekt" können Bauteile direkt zur Bestell-Liste hinzugefügt werden. Dabei wird die VPE-Menge des Bauteils berücksichtigt. Wenn z.B. die VPE-Menge 100 ist und es werden 143 Stück für die Produktion benötigt, so wird in der Bestellung 2 als Menge zu bestellen eingetragen.
Vorsicht: Wenn nun ein anderer Lieferant mit anderen VPE Mengen ausgewählt wird, so muss man die korrekte Menge der zu Bestellenden Bauteile selbst korrigieren!

Taste Beschreibung

Neue Position
Position kopieren
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle
Warenkorb-Taste, Eintrag in Bestellen
  • Öffnen der Datei / Internet Browser
  • Öffne Hersteller/Lieferant "Adresse" mit Anzeige Eintrag
  • Öffne Internet-Seite des Lieferanten
  • ...


Bauteile Verwalten

Bauteile verwalten - Bestellungen

Hier sind alle Bestellungen, auch Archivierte zu dem Bauteil ersichtlich. Änderungen können nicht vorgenommen werden, diese Ansicht dient nur zu Übersicht.

Im Auswahlfeld kann anhand "Lager/Gehäuse" gefiltert werden. Mit der ">>" Taste kann zum "Lager/Gehäuse" Eintrag gesprungen werden.

Mit der ">>" Taste bei Bezeichnung oder Doppelklick in der Tabelle kann zur Bestell-Ansicht gewechselt werden, dabei wird automatisch die Archiv-Ansicht gezeigt wenn es eine Archiv-Position ist.

Die Liste kann mit der Tastenkombination "STRG+P" als HTML-Dokument ausgedruckt werden.


Bauteile in Kiste/Fach verwalten

Bauteile in Kiste/Fach verwalten

Hier können Bauteile frei dem Lager Kisten / Fächern zugeordnet werden. Dieser Dialog öffnet man unter "Bauteile">"Lager/Gehäuse" oder "Kiste" oder mit der Tastenkombination STRG+K.

Aufteilung:

  • Auf der linken Seite ist der Baum mit allen "Kisten" und den dazu geordneten "Lager-Nr" Einträge (aus "Bauteil" > "Lager/Gehäuse")
  • In der mittleren Tabelle sieht man den Inhalt des Faches, das man mit dem linken Baum ausgewählt hat.
  • In der rechten Tabelle sieht man alle "Bauteile" samt "Lager/Gehäuse" Varianten

Funktionen:

  • Taste "Bauteil aus Kiste entfernen" wird aus dem ausgewählten Bauteil der mittleren Tabelle das Feld "Kiste" und "Lager-Nr" leeren.
  • Taste "Bauteil aus Lagerfach entfernen" wird aus dem ausgewählten Bauteil der mittleren Tabelle das Feld "Lager-Nr" leeren.
  • Taste "Bauteil in Lagerfach hinzufügen" wird das ausgewählte Bauteil der rechten Tabelle in die Kiste/Lager-Nr (Fach) aus dem linken Baum zuordnen. wenn das Bauteil bereits einem anderen Fach zugeordnet war wird diese alte Information überschrieben. Dabei wird das Feld "Kiste" und "Lager-Nr" aus "Bauteil" > "Lager/Gehäuse" beschrieben.
    Sollte beim ausgewählten Bauteil unter "Bauteil" > "Lager/Gehäuse" noch kein Eintrag existieren so wird ein neuer automatisch angelegt damit die Information "Kiste" und "Lager-Nr" gespeichert werden kann.
  • Taste "Lagerfach Hinzufügen" fügt im linken Baum unterhalb einer Kiste ein neues Lagerfach hinzu. Solange dem Fach kein Bauteil zugeordnet ist existiert es nur Temporär und ist nach dem Schließen des Dialogs wieder weg.
  • Taste "Lagerfach Umbenennen" benennt bei dem Feld "Lager-Nr" von "Bauteil" > "Lager/Gehäuse" bei allen im Fach liegenden Bauteilen um. Sollte der neue Fach-Name bereits existieren, dann hat man beide Fächer (die Bauteile) zusammengeführt in ein Fach.
  • Taste "Inhalt nach Kiste / Lager-Nr verschieben" verschiebt eine ganzes Fach in eine andere Kiste und benennt das Fach auch gleich mit um.
  • Mehrfach Markierung in den Tabellen mit STRG + Mausklick oder mit SHIFT + Cursortasten.
  • Popup-Menü in allen 3 Spalten mit den möglichen Funktionen

Drag & Drop:
Mit Drag&Drop können Bauteile in/aus Lagerfächer gezogen oder ganze Fächer in den Kisten verschoben werden. Um Darg&Drop benutzen zu können muss die STRG-Taste gedrückt und das Bauteil / Fach gezogen werden.

  • Fach von Kiste-Baum in Kiste-Baum verschieben. Wenn dieses Fach in der anderen "Kiste" bereits existiert hat man die Möglichkeit ab zu brechen oder das Fach um zu benennen oder es werden beide Fächer zusammengeführt.
  • Inhalt von Kiste in anderes Fach in Baum verschieben
  • Inhalt von Kiste raus nehmen (in Bauteile-Liste verschieben)
  • Bauteil aus Bauteile-Liste in Inhalt von Kiste verschieben
  • Bauteil aus Bauteile-Liste in Kiste-Baum/Fach verschieben

Wegen der Drag&Drop-Funktion muss man um eine Spalte der Tabelle zu verbreitern zusätzlich die Shift-Taste drücken.

Ich denke ich habe nichts vergessen und man kann somit alle Bauteile frei Zuordnen. Wenn man ein Bauteil in ZWEI Fächer unterbringen muss, dann muss unter "Bauteil">"Lager/Gehäuse" der Eintrag kopiert werden und kann einem zweiten Fach zugeordnet werden. So können unendlich viele Fächer für ein Bauteil angelegt werden.

Doppelklick auf ein Bauteil von der Tabelle "Inhalt von Kiste/Box" springt zum Bauteil in der Tabelle "Bauteil-Liste".

Mit der Taste "Schließen wird der Dialog geschlossen. Dabei wird die Position gespeichert, so dass beim nächsten öffnen der Dialog wieder an der gleichen Position/Größe erscheint.

Tipp Fach tauschen:

Wenn ein Fach mit einem anderen im Sortierkasten getauscht werden soll, dann wird dies folgendermaßen gemacht:

  • erstes Fach umbenennen, z.B. "03A" in "03 A alt"
  • zweites Fach umbenennen von z.B. "03 B" in "03 A"
  • dann erstes Fach umbenennen von "03 A alt" in "03 B"

Das erste umbenennen muss sein, denn wenn das Fach gleich auf "03 B" umbenannt werden würde, dann wandern alle Bauteile in dieses eine Fach.


Etikett drucken

Etikett drucken

Hier können Etiketten / Beschriftungsschilder für Sortierkästen gedruckt werden. Diese Funktion wird unter "Bauteil" > "Exportieren" > "Drucke Etikett" geöffnet.

Als erstes wird der Sortierkasten ausgewählt für den man Etiketten drucken möchte. Es werden nur Kisten in die Liste eingetragen, bei denen unter "Bauteil" > "Lager / Gehäuse" auch eine "LagerNr" hinterlegt wurde. Mit der Taste ">>" kann die Tabelle gezeigt werden welche Bauteile alles in diesem Sortierkasten einsortiert sind. Doppelklick auf der Tabelle wechselt im Hauptprogramm die Seite und springt zum "Bauteil". Mit der rechte Maustaste auf der Tabelle kann diese auch gedruckt werden.

Anschließend muss das Etikett-Format festgelegt werden. Der "Standard Sortierkasten ist das "Conrad Werkstattmagazin 813112" (ich mache ungern für etwas Werbung, aber das ist der einzige Kasten, bei dem man in die Schublade einen Zettel rein schieben kann und zudem relativ günstig ist. Außerdem habe ich davon viele rumstehen ;-) )

Wenn als Etikett-Format "Individuell" ausgewählt wurde, so kann die Höhe / Breite selbst bestimmt werden.

Um die Etikett-Größe optimal ausnutzen zu können kann man die Schriftgröße / Art noch anpassen. Möchte man z.B. eine Liste auf ein DIN-A4 Blatt haben, so muss die Größe individuell auf Breite 180 und Höhe 250 eingegeben werden.

Im Abschnitt Barcode kann ein zusätzlicher Barcode in den Ausdruck gedruckt werden. Weiter unten ist mehr über Barcode beschrieben.

Mit der Definition "Ausrichtung" kann bestimmt werden wie der Text in den Rahmen gezeichnet wird. "Linksbündig" wird der Textblock nach oben/links begonnen, "Mittig" wird der gesamte Textblock zentriert je Box der Kiste ausgegeben.

Unter "Auswahl Felder" kann zusätzlich definiert werden welche Felder auf dem Etikett erscheinen sollen.

Bei "Druck" geht es los. Es öffnet sich ein Drucker-Dialog in dem der Drucker ausgewählt werden kann. Ich empfehle für den ersten Test ein Ausdruck mittels PDF Drucker, z.B. "FreePDF XP" oder "PDF Creator", beides ist Freeware in Sourceforge.net. Dies spart einiges an Papier. Dennoch, der "Echte" Drucker hat eine andere Seitenskalierung und der Ausdruck kann dann etwas anders aussehen. Das Programm rechnet die DPI des Druckers in die richtigen mm-Koordinaten um. Daher kann es vorkommen, dass der PDF-Ausdruck aus der erzeugten PDF nicht passt, bzw. beim PDF Ausdruck muss auf 100% Skalierung geschaltet werden. Also besser mit diesem Programm auf den Drucker direkt drucken.

Nach Auswahl des Druckers wird eine Seite erzeugt und zu erst das Raster der Feldgrößen Breite/Höhe gezeichnet.

Anschließend wird in jedes Feld ein Text eingestellt, der folgendermaßen zusammengesetzt ist:

  • Fachbezeichnung: "[ bauteillager.LagerNr ]", wobei alle Bauteile und Gehäuse hier in dieses Fach gedruckt werden
  • Bauteilname: "bauteil.Bezeichnung :", wobei mehrere Bauteile in einem Fach liegen können, die Einträge werden mit "/" getrennt.
  • Gehäuse: "bauteillager.Bezeichnung/case.Bezeichnung", wobei mehrere Einträge je Bauteil eingetragen werden, die Einträge werden mit "|" getrennt.

Wenn die Textbreite einer Zeile nicht ausreicht wird die Schriftgröße dieser Zeile automatisch verringert, sollte dies immer noch nicht reichen wird der Text abgeschnitten.
Der Text wird mehrzeilig ausgegeben. Wenn die maximale Höhe überschritten wurde, wird der Text-Block in einer kleineren Schriftgröße ausgegeben, sollte es nicht reichen wird er dennoch ausgegeben und man sieht es im Ausdruck und kann die "Schriftart / Schriftgröße" so anpassen bis es passt. (Daher der Test-Ausdruck mit dem PDF Drucker).

Sollten zu viele Bauteile in einer Box liegen, so dass nicht alles auf ein Etikett passt, dann muss man doch einige Typen herausnehmen und ein neues Fach dafür anlegen. (Beispiel: Box Sortierkasten kann Unterteilungen haben, darin kann man problemlos 10 unterschiedliche Quarze rein machen, 10 Typen passen aber garantiert nicht auf das Etikett...)

Die kleinste Schriftart die errechnet wird ist die Größe 5.

Sollte die Seite nicht für alle Fächer reichen, dann wird eine neue Seite angefangen, solange bis alle Datensätze gedruckt sind.

EleLa merkt sich für jede Kiste die eingestellten Parameter bei "Druck". Wenn eine andere Kiste ausgewählt wird, so wie die letzte Einstellung vom Ausdruck wiederhergestellt. Wenn man nur die Eingaben speichern möchte, so kann mit "Druck" der Ausdruck gestartet und anschließend die "Abbruch" Taste im Druckerauswahl-Dialog gedrückt werden.

Tipp:

Die Reihenfolge des Ausdrucks ist sortiert nach "bauteillager.LagerNr" und der Text wird von links nach Rechts, dann nach unten ausgegeben. Bei diesem angewählten "Standard Sortierkasten" passen gerade zufällig 5 Etikette nebeneinander, so wie auch Schubladen drin sind. Daher empfiehlt sich die die LagerNr so zu vergeben: "01 A" = Zeile 01; Spalte 1 ... "12 E" = Zeile 12; Spalte 5.

Barcode:

Je Lagerfach kann ein Barcode ausgegeben werden. Sollten mehrere Bauteile im Lagerfach liegen, so wird nur der erste verfügbare Barcode ausgedruckt. Der Barcode wird unter "Bauteil" > "Lager/Gehäuse" im Feld Barcode eingegeben, somit besteht die Möglichkeit unabhängig von der Lager-Nr/Fach Bezeichnung eine Nummer zu vergeben.

Zur Auswahl stehen die Barcodes:

Code | Bemerkung | Vorteil | Nachteil
kein | damit ist die Barcode-Funktion deaktiviert |  |
2 OF 5 INTERLEAVED | Für Zahlen 0..9, gerade Anzahl von Stellen (2, 4, 6, ...) | klein | Anzahl Stellen immer paarweise
CODE128 | Für Zahlen und Buchstaben | viele mögliche Zeichen | groß
EAN-13 | Für Zahlen 0..9, 12 Zahlen + Checksumme | mit Prüfsumme, für Waren aus dem Supermarkt | muss 12 Zahlen + Prüfsumme haben
CODE39 | Für Zahlen, Buchstaben und Sonderzeichen | mit Prüfsumme, viele mögliche Zeichen, unbegrenzte Anzahl Zeichen | groß

Wenn im Feld Barcode ein Text steht, der Buchstaben enthält, dann wird nur ein Barcode bei der Auswahl "CODE128" ausgegeben.

2 OF 5 INTERLEAVED: Sollte das Feld Barcode eine ungerade Anzahl von Stellen haben, so wird automatisch eine 0 vorne angefügt.

CODE128: Sollte im Feld Barcode nur Zahlen stehen und diese sind in einer geraden Anzahl Stellen, dann wird der CODE128C verwendet ansonsten CODE128B. Im CODE128C können zwei Zahlen als ein Code-Block dargestellt werden, daher die Zweier-Teilung.
Mit dem Code 128B sind folgende Zeichen möglich:
Leerzeichen, !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyyz{|}~

EAN-13: Im Feld Barcode müssen 12 oder 13 Stellen stehen. Wenn weniger als 12 Stellen stehen, so werden links 0en (Null) angefügt. Wenn mehr als 13 Stellen stehen werden die hinteren Stellen (rechts) abgeschnitten. Wenn der Barcode nur 12 Stellen hat so wird automatisch eine Modulo10 Checksumme errechnet und diese als 13. Stelle angefügt. Wenn der Barcode 13 Stellen hat wird die Checksumme für den Ausdruck nicht extra kontrolliert, EleLa druckt das einfach.

CODE39: Es sind die Zeichen: Leerzeichen, 0..9, A..Z und -.$/+% erlaubt. Es kann eine beliebige Anzahl von Zeichen gedruckt werden. EleLa fügt automatisch die Startkennung, Ende-Kennung und eine Prüfsumme hinzu.

Der Ausdruck vom Barcode:

Die Höhe gibt die Anzahl der Zeilen an. 1 bedeutet so hoch wie eine Textzeile. Der Ausdruck des Barcodes kann maximal 3 Textzeilen hoch sein. Manche Scanner benötigen eine Mindesthöhe, auch ist das Scannen mit einem Laserscanner bei höherem Barcode leichter.

Die Breite gibt an wie breit minimal ein Strich des Barcodes sein soll. Als Standard reichen 1/4mm aus. Wenn der Drucker eine schlechte Qualität druckt sollte ein breiterer Strich gewählt werden. Wenn der Barcode im Ausdruck breiter wird als wie die Breite des Etiketts definiert wurde, so verkleinert EleLa automatisch den Barcode so dass er in das Etikett rein passt. Daher sollte der Barcode nach dem Ausdruck immer auf korrekte Funktion geprüft werden.

Mit dem Häkchen "Mit Barcode als Text" wird unter dem Barcode der Barcode-Text ausgegeben und zwar in der Form wie der Barcode als Strichcode gezeichnet wurde, also mit den führenden Nullen und der errechneten Prüfsumme.

Der Barcode wird immer Oben/Mitte im Etikett gedruckt. Die Textausgabe des Barcodes immer in der Mitte unterhalb des Barcodes.


Projekt

Projekte Verwalten

Hier werden die Projekte verwaltet.

Die Bezeichnung der Projekte muss eindeutig sein.

Als Handbuch kann das Projektverzeichnis angegeben werden. Sollten mehr Verzeichnisse benötigt werden, so können diese auch in das Memo-Feld eingegeben werden.

Das Projekt kann mit einem Bauteil verknüpft werden. Damit ist das Ergebnis dieser Produktion ein Gerät, das als "Bauteil" verwaltet wird.

Wenn ein Termin in der Zukunft eingegeben wird, so wird EleLa eine Hinweis-Box öffnen und auf den fälligen Termin hinweisen sobald das Datum erreicht wurde.

Unter "Positionen" können alle Bauteile eingetragen werden. Hier können auch Bauteile eingetragen werden die nicht unter "Bauteile" angelegt wurden.

Mit der Taste neben dem Eingabefeld "Menge Offen" können die Funktionen "Prüfe Menge für Produktion" und "Buche Menge nach Produktion" durchgeführt werden.

Funktion "Buche Menge nach Produktion":

  • Sicherheitsfrage ob man wirklich die Mengen buchen möchte.
  • Abbuchen der Lagerbestände von "Bauteil" > "Lager / Gehäuse" aller anhand der ausgewählten "Variante" unter "Positionen" anhand der produzierten "Menge Offen" * "Menge" der Position
  • Sollten Lagerbeständen eine Negativen Wert annehmen, dann wird der Lagerbestand auf 0 begrenzt.
  • Erhöhung "Menge Fertig" um "Menge Offen" und setzen "Menge Offen" auf 0.
  • Wenn das Projekt mit einem Bauteil und Lager/Gehäuse verknüpft wird, wird die Menge um die "Menge Offen" erhöht und somit der Lagerbestand nach Produktion angepasst.

Der Link zum "Handbuch" kann eine Datei sein oder man kann auch eine Internet-Adresse angeben, dabei muss ein "http://" voran stehen. Mehr kann unter "Allgemeine Infos" nachgelesen werden.

In der Tabelle hat man zusätzliche Eingabemöglichkeiten einer Adresse oder OptA, OptB und OptC (Optionen). Die Spalten-Titel der Optionen können mit Hilfe der Übersetzen-Funktion umbenannt werden. EleLa hat die Optionen als Auswahlfelder für Ja/Nein vorbelegt, man kann jedoch andere Texte hinterlegen. Hierzu muss mit Hilfe der Übersetzen-Funktion der Text geändert werden, dabei können beliebig viele Auswahl-Optionen erzeugt werden. Die Textliste für das Feld "OptA" ist im Übersetzungs-Text "Strings.64", "OptB" in "Strings.65" und "OptC" in Strings.66" abgelegt. Die einzelnen Texte sind mit "|" getrennt. Wenn in einer Auswahloption ein Leerzeichen enthalten ist, dann muss der Text in Anführungszeichen (") geschrieben werden.
Beispiel: Ja|Nein|"keine Auswahl"
Die Optionen sollten im Nachhinein nicht mehr verschoben werden da diese nur als Zahl in der Datenbank gespeichert werden (In diesem Beispiel 1, 2 oder 3).

Unter "Historie" kann der Projektverlauf aufgezeichnet werden.

Taste Beschreibung

Neue Position

Position kopieren

Wenn auf diese Taste mit der rechten Maustaste geklickt wird, erscheint ein Popup-Menü mit dem man das ausgewählte Projekt mitsamt "Positionen" kopieren kann. Historien-Einträge werden nicht kopiert. Das so kopierte Bauteil erhält den Bezeichnungstext mit dem Zusatz " (Copy)", wenn dieser Name bereits existiert, so wird ein Eintrag "(Copy xxx)" generiert, wobei xxx die fortlaufende Nummer ist.
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle

Export / Import-Funktion

  • Export der Projekt-Liste als CSV oder XML Datei
  • Öffne "Bauteil" und Anzeige
  • Öffne "Lager/Gehäuse" von Bauteil und Anzeige
  • Auswahl einer Datei
  • Prüfen / Buchen Lagermengen


Projekt Positionen

Projekte Verwalten - Positionen

Hier werden die Bauteile eines Projektes verwaltet. Als Positionen können entweder Bauteile aus "Bauteile" oder beliebig andere Teile aufgenommen werden.

Entweder es wird jedes einzelne Bauteil einer Schaltung aufgenommen, z.B. R1, R2 usw. oder es wird eine Position für z.B. alle R's mit 10 KOhm und der Anzahl Menge angelegt.

Das Eingabefeld neben dem Datum ist ein Schnellsuchen-Feld, in dem man eine Position schnell finden kann. Der Text in Klammern "(Bezeichnung)" zeigt die Spalte in der gesucht wird. Die Suchspalte kann geändert werden indem auf den Spaltentitel der Tabelle geklickt wird. Dadurch ändert sich auch die Sortierreihenfolge. Um z.B. nach dem Symbol zu suchen muss zu erst auf den Spaltentitel "Symbol" geklickt werden, dann erscheint neben dem Schnellsuchen-Feld "(Symbol)", dann kann im Schnellsuchen-Feld die Symbol-Bezeichnung eingegeben werden.

Sobald ein Bauteil ausgewählt wird wird die Bezeichnung von der Bezeichnung des Bauteils überschrieben. Sollte im Bauteil nur eine Lager/Gehäuse Variante angelegt sein, so wird automatisch das Feld "Lager/Gehäuse" beschrieben.
Mit der "..." Taste kann ein Bauteil-Suchen Dialog geöffnet werden:

Auswahl anhand Typ, Suchen-Eingabefeld, Bild. Mit OK oder Doppelklick auf die Tabelle wird das Bauteil sowie Lager/Gehäuse übernommen.

Das "Lager/Gehäuse" Feld wird gefüllt anhand der Einträge die dem Bauteil hinterlegt sind. Sobald hier ein Eintrag ausgewählt wird, werden die Felder "Gehäuse" und "SMD" überschrieben und in der Spalte "Kiste" / "LagerNr" wird der Lagerort mit angezeigt.

im Feld "Variante" kann die Bestückungsvariante definiert werden. Hier kann z.B. RS232 bei den Bauteilen des RS232 Anschlusses eingetragen werden. Mit der Filter-Funktion können dann alle Varianten ausgewählt werden, die bestückt werden sollten. Es können unter Variante auch mehrere Varianten definiert werden, wenn z.B, das Bauteil für RS232 und CAN benötigt wird, dann hier "RS232|CAN" eintragen. Als Trennzeichen wird ein "|" oder "/" erkannt.

Jeder Position kann ein Status gesetzt werden. Mit der "..." Taste neben den Status-Tasten können von allen Bauteilen der Status gesetzt werden und es kann bei einer "Handbestückung" eine Lagerbuchung gemacht werden. Wenn über diese Funktion die Lagerbuchung durchgeführt wird, dann wird die Position als Status "Fertig" markiert und es wird die Menge "Menge Offen" * "Menge" der Position vom Lager abgebucht. Es sollte bei einzelner Lagerbuchung die Funktion "Buche Menge nach Produktion" nicht mehr ausgeführt werden, da ansonsten die Mengen doppelt abgebucht werden.

Farbe | Status
 | kein Status
O | offen
A | aktiv
F | fertig
P | prüfen
N | nicht verwendet

Zusätzlich kann die Position der Bauteile aufgeschrieben werden, "Top", "Pos X" und "Pos Y. Wobei die Positionen nur als ganze Zahlen eingebbar sind.

Jeder Position kann ein E-Preis angegeben werden. Der G-Preis errechnet sich automatisch sobald der E-Preis oder die Menge ändert. Die Summe zeigt die Summe aller Positionen an, dabei wird der gesetzt Filter berücksichtigt. Der E-Preis wird automatisch aus dem Bauteil übernommen sobald eine Lager/Gehäusevariante ausgewählt wurde, ist ein "Lieferant" angelegt, so hat dieser E-Preis Vorrang vor dem E-Preis der unter "Lager/Gehäuse" angelegt ist.
Wenn sich der E-Preis des Bauteils ändert wird der neue E-Preis nicht automatisch in die Projektposition übernommen.

Werkzeug "Import/Export":

Mit den Werkzeugen "Schnelleingabe" kann die Liste mit wiederholenden Bauteilen gefüllt werden. Mit "Import CAD CSV" durch einen Export mit Hilfe eines CAD Programms.

Mit dem Werkzeug "Import/Export" > "Kopiere Bauteil/Lager/Gehäuse" können nicht zugeordnete Bauteile nach einem Import schneller zugeordnet werden. Dabei muss zu erst ein Bauteil, z.B. Kondensator 100nF zu einem Bauteil / Lager/Gehäuse zugeordnet werden, anschließend, wenn noch mehr Bauteile mit gleichem "Wert" / "Gehäuse" in den Positionen stehen, die noch nicht mit einem Bauteil zugeordnet wurden, können diese mit dieser Funktion zugeordnet werden. Dieser Menüpunkt ist nur aktiv wenn in der Liste noch zuordnen bare Bauteile sind.

Das angezeigte Bild ist das unter "Bauteil" hinterlegte Bild. Siehe Beschreibung unter "Bauteile Verwalten".

Taste Beschreibung

Neue Position

Position kopieren

Rechtsklick auf diese Taste öffnet ein Popup-Menü. Damit kann diese Position unter ein anderes Projekt verschoben oder kopiert werden.
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle

Export / Import-Funktion

  • Schnelleingabe von Bauteilen
  • Kopiere Bauteil/Lager/Gehäuse auf nicht zugeordnete Positionen
  • Import von Target-STK / CSV Dateien
  • Export der Projekt-Liste als CSV oder XML Datei
Warenkorb-Taste, Eintrag in Bestellen
  • Öffne "Bauteil" und Anzeige
  • Öffne "Lager/Gehäuse" von Bauteil und Anzeige
  • Öffnet Bauteil-Auswahl/Suchen Dialog
  • Status: Lagerbuchung und globale Statusänderungen
Filter anhand Variante, öffnet ein Popup-Dialog mit allen dem einen Projekt hinterlegten Varianten


Projekt - Schnelleingabe

Projekte Verwalten - Schnelleingabe von Positionen

Hier können wiederholende Bauteile zu "Projekt Positionen" hinzugefügt werden.

Es wird das "Bauteil" ausgewählt, die dazugehörige "Lager/Gehäuse" Variante.

Nach Auswahl des Bauteils wird automatisch der Typ eingetragen. Anhand diesem Typ kann ein Filter mit der Taste "Y" gesetzt werden, dabei wird die Bauteil-Auswahl begrenzt anhand dem Typ. Mit der Taste "..." kann auch ein anderer Typ anhand eines Dialoges ausgewählt werden.

Mit Bezeichner wird z.B. ein R, C, L, IC eingegeben

Nummer Start bis Nummer Ende eingegeben.

Das Zahlenformat kann folgende Eingaben haben:

  • " " (Leertaste) für einen Abstand zwischen Bezeichner und Nummer
  • "'#" Platzhalter einer Zahl
  • "0" Platzhalter einer Ziffer, somit können voran eilende Nullen definiert werden.

In der "Demo" ist ersichtlich wie das Symbol aussehen wird.

Mit Erzeugen wird in einer temporären Tabelle die Bauteile erzeugt. Daraus können die Bauteile auch wieder entfernt werden. In der Tabelle kann der Symbol Bezeichner nachträglich geändert werden.

Mit "Hinzufügen" werden die Bauteile den Projektpositionen hinzugefügt und die Liste geleert.

Mit Abbrechen wird der Dialog geschlossen, dabei bleiben die temporär erstellten Symbole erhalten. Wenn die Exe geschlossen wird, so geht diese Liste verloren.


Projekt - Import Target CSV/STK

Projekte Verwalten - Import CAD CSV / STK

Mit dieser Funktion können Stücklisten eines CAD Programms importiert werden. Gestartet wird diese Funktion unter "Projekt" > "Positionen" > [image] > "Import CAD CSV".

.Es öffnet sich ein Dialog mit der die Datei ausgewählt wird. Mit OK beginnt der Import.

Beispiel der Target-Datei:

; Stückliste=Test.T3001
; Datum=17.September.2010 16:16
; Variante=
; Author=
;
Pos;Name;Wert;Gehäuse;PosX;PosY;Wo;Rotation;
1;C1;100n;1206;54,770;39,926;oben;270,000°;
2;C2;10uF;ELKO1;8,891;19,051;oben;180,000°;

Die Zeilen mit einem ";" (Semikolon) am Anfang oder Leerzeilen werden ignoriert. Als Spalten-Trennzeichen kann entweder ein TAB-Zeichen (#9) oder ein Semikolon (";") oder ein Komma (",") verwendet werden. Auch wenn die einzelnen Elemente in Anführungszeichen " stehen wird dies erkannt. Somit sollte diese Funktion mit nahezu jedem CAD Programmen funktionieren.

Anschließend erfolgt eine Zeile mit der Spaltenbezeichnung. Dabei müssen nicht alle Spalten vorhanden sein, auch die Reihenfolge ist unwichtig. Wichtig ist nur dass es diese Zeile gibt ansonsten kann EleLa keine Zuordnung machen.

Die Tabellen-Spalten werden in folgende Projekt-Pos Spalten importiert:

Name in CSV-Datei | Name in EleLa | Beschreibung
Pos | Kennz | Fortlaufende Nummerierung
Name oder Symbol oder Part oder Ref | Symbol | Ohne diese Spalte ist ein Import nicht möglich
Wert oder Value | Wert | Bauteilwert
Gehäuse oder Case oder Package oder Footprint | Gehäuse | Gehäuse Bezeichnung
PosX | Pos X | Position, Zahl wird erkannt und bei Punkt oder Komma abgeschnitten
PosY | Pos Y | Position, Zahl wird erkannt und bei Punkt oder Komma abgeschnitten
Wo | Top | Als Wert muss hier "oben" oder "top" stehen, damit wird das Bauteil als "Top"=Ja gesetzt.
Device und/oder Description | Bemerkung | Beide Bemerkungen werden eingefügt, jede in eine eigene Zeile

Andere Spalten werden ignoriert.

Der Import wird zu erst in eine Temporäre Tabelle eingelesen, diese wiederum in die Positionen importiert. Während dem Import in die Positionen sucht EleLa ob es z.B. das Symbol "C1" bereits in der Tabelle gibt, wenn ja, dann werden diese Daten in der Tabelle überschrieben, wenn nein, dann wird EleLa eine neue Position anlegen und die oben beschriebenen Felder ausfüllen.

Nach dem Import muss/kann in den Spalten "Bauteil" und "Lager/Gehäuse" die Bauteile ausgewählt werden die EleLa bekannt sind.

Sollte das CAD Programm andere Bezeichnungen der Spalten-Überschrift generieren, so kann dies von Hand in der Textdatei anhand dieser Tabelle angepasst werden, womit anschießend ein Import in EleLa möglich ist.
Diese Funktion erkennt die Spaltennamen für Target, CadSoft und KiCAD.

Export aus Eagle

Um mit Eagle die Stückliste in dem passenden Format für den EleLa Import zu erhalten kann die ULP Datei "EleLa.ulp" in Eagle eingebunden werden. Hier klicken für den Download. Dabei wird eine Stückliste als CSV Datei erzeugt, die mit dem TAB Zeichen getrennt ist. Sollte in den Texten ein TAB sein so wird dieses Zeichen automatisch zu einem Leerzeichen konvertiert.
Ein Dankeschön an Hr. Dierkes für dieses kleine Tool.


Projekt Historie

Projekte Historie

Hier kann zu einem Projekte eine Historie/Tagebuch/Logbuch/Reparaturen geführt werden. Es können z.B. Stände der Hardware und der Software festgehalten werden. Alles rund um das Projekt passt hier rein.

Datum, von wann der Eintrag kommt.

Version bei der dies festgestellt wurde.

Status:

Farbe | Status
H | Historie
O | offen
A | aktiv
F | fertig
N | nicht bearbeiten
S | später

B/F (Bug/Feature):

Farbe | Status
H | n.v.
B | Bug
F | Feature

Seriennummer / Gerätenummer bei Reparatur.

Datum fertig / Version fertig bei Änderung / Reparatur. Anhand dem ausgewählten Feldern kann gefiltert werden, dabei wird auf ">=" dem Wert gefiltert. (Diese Filterfunktion ist nur unter Extras > Historie nicht verfügbar).

Aufwand in z.B. Stunden (Dezimal). Neben dem Eingabefeld wird die Summe aller Aufwände dieses Projekts gezeigt.

Als Projektbezeichnung wird die Bezeichnung des Projekts übernommen, kann nach belieben geändert werden.

Die eigentliche Bezeichnung betitelt die Änderung und es kann eine Datei angehängt werden.

Als Beschreibung kann ein beliebiger Text eingegeben werden.

In der Tabelle kann ein zusätzliches Adress-Feld eingeblendet werden. Damit können Adressen die unter "Adressen" angelegt wurden ausgewählt werden.

Druck eines Eintrags:

Mit der Rechten Maustaste auf das Drucken-Symbol öffnet ein Popup-Menü. Mit dem kann mit "Drucke aktueller Datensatz" die ausgewählte Zeile als Einzelseite ausgedruckt werden. Für den Ausdruck wird die Vorlagen-Datei "Hist_1.htm" verwendet und die Kodierten Spalten ersetzt und anschließend wird die HTML Datei im EleLa Verzeichnis mit dem Name "Hist_1_<ID>.htm" abgespeichert. Die ID ist der Wert der Spalte ID der Datenbank und somit eine eindeutige Zahl. Anhand der Vorlage-Datei kann jeder selbst das Aussehen bestimmen/anpassen.
Folgende Kodierung wird erkannt und ersetzt:

Kodierung | Beschreibung
$TIME$ | aktuelle Uhrzeit
$DATE$ | aktuelles Datum
$NOW$ | aktuelles Datum + Uhrzeit
$IMAGE$ | das Hauptbild
$<SpaltenName>$ | Alle Spalten der Tabelle "Historie" werden hier eingetragen.

Tipp, Druck einer Logbuch Liste bei z.B. Softwareupdate:

Zu erst wird die Zeile "Datum fertig" oder "Version fertig" ab der man die Liste drucken möchte ausgewählt, anschließend wird danach gefiltert. Somit sind alle ältere Log-Einträge versteckt.
Dann wird anhand dem Status nach "fertig" gefiltert, somit stehen nur noch alle fertige mit neuestem Datum in der Tabelle.
Nun werden Spalten, mit Rechts-Klick auf die Titelleiste ein-/ausgeblendet, je nach dem welche Spalten im Ausdruck erscheinen sollen.
Dann können die Spalten mit Drag&Drop verschoben werden.
Möchte man Bilder mit ausdrucken, so muss die Spalte "Foto_ID" mit eingeblendet werden, allerdings wird nur das "Hauptbild" gedruckt.
Nun Drucken mit der [image] - Taste, es wird eine HTML Datei erstellt, die mit einem Internet-Browser gedruckt werden kann. Auch könnte diese Datei mit einem HTML-Editor nachbearbeitet werden. Die Bilder sind in der HTML Datei eingebettet.

Anmerkung:
Wenn das Projekt gelöscht wird, so wird der Historien-Eintrag nicht gelöscht, nur der ID-Verweis auf das Projekt. Unter "Extras" > "Historie" kann er nachträglich gelöscht werden.

Taste | Beschreibung
 | Neue Position
 | Position kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle Mit Rechtsklick kann einzelne Position gedruckt werden
 | Auswahl Datei
 | Öffne Datei
 | Filter anhand Status / B/F / Datum fertig / Version fertig


Projekt prüfe Menge für Produktion

Projekte prüfe Menge für Produktion

Hier kann vor einer Produktion eines Projektes der Lager-Bestand überprüft werden. Dieser Dialog wird aus "Projekt", der Taste neben "Menge Offen" gestartet.

Im Feld "Lager Menge" wird der aktuelle Bestand gezeigt. "Menge Pos" zählt alle in der Projekt Position gefundenen gleichen Bauteile zusammen und bildet eine Summe. "Menge Proj. Offen" zeigt die "Menge Offen" aus "Projekt". "Lager Rest" zeigt den Lagerbestand nach deren Produktion.

Mit der [image] "Warenkorb-Taste" kann der Artikel in die Bestell-Vorschlagliste übernommen werden. Dabei wird gleich der Reiter "Bestellung" geöffnet und in das "Menge" Eingabefeld mit "Menge Pos" * "Menge Proj. Offen" - "Lager Menge" beschrieben. Wenn als Lieferant ein Lieferant mit eingetragener VPE-Menge gefunden wird, so wird diese bei Eintrag in die Bestell-Liste berücksichtigt. Näheres kann unter "Lieferant" gelesen werden.
Der Dialog bleibt offen, so dass gleich mehrere Bauteile in die Bestell-Vorschlagliste aufgenommen werden können.

Die Tabelle wird Farblich anhand der Bestände "Lager Rest" hinterlegt:

Tipp:

In dieser Liste erscheinen nur die Bauteile, die in den Projektpositionen mit einer "Lager/Gehäuse" Variante hinterlegt wurden, denn nur damit lässt sich die Mengen-Verfügbarkeit berechnen. Daher immer in den Projektpositionen das Feld "Bauteil" und "Lager/Gehäuse" mit ausfüllen.

Farbe | Bezeichnung
 | genügend Bestand vorhanden
 | Bestand nach Produktion = 0
 | Bestand nach Produktion negativ, Produktion kann nicht durchgeführt werden, bzw. es können nicht alle Teile bestückt werden
 | Keine Mengen-Angabe unter "Bauteil" > "Lager / Gehäuse" hinterlegt, "Lager Rest" kann nicht berechnet werden.

Die Spalte "Variante" zeigt nur dann den richtigen Wert, wenn unter "Projekt > Positionen" das Bauteil nur ein mal eingetragen ist. Diese Spalte dient nur zur Info.

Wenn unter "Projekt" > "Positionen" ein Filter auf die Variante gesetzt wurde, so wird der auch in diesem Anzeigedialog berücksichtigt.

Doppelklick auf den Tabelleneintrag springt zum "Bauteil" > "Lager / Gehäuse".

Schließen schließt den Dialog.


Bestellung

Bestellung

Hier wird vorgemerkt welche Artikel zu bestellen sind, welche bestellt wurden und welche geliefert und bereits eingelagert sind. Mit der Archivieren-Funktion können Bestellungen archiviert werden, damit sind diese in der Bestellansicht nicht sichtbar.

Um eine Bestell-Position schnell auswählen zu können kann die Bezeichnung im Schnellsuchen-Feld neben dem Datum eingegeben werden. Dabei springt der Datensatz in den Tabelleneintrag. Zusätzlich können die Datensätze mit der [image] -Taste gefiltert werden, dabei kann auch das Wildcard-Zeichen "*" für beliebigen Text eingegeben werden um die Ansicht ein zu grenzen.

Die Bestell-Vorschlagliste kann entweder von "Hand" gefüllt werden, indem die "Neu" Taste gedrückt wird oder aus "Bauteile" heraus mit der "Warenkorb-Taste" oder der Funktion "Bauteile mit Min-Mengen Unterschreitung". Wichtig ist, dass auch Bauteile aufgeschrieben werden können die gar nicht als "Bauteil" angelegt sind.

Im Eingabefeld "Bauteil" kann das angelegte Bauteil ausgewählt werden. Erst wenn dies ausgewählt wurde, kann das dazugehörige "Lager/Gehäuse" und "Lieferant/Lager/Gehäuse" ausgewählt werden, sofern die dem Bauteil hinterlegt worden sind. Mit der "..." Taste kann ein Dialog zur Bauteilauswahl geöffnet werden, damit wird das Bauteil, Lager/Gehäuse ausgewählt und wenn möglich die Lieferanten gesetzt.

Wenn "Lieferant/Lager/Gehäuse" ausgewählt wird, so wird bei "Lieferant 1" automatisch der Eintrag aus dem Bauteil übernommen. Sollte "Lieferant 1" bereits belegt sein, so wird dies in "Lieferant 2" eingetragen, sofern dieser nicht auch belegt ist.

Als "Projekt" kann ein Projekt ausgewählt werden, um die Bestellung für ein Projekt zuzuordnen.

Mit "Lieferant 1 / 2" hat man die Möglichkeit zwei Lieferanten vor zu sehen, denn man weiß ja nie bei wem man zu erst bestellen möchte. Hier könnte man auch die Preise vergleichen.
Mit der "Y" Taste kann ein Filter auf eine Adresse gesetzt werden. Wenn der Filter aktiv ist, so werden nur Positionen gezeigt, bei denen die Adresse bei Lieferant 1 oder 2 hinterlegt ist. Somit ist es einfacher bei einem Lieferanten zu bestellen.
Mit der GoTo-Taste neben dem Warenkorb-Symbol kann zu der Lieferanten-Homepage gesprungen werden. Wenn unter "Adresse" in der Internetseite der Text "<BESTELLNR>" mit eingetragen ist, so wird dieser Text mit der Bestell-Nr ersetzt und man hat die Möglichkeit dass direkt der Artikel des Lieferanten aufgerufen wird. Beispiele sind unter "Adresse" hinterlegt.

Unter "Bauteile" > "Lieferanten" besteht die Möglichkeit eine Preisstaffel zu hinterlegen. Eine Preisstaffel kann nur berechnet werden wenn "Bauteil" sowie "Lager/Gehäuse" eingetragen sind. Bei jedem abspeichern vom Datensatz wird anhand der gewünschten Menge die Preisstaffel heraus gesucht und in den Feldern eingetragen:

  • Lieferant/Lager/Gehäuse
  • Für Lieferant 1 anhand der Adresse der E-Preis sowie die Bestell-Nummer
  • Für Lieferant 2 anhand der Adresse der E-Preis sowie die Bestell-Nummer

Sollte für die Staffel ein anderer Preis gelten, so muss der Preis in der Staffel geändert werden, denn bei jedem Speichern wird der Staffelpreis automatisch aus "Bauteile" > "Lieferanten" gelesen.

In der "Summe" sieht man die Summe aller Positionen mit dem Status "offen" und "bestellt". Dabei wird die Summe aller billigst eingetragenen Lieferanten gezeigt.

Status der Bestellung

Taste | Beschreibung
O | "offen", noch nicht bestellt
B | "bestellt", Bestellung an Lieferant übergeben
G | "geliefert", bestellte Ware angekommen
E | "eingelagert", Waren in "Kiste" einsortiert
S | "später" bestellen, bearbeiten

Neben den Status-Tasten ist die "Y" Taste. Anhand dieser kann die Tabelle gefiltert werden. Wenn diese gedrückt wird, so sind nur noch die Positionen sichtbar, die den gleichen Status haben wie die ausgewählte Position. Rechtsklick auf die "Y"-Taste öffnet ein Popup-Menü mit dem man den Status für die Filterung auswählen kann.
Immer wenn der Status geändert wird, dann wird auch das Feld "Status Datum" mit dem heutigen Datum beschrieben. Das Feld ist auch von Hand änderbar.

Bauteile mit Min-Mengen Unterschreitung:
Diese Bauteile können über einen Dialog eingefügt werden, siehe hier.

Exportieren einer Bestellung:
Für den Lieferant "Reichelt" kann die Bestellung exportiert werden und wenn man als Reichelt "MyKunde" registriert ist, kann dieser importiert werden. So auch umgekehrt. Reichelt tauscht nur die Bestell-Nummer und die Menge aus, kein Preis oder andere Infos.
Beim Import eines exportierten Reichelt-Warenkorbes kann global der Status aller erkannten Positionen geändert werden. Anhand dieser Funktion kann z.B. nach Bestellung bei Reichelt alles mit einem Rück-Import auf Status "bestellt" gesetzt und nach der Anlieferung auf Status "geliefert" gesetzt werden. Beim setzen auf Status "eingelagert" wird nur der Status geändert, jedoch keine Lagerbuchung vollzogen. Wenn der Artikel in der Bestell-Liste nicht vorhanden ist, so wird der Import den anlegen und die Daten anhand der Bestell-Nummer aus "Bauteile" nachtragen, sofern die Bestell-Nr gefunden wird.

Mit der Bestell-Nr Export Funktion kann ein Lieferant ausgewählt werden und in einem Textfeld werden alle Bestellnummern sowie Mengen der offenen Positionen eingetragen.

Als Trennzeichen kann ein Komma, Semikolon oder TAB-Zeichen ausgewählt werden. Anschließend kann man den Text markieren und mit Strg+C in die Zwischenablage kopieren. Bei Farnell kann diese Liste als "Stückliste", bei TME.eu als "Quickbuy" einkopiert werden. Somit können mehrere Positionen bei Lieferanten komfortabel bestellt werden, die eine CSV-Schnittstelle bieten.

Vorsicht: Sollte Lieferant 1 und 2 genutzt werden, muss jeder selbst aufpassen dass Bauteile nicht doppelt bestellt werden!

Gelieferte Ware ins Lager buchen:
Mit der Taste "In Lager Buchen" kann eine Position, die als "geliefert" markiert wurde in das Lager gebucht werden. Die Taste wird nur dann aktiv, wenn auch ein "Lager/Gehäuse" ausgewählt wurde und die Menge > 0 ist.
Die Aktion: Das Bauteil wird unter "Lager/Gehäuse" von der Menge hochgezählt, die Bestellposition erhält den Status "eingelagert". Wenn das Feld "Lieferant/Lager/Gehäuse" ebenfalls ausgewählt ist und einer der Lieferanten 1/2 ein gültiger Lieferant hinterlegt ist und der EPreis eingetragen ist, dann wird auch der EPreis in die Bauteildaten übernommen.
Wenn das Feld "Lieferant/Lager/Gehäuse" ausgewählt und diesem Eintrag eine VPE-Menge hinterlegt ist, so wird die bestelle Menge * VPE-Menge" dem Lagerbestand hinzugefügt.

Archivieren-Funktion:

Mit archivieren können ältere bestellte Positionen archiviert werden, damit sie für ein späteres nachschauen erhalten bleiben.
Um eine Position zu archivieren kann entweder das Häkchen "Archivieren" gesetzt werden oder über das Menü der "Export/Import" Taste die Funktion "Sichtbare archivieren" ausgeführt werden.
Bei wenn das Häkchen bei "Archivieren" einzeln gesetzt wird, dann wird diese eine Position nach Speichern vom Datensatz ausgeblendet.
Bei Funktion "Sichtbare archivieren" werden bei allen momentan sichtbare Positionen das Häkchen "Archivieren" gesetzt, dabei werden die aktive Filter berücksichtigt.
Um die Ansicht auf archivierte Positionen um zu schalten muss der Menüpunkt "Export/Import" "Archiv Ansicht" aktiviert werden. Bei dieser Ansicht werden alle archivierten Positionen gezeigt. Darin sind auch alle Filter-Funktionen aktiv. In den archivierten Positionen können keine Änderungen vorgenommen werden, nur das Häkchen "Archivieren" kann entfernt werden. Dabei wird der Datensatz nicht ausgeblendet. Sobald man im Menü "Export/Import" "Archiv Ansicht" wieder zurück zur Normalansicht wechselt, sind die aus dem Archiv zurückgeholten Einträge wieder änderbar.
Somit kann immer nachvollzogen werden welche Bauteile wo bestellt wurden oder man kann sich Bauteile die ständig bestellt werden in den Hintergund schalten.

Tipp, ansicht Bestellhistorie eines Bauteils:

Unter "Bauteil - F2 >> Bestellungen" können alle Bestellungen eines Bauteils, auch der Archivierten gefunden werden.

Taste Beschreibung

Neue Position
Position kopieren
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle

Export / Import-Funktion

  • Bauteile mit Min-Mengen Unterschreitung
  • Reichelt Warenkorb Export/Import
  • Bestell-Nr Export Funktion

Filtern von Positionen anhand aktuellem Status
Rechtsklick öffnet ein Popup-Menü, in dem man einen anderen Status auswählen kann nach dem gefiltert werden soll.

Filter auf Lieferant-Adresse, wirkt für Lieferant 1 und 2 gleich.
  • Öffne "Bauteil" und Anzeige
  • Öffne "Lager/Gehäuse" von Bauteil und Anzeige
  • Öffne "Lieferant/Lager/Gehäuse" von Bauteil und Anzeige
  • Öffne "Adresse" vom Lieferant 1/2 und Anzeige
  • Öffne Internet-Seite des Lieferanten
Auswahl Bauteil mit Dialog

Das Feld Status in der Tabelle kann nur in der Eingabemaske/Tasten geändert werden. Die grau hinterlegten Felder in der Tabelle sind nicht editierbar.


Bestellung Min-Mengen Unterschreitung

Bestellung von Min-Mengen Unterschreitung bei Bauteilen

Dieser Dialog kann unter "Bestellung", Klick auf Import/Export Taste, Menü "Bauteile mit Min-Menge unterschritten" geöffnet werden.

Es werden alle Bauteile/Gehäusevarianten aufgelistet, deren Min-Menge >= Menge ist.

Mit der [image] -Taste wird das Bauteil in die "Bestellung" Liste übernommen, dabei wird das Mengen-Feld nicht beschrieben.

Der Dialog wird erst mit der "Schließen" -Taste geschlossen.

Status der Bestellung

Taste | Beschreibung
n. Best. | Bauteil ist nicht in der Bestell-Vorschlagliste
offen | Bauteil ist bereits in der Bestell-Vorschlagliste mit Status "offen"
bestellt | Bauteil ist bereits in der Bestell-Vorschlagliste mit Status "bestellt"
geliefert | Bauteil ist bereits in der Bestell-Vorschlagliste mit Status "geliefert"

Einträge mit dem Kennzeichen "eingelagert" werden nicht gezeigt. Wenn ein Bauteil bereits in der "Bestellung" Liste mehrfach existiert und unterschiedlichen Status hat, so werden diese auch in dieser Tabelle angezeigt.

Die Min-Menge und Menge eines Bauteils werden unter "Bauteil" > "Lager/Gehäuse" eingegeben.


Suchen

Suchen

Mit suchen können Bauteile, Historien- und Wissenseinträge gefunden werden.

Im Suchen Eingabefeld kann "*" als Wildcard-Zeichen verwendet werden. Die Groß/Kleinschreibung spielt ebenfalls keine Rolle.

Gesucht wird bei Bauteile in den Feldern

  • Bauteil.Bezeichnung,
  • BauteilLager.Bezeichnung,
  • BauteilLager.SMD_Text,
  • BauteilLager.LagerNr,
  • BauteilAdr.BestellNr.

Somit kann z.B. eine Bestellnummer eines Lieferanten eingegeben werden und das Bauteil wird angezeigt.
Das Feld EPreis wird aus dem Lieferanten-Eintrag genommen. Sollte kein Lieferant eingetragen sein, so wird der EPreis aus dem Lager/Gehäuse Bereich verwendet. GPreis errechnet sich aus Menge * EPreis.
Rechts oben wird die Summe von allen gezeigten GPreis Felder gezeigt.

In der Historie und Wissen wird in den Feldern Bezeichnung und Beschreibung gesucht.

Wenn als Suchtext "**" eingegeben wird, so werden alle Bauteile angezeigt.

Die angezeigte Liste kann ausgedruckt werden mit der [image] - Taste.

Doppelklick auf die Tabelle springt zum "Bauteil" (oder "Historie" / "Wissen").

In der Statusleiste wird nach der Suche gezeigt wie lange es gedauert hat um die Daten zu suchen.

Tastaturfunktionen

Taste | Beschreibung
F5 | Auswahl Reiter "Suche F5", setze Eingabefokus auf das Suchen-Feld und markiere den gesamten Text, außer das erste Zeichen wenn es ein "*" ist
Pfeiltaste Up oder F11 | Voriger Datensatz auswählen
Pfeiltaste Down oder F12 | Nächster Datensatz auswählen
Enter-Taste | Gehe zum Bauteil / Historien-Eintrag / Wissens-Eintrag
Strg + F | Setze Eingabefokus auf das Suchen-Feld und markiere den gesamten Text

Hier der SQL-Code der Suche "in Bauteile":

SELECT b.ID, l.ID AS LID, b.tree_typ_ID, b.Bezeichnung AS Bezeichnung,
  l.Bezeichnung AS LBez, g.Bezeichnung AS CBez, l.SMD, l.SMD_Text,
  k.Bezeichnung AS KBez, l.LagerNr, l.Menge, l.Haltbar, l.Barcode,
  adr.Bezeichnung AS AdrBez, a.BestellNr,
  a.EPreis, (a.EPreis * l.Menge) AS GPreis,
  l.EPreis AS LEPreis, (l.EPreis * l.Menge) AS LGPreis
FROM bauteil b
LEFT JOIN bauteillager l ON (b.ID = l.Bauteil_ID)
LEFT JOIN bauteiladr a ON (l.ID = a.BauteilLager_ID)
LEFT JOIN `case` g ON (g.ID = l.Case_ID)
LEFT JOIN kiste k ON (k.ID = l.Kiste_ID)
LEFT JOIN adr ON (adr.ID = a.Adr_ID)
WHERE b.Bezeichnung LIKE '%'
OR l.Bezeichnung LIKE '%'
OR l.SMD_Text LIKE '%'
OR l.LagerNr LIKE '%'
OR l.Barcode LIKE '%'
OR a.BestellNr LIKE '%'
ORDER BY Bezeichnung

Mit rechtsklick im Eingabefeld kann der aktive SQL-Befehl in die Zwischenablage kopiert werden.

Wenn Sie eine anderen Such-Algorithmus wollen, so können Sie diesen Code unter "Extra" > "Datenbank" eingeben und abändern. Mit dem LIKE Befehl wird die Suche anhand dem nachfolgenden String eingegrenzt.


Gehäuse verwalten

Gehäuse verwalten

Hier werden alle Gehäuse Typen der Bauteile angelegt. Zu jedem Gehäuse kann auch ein Bild hinterlegt werden.

Um ein Gehäuse schnell auswählen zu können kann die Bezeichnung im Schnellsuchen-Feld neben dem Datum eingegeben werden. Dabei springt der Datensatz in den Tabelleneintrag.

Mit der Eingabe "Typ" kann das Gehäuse einer Kategorie zugeordnet werden.
Beispiel: "IC/DIP"
Dabei wird mit slash "/" automatisch ein Untertyp generiert. Das Auswahlfeld beinhaltet alle bisher angelegten Typen. Mit der "Y" Taste kann die Ansicht gefiltert werden. Rechtsklick auf die "Y" Taste öffnet ein Auswahldialog um anhand einem Typ zu filtern.
Die Typ-Filterung ist hilfreich wenn unter "Bauteile" > "Gehäuse/Lager" nach einem Gehäuse mit Hilfe der Taste "..." gesucht wird, da hier auch anhand dem Typ gefiltert werden kann.

Im Eingabefeld unterhalb von "Pins" kann ein Beschreibungstext eingegeben werden.

Ein Bild kann mit Hilfe der Taste "Bild" eingefügt, kopiert oder gelöscht werden. Es ist insbesondere darauf zu achten, dass es mit einem Zeichenprogramm verkleinert, bzw. optimiert wird. Es wird in der Datenbank in PNG Format abgelegt und sollte auf der Festplatte nicht mehr als 32KB haben. Nur so ist sichergestellt, dass es nicht zu großen Verzögerungen beim Laden von Bildern aus der Datenbank kommt.
Wenn das Bild in der Vorschau nicht ganz dargestellt werden kann, da das Mini-Fenster zu klein ist, so kann mit Doppelklick ein Vorschau-Fenster geöffnet werden.

Wenn der Datensatz kopiert wird, so wird das Bild nicht mit kopiert.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils entfernt, jedoch nicht der Datensatz gelöscht. So auch bei der Bestell-Liste.

Taste | Beschreibung
 | Neue Position
 | Position kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Filter anhand Typ, rechtsklick für Auswahldialog


Kiste

Kiste

Hier werden die Lagerorte "Kisten" verwaltet.

Um eine Kiste schnell auswählen zu können kann die Bezeichnung im Schnellsuchen-Feld neben dem Datum eingegeben werden. Dabei springt der Datensatz in den Tabelleneintrag.

Hier werden nur die Kisten, Schubladen, Regale usw. eingetragen. Nicht jedoch z.B. "Sortierkasten 1, Box A/4", die "Box A/4" wird unter "Bauteile" > "Lager/Gehäuse" in "Lager-Nr" eingetragen, denn sonst müsste man für jeden Sortierkasten 60 Einträge, für jede Schublade machen. Lesen Sie über Etikettendruck, bevor Sie die Kiste festlegen, denn damit lassen sich Etikette für Schubladen aus einem Sortierkasten generieren.

Zuordnen von Bauteile in Fächer einer "Kiste", z.B. eines Sortierkastens in die Schubladen kann mit dem Dialog Bauteile in Kiste/Fach verwalten gemacht werden. Damit können auch alle Bauteile eines Faches innerhalb eines Sortierkastens verschoben werden.

Die Felder "Nummer", "Pos X" und "Pos Y" sind Eingabefelder für Zahlen.

Eine Kiste kann nur dann gelöscht werden, wenn diese unter "Bauteil" > "Lager/Gehäuse" nicht mehr verwendet wird.

Taste | Beschreibung
 | Neue Position
 | Position kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Druck Etickett
 | Bauteile in Kiste/Fach verwalten


Typ

Typ, Kategorie der Bauteile

Hier werden die Kategorien angelegt die ein Bauteil annehmen kann.

Wichtig ist hierbei dass es nicht zu viele Untertypen gibt, denn man kann anhand dieser Typeinordnung ein Bauteil filtern. Daher sollte dies relativ "allgemein" gehalten werden.

Jedem Typ-Eintrag kann ein Bild zugeordnet werden. Dieses Bild wird unter "Bauteil" angezeigt, sofern dem Bauteil kein individuelles Bild eingefügt wurde.

Jeder Eintrag kann in der unteren Eingabezeile einen frei definierbaren Zusatztext haben.

Jeder Eintrag kann eine Formatierung für den Barcode haben. Diese wird berücksichtigt wenn bei einem Bauteil der Barcode erzeugt wird. Details können unter "Lager/Gehäuse" nachgelesen werden.

Einen Typ kann man nur dann löschen, wenn er keine Untereinträge mehr hat und wenn der Typ unter "Bauteil" nicht verwendet wird.

Die Tabelle rechts neben dem Baum dient rein zu Ansicht welche Bauteile dem Typ zugeordnet sind. Ein Doppelklick auf den Eintrag in der Tabelle öffnet "Bauteil", wenn dem ein "Lager/Gehäuse" zugeordnet ist automatisch auch diesen Reiter unter "Bauteil".
Die Ansicht der Tabelle kann anhand dem "Nur gewählter Typ" oder "gewählter samt Untertypen" ausgewählt werden.
Die Ansicht kann nach Gehäuse gefiltert werden indem rechts neben der Tabelle ein Häkchen auf das Gehäuse gesetzt wird. Es können mehrere Gehäuse ausgewählt werden.

Taste | Beschreibung
 | Neuer Eintrag im aktuell ausgewählten Zweig
 | Neuer Kind-Eintrag im ausgewählten Eintrag
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle

Mit Klick auf den Eintrag kann er editiert werden.


Adressen

Adressen

Hier werden die Lieferanten und Hersteller verwaltet.

Um eine Adresse schnell auswählen zu können kann die Bezeichnung im Schnellsuchen-Feld neben dem Datum eingegeben werden. Dabei springt der Datensatz in den Tabelleneintrag. Zusätzlich können die Datensätze mit der [image] -Taste gefiltert werden, dabei kann auch das Wildcard-Zeichen "*" für beliebigen Text eingegeben werden um die Ansicht ein zu grenzen. Es wird in allen Text-Feldern außer Login/Passwort gesucht.

Die Felder sollten selbsterklärend sein. Die Felder "Bank/BLZ/Konto" gibt es nur in der Tabellen-Ansicht.

Unter "Internet" kann die Internetseite eingegeben werden, die mit der Taste ">>" mittels eines Internetbrowsers gezeigt werden kann.
Wenn in dem Link der Text "<BESTELLNR>" mit angegeben ist so wird dieser Text durch die Bestell-Nummer von "Bauteil >> Lieferant" ersetzt und es kann direkt das Bauteil vom Lieferant angezeigt werden. (Der Text <BESTELLNR> muss groß geschrieben werden.)
Beispiele von Links:

Lieferant | Internet-Link
Reichelt | www.reichelt.de/<BESTELLNR>/search
Digikey | search.digikey.com/scripts/DkSearch/dksus.dll?k=<BESTELLNR>
Farnell | de.farnell.com/<BESTELLNR>
Pollin | www.pollin.de/shop/suchergebnis.html?S_TEXT=<BESTELLNR>
Conrad Privatkunden | www.conrad.de/ce/de/product/<BESTELLNR>
Conrad Geschäftskunden | www.conrad.biz/ce/de/product/<BESTELLNR>
RS Components GmbH | http://de.rs-online.com/web/search/searchBrowseAction.html?method=getProduct&R=<BESTELLNR>
TME | www.tme.eu/de/katalog/#idp%3D1%26search%3D<BESTELLNR>
Weitere Beispiele mir bitte mailen, ich nehme sie gerne in die Liste auf.

Die Adresse mit der Bezeichnung "Reichelt" hat eine Sonderstellen, mit ihr können Reichelt Warenkörbe unter "Bestellung" exportiert und importiert werden.
Bei einer Adresse mit dem Wort "Conrad" wird als <BESTELLNR> nur die erste Zahl ohne Leerzeichen und Bindestrich übergeben, denn sonst geht das nicht.

Wenn ein Eintrag gelöscht wird, so wird auch der Verweis des Bauteils entfernt, jedoch nicht der Datensatz gelöscht. So auch bei der Bestell-Liste.

Mit der Telefon-Taste kann die nebenstehende Telefonnummer gewählt werden. Mit Rechtsklick auf das Telefonsymbol öffnet sich ein Popup-Menü mit dem man die Telefoneinstellungen parametrieren kann.

Es kann eine Telefonliste ausgedruckt werden von allen Adressen mit hinterlegter Telefon oder Mobilnummer. Dazu muss auf der Druck-Taste mit der rechten Maustaste das Popup-Menü geöffnet werden.

Im Feld Geburtstag kann ein Datum eingetragen werden. Neben dem Eingabefeld kann mit der "..."-Taste ein Datum mit Hilfe eines Dialoges ausgewählt werden. Sollte das Datum in den Bereich zwischen letztem Start und Morgen fallen, so erscheint bei Programmstart ein Hinweis auf den fälligen Termin.
In der Tabelle wird bei Geburtstag das Feld farblich hinterlegt:

Farbe Datumsfeld
Geburtstag war gestern
Geburtstag ist heute
Geburtstag ist morgen

Taste | Beschreibung
 | Neue Position
 | Position kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle, Rechtsklick für Ausdruck Telefonliste.
 | Telefonnummer wählen (benötigt analoges Modem sowie eine analoges Telefon, siehe Telefoneinstellungen)
 | Internetseite öffnen
 | Auswahl Geburtsdatum mittels Datums-Dialog


Telefoneinstellungen

Telefoneinstellungen

Hier kann das Modem für das Wählen einer Telefonnummer parametriert werden. Dieser Dialog öffnet sich, wenn mit der rechten Maustaste auf das Telefonsymbol von "Adressen" geklickt wird.

Einstellung:

In Com Port mit Modem muss der COM serielle Port eingestellt werden. Unter Windows muss hier z.B. COM1 unter Linux tty01 eingetragen werden.

Mit der AT Init Sequenz kann ein Modem Befehl abgesetzt werden, der vor dem Wählen das Modem initialisiert.

Mit Wählpräfix kann der Verbindungsaufbau über eine Nebenstelle parametriert werden. Wenn man keine Nebenstellenanlage hat, so bleib das Feld leer, ansonsten kann hier 0W für 0 = Amt holen und W = Warten auf Freizeichen.

Kleine Übersicht der Modem-Befehle für die Init-Sequenz:

Befehl | Beschreibung
AT | Einleitung eines Modem-Befehls. Muss immer zu beginn eines Befehls stehen
Q0 | Modem Rückmeldung, Antworten geben
V1 | Modem Rückmeldung, Antworten im Klartext
L0..3 | Lautstärke fast ganz stumm ... Lautstärke laut
M2 | Lautsprecher ist immer eingeschaltet
X0 | Nicht auf Wählton warten und nicht auf Besetzt-Zeichen reagieren
X2 | Auf ein Freizeichen warten und nicht auf Besetzt-Zeichen reagieren
X3 | Nicht auf Frei-Zeichen warten und auf Besetzt-Zeichen reagieren

Ein Modem hat noch viel mehr Befehle, auch kann sein dass der ein oder andere nicht unterstützt wird. Näheres findet man im Handbuch des entsprechenden Modems und im Internet.
Beispiel eines Befehlsaufbaus:

ATQ0V1L3M2X3

Es können mit einem AT Befehl mehrere Parameter gleichzeitig gesetzt werden.

Damit EleLa überhaupt ein Modem erkennt muss es auf ein Befehl "AT" + CR eine Klartextantwort zurückgeben, entweder "OK" oder "ERROR". Wenn das nicht vom Modem als Antwort gesendet wird, so wird EleLa die Fehlermeldung "Error: no modem found at port xxx" ausgeben und in das "Log" schreiben.

Die Init-Sequenz wird ohne Fehlerabfrage zum Modem verschickt.

Anschließend wird sofort gewählt mit dem Befehle:

ATDT <Wähl Prefix> <Telefon-Nummer>

Wobei aus der <Telefon-Nummer> alle ungültige Zeichen entfernt werden, wenn zu beginn ein + steht wird dies zu 00 ersetzt.
Gültige Zeichen sind: 0..9, P, T, R, W, ,, !, /

Anschluss von Telefon und Modem

Das Telefon und das Modem haben jeweils die Drähte La und Lb als Signalleitung. Beide Geräte sind gleichzeitig parallel angeschlossen. Mit einem Y-Adapter können diese zusammengeschlossen werden.

In diesem Beispiel wurde zwei Telefondosen verwendet, die parallel angeschlossen sind.

Viele Laptops haben ein Modem eingebaut, damit entfällt das externe Gerät.

Funktionsweise Telefonieren

Um mit EleLa wählen zu können muss folgendermaßen vorgegangen werden:

  1. Abheben Telefonhörer
  2. Wählen der Nummer indem die Telefon-Taste in EleLa gedrückt wird
  3. sobald die Nummer gewählt wurde erneut die Telefon-Taste betätigen, damit legt das Modem auf und die serielle Schnittstelle wird geschlossen. Ansonsten kann es sein, dass man mit dem Telefon nicht telefonieren kann weil das Modem die Leitung noch belegt.
  4. Nun kann ganz normal telefoniert werden
Symbol | Beschreibung
 | Modem hat aufgelegt, mit Klick auf die Taste wird das Modem abheben und die Nummer wählen
 | Modem hat abgehoben, mit Klick auf die Taste wird das Modem auflegen. Wenn der Wählvorgang in dem Moment aktiv ist, so kann dieser abgebrochen werden.

Tipp

Wo sehe ich welchen Port mein eingebautes Modem nutzt (Windows)?

Systemsteuerung > Verwaltung > Computerverwaltung
Links im Baum: Geräte-Manager
Rechts im Baum: Modems > Modem auswählen, Doppelklick
Im Eigenschaftsdialog in der Seite "Modem" steht der Anschluss: "COMx"

Diese Vorgehensweise kann bei neueren Windows-Systemen abweichen.


Extras

Extras

Hier sind Zusatzfunktionen verfügbar, die mit der eigentlichen Lager-Haltung nichts zu tun haben.

  • Rechner / Timer
  • Historie - über alle Projekte
  • Wissen, hier können allgemeine Erfahrungen und Tipps aufgeschrieben werden
  • Logbuch von Programm-Meldungen/Fehlern
  • Datenbank, der direkte Zugang zur Datenbank
  • Info/Übersetzung


Rechner

Rechner

Hier ist ein Timer mit Up/Downcount integriert.

Wird die Start-Zeit >0 eingegeben, so läuft der Timer automatisch im Downcount-Modus muss Zeit 0 und dann Piept die EXE für jede Sekunde bis zum Stop.
Wenn die Start-Zeit =0 eingegeben wird, dann läuft der Timer im Upcount-Modus, ohne zeitliche Begrenzung.

Die Eingabe kann verschiedene Modi haben:

Format | Dauer
Zahl, ohne ":" z.B. 1234 (Sekunden) | 1234 Sekunden
Zahl mit einem Trennzeichen ":" z.B. 3:33 (Minute:Sekunde) | 213 Sekunden
Zahl mit zwei Trennzeichen ":" z.B. 5:6:7 (Stunde:Minute:Sekunde) | 18367 Sekunden

Als Trennzeichen wird erkannt: : ; , . -
Andere Zeichen als Zahlen werden einfach ignoriert.
Selbst eine Eingabe z.B. "3x00;30" wird als 300 Minuten und 30 Sekunden erkannt.

Taste | Funktion
 | Start Timer, Übernahme der eingegebenen Zahl als Start-Wert
 | Pause Timer
 | Stop Timer

Der Timer lässt sich auch mit den Media-Tasten steuern, sofern die Tastatur Multimediatasten hat. Damit kann der Timer gesteuert werden, wenn auch nicht die Ansicht "Extras", "Rechner" zu sehen ist.

Taste | Funktion
Play/Pause | Play / Pause des Timers, ist der Timer im Downcount-Modus und abgelaufen, so kann auch mit dieser Taste gestoppt werden.
Stop | Stop Timer

Währungsrechner:

Unter Kurs kann z.B. der aktuelle Dollar-Kurs eingegeben werden. Unter Betrag dann der Betrag als z.B. EUR oder Dollar. Angezeigt wird der Betrag Multipliziert und Dividiert durch den Kurs.

Ohm-Zeichen:

Das Ohm-Zeichen dient nur als Zeichen, das man in die Zwischenablage kopieren kann, ohne weitere Funktion.

SMD Zahlencode:

Bei vielen Bauteilen ist als Wertangabe ein Zahlencode aufgedruckt, entweder 3 oder 4 Ziffern. Wenn diese Ziffern in das Eingabefeld eingegeben werden, so wird der Wert in Ohm und Farad angezeigt.

Zusätzlich kennt die EXE über 4000 SMD-Codes von Halbleitern die z.B. bei einem SOT23-Bauteil aufgedruckt sind. Wird nun ein Code in der Liste eingegeben so erscheint in der Tabelle die möglichen Chips.
Aber Vorsicht: Es sind nicht alle Zahlencodes aller Hersteller verfügbar, Funktion ohne Gewähr. Microchip beispielsweise hat gar keine Übersichtstabelle der eigenen Zahlencodes, somit kann man diese auch nicht rein nehmen.
Dafür werden auch alle SMD-Texte gefunden und mit angezeigt, die unter "Bauteil" > "Lager/Gehäuse" neben dem Häkchen SMD eingegeben wurden. Damit kann man die Tabelle erweitern mit den Chips die man selbst auf Lager hat.

Von der Internetseite http://www.elektronik-kompendium.de wurde diese sehr Umfangreiche Liste zur Verfügung gestellt. Vielen Dank an deren Admin! Weitere Links mit Formelsammlungen gibt es hier.

Eigene Zahlencode-Liste:
Wenn jemand eine eigene SMD Zahlencode-Liste hat, so kann er diese in EleLa einbinden. Dazu muss nur eine Datei "smdcodes.csv" in das gleiche Verzeichnis von EleLa.exe kopiert werden. Struktur:

"stempel";"typ";"hersteller";"base";"gehaeuse";"beschreibung"
"1B";"BC846B";"Phi";"N";"SOT23";"BC546B"

Wobei die erste Zeile die Spalten-Namen enthält, alle weiteren Zeilen die Daten. Somit ist die mitgelieferte Liste außer Funktion.

Zusatzfunktionen:

Mit der Taste "Taschenrechner" öffnet ein kleiner Taschenrechner.

Mit der Taste "Kalender" öffnet ein Kalender mit Monatsansicht.

Mit der Taste "Spannungsteiler" öffnet Dialog zur Berechnung eines Spannungsteiler:

Hier wird Ugesamt und Ufb eingegeben. Anhand dieser Werte wird der Widerstandswert R1 errechnet anhand der E12 Tabelle, eingesetzt für R1. Viele Spannungsregler haben einen FB Spannungseingang, daher diese Spannungsteiler Berechnung.
In diesem Beispiel wäre als R2 3,3KOhm und als R1 10KOhm ideal.

Mit der Taste "LM317 / LM350" öffnet der Dialog zur Berechnung der Widerstände für diesen Chip.

Hier kann die Zahl VOut, R1 und R2 eingegeben werden. Es wird jeweils immer gerechnet.

Mit der Taste "U R I P" öffnet der Dialog zur Berechnung von U R I P.

Von den 4 Eingabefeldern können beliebige zwei ausgefüllt werden, dann errechnet EleLa alle Werte.


Projekt Historie

Extra Historie

Hier kann zu allen Projekten eine Historie/Tagebuch/Logbuch/Reparaturen geführt werden, dabei muss keine Verbindung zu einem "Projekt" bestehen. Es können z.B. Stände der Hardware und der Software festgehalten werden.

Unter "Suchen" kann ein Historien-Eintrag gefunden werden.

Auswahl des "Projektes", muss nicht ausgefüllt werden. Es kann somit ein Historien.Eintrag aus einem Projekt entfernt oder einem anderen Projekt zugeordnet werden.

Datum, von wann der Eintrag kommt. Wenn als Datum ein Termin in der Zukunft eingegeben wird, so wird EleLa eine Hinweis-Box öffnen und auf den fälligen Termin hinweisen sobald das Datum erreicht wurde.

Version der Änderung.

In der Tabelle kann ein zusätzliches Adress-Feld eingeblendet werden. Damit können Adressen die unter "Adressen" angelegt wurden ausgewählt werden.

Status:

Farbe | Status
H | Historie
O | offen
A | aktiv
F | fertig
N | nicht bearbeiten
S | später

B/F (Bug/Feature):

Farbe | Status
H | n.v.
B | Bug
F | Feature

Seriennummer / Gerätenummer bei Reparatur.

Datum fertig / Version fertig bei Änderung / Raperatur.

Aufwand in z.B. Stunden (Dezimal).

Als Projektbezeichnung wird die Bezeichnung des Projekts übernommen, kann nach belieben geändert werden.

Die eigentliche Bezeichnung betitelt die Änderung und es kann eine Datei angehängt werden.

Als Beschreibung kann ein beliebiger Text eingegeben werden

Druck eines Eintrags:

Mit der Rechten Maustaste auf das Drucken-Symbol öffnet ein Popup-Menü. Mit dem kann mit "Drucke aktueller Datensatz" die ausgewählte Zeile als Einzelseite ausgedruckt werden. Für den Ausdruck wird die Vorlagen-Datei "Hist_1.htm" verwendet und die Kodierten Spalten ersetzt und anschließend wird die HTML Datei im EleLa Verzeichnis mit dem Name "Hist_1_<ID>.htm" abgespeichert. Die ID ist der Wert der Spalte ID der Datenbank und somit eine eindeutige Zahl. Anhand der Vorlage-Datei kann jeder selbst das Aussehen bestimmen/anpassen.
Folgende Kodierung wird erkannt und ersetzt:

Kodierung | Beschreibung
$TIME$ | aktuelle Uhrzeit
$DATE$ | aktuelles Datum
$NOW$ | aktuelles Datum + Uhrzeit
$IMAGE$ | das Hauptbild
$<SpaltenName>$ | Alle Spalten der Tabelle "Historie" werden hier eingetragen.

Druck einer Logbuch Liste bei z.B. Softwareupdate:

Diese Funktion steht nur unter "Projekt" > "Historie" zur verfügbar.

Taste Beschreibung

Neue Position
Position kopieren
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle
Mit Rechtsklick kann einzelne Position gedruckt werden
  • Öffnet das "Projekt"
  • Öffnet die Handbuch-Datei
Auswahl Handbuch-Datei
Filter anhand Status
Filter anhand B/F (Bug/Feature)


Wissen

Wissen

Hier können Infos und Tipps abgelegt werden.

Unter "Suchen" kann ein Wissens-Eintrag gefunden werden.

Ein Wissen hat eine Bezeichnung mit der das Thema beschrieben wird.

Mit Thema wird ein Such-Wort definiert, um was es geht. Damit alle verwandten Themen den gleichen Wortlaut haben können alle eingegebenen Themen in der Box ausgewählt werden.
In diesem Beispiel ist das Thema "EleLa" mit dem Unterthema "Install". Mit dem "/" Zeichen können Themen gruppiert werden.

Mit der "Y" Taste neben dem Thema kann nach Thema gefiltert werden. Mit der rechten Maustaste öffnet sich ein Dialog für die Filterung, dabei wird ein Baum anhand "Thema" und "Unterthema" aufgebaut:

Zusätzlich lässt sich hier ein Verzeichnis und ein Bild anhängen,.

Im Beschreibungstext wird das Wissen dann beschrieben.

Taste | Beschreibung
 | Neue Position
 | Position kopieren
 | Speichere Änderung
 | Abbruch ohne speichern
 | Löschen Eintrag
 | Druck als Tabelle
 | Filtern nach Thema, rechtsklick für Auswahldialog
 | Auswahl Handbuch Datei
 | Öffne Handbuch-Datei


Extras - Log

Extras - Logbuch

Hier werden alle Ereignisse und Programmfehler geloggt. Diese Ansicht enthält somit die Informationen um Fehlern auf die schliche zu kommen. Sollte bei Programmstart von EleLa die Verbindung zur Datenbank nicht hergestellt werden können, so wird auch diese Seite gezeigt mit entsprechenden Fehlermeldungen.

Unter dem Reiter "Log" können einzelne Zeilen oder das ganze Protokoll mit der rechten Maustaste kopiert werden. Das Programm kann automatisch den Log in eine Datei schreiben, wenn der Parameter der INI-Datei [Programm] LogInFile=1 gesetzt wird.

Mit der Taste "Leeren" wird die Liste geleert.

Mit dem Häkchen "Pause" kann der Log angehalten werden, wobei die zwischenzeitlich aufgelaufenen Meldungen verloren gehen, außer sie werden die die Datei geloggt.

Mit der Taste "Optionen" kann der EleLa Konfigurationsdialog geöffnet werden. Dabei können nahezu alle Parameter die in der INI-Datei abgelegt sind editiert werden. Mehr dazu unter "Installation".


Extras

Extras - Datenbank

Unter dem Reiter "Datenbank" kann direkt ein SQL-Befehl eingegeben werden. Damit ist es möglich alle Daten anzuzeigen und zu editieren oder löschen.

Die Datenbank öffnet bei SELECT eine Tabelle, bei anderen Befehlen wird der SQL-Befehl ausgeführt, z.B. UPDATE zeigt keine Tabelle. Mit der Taste "Execute" kann ein SQL Befehl ausgeführt werden. Alle SQL-Befehle werden unter "Log" in das Logbuch geschrieben, woraus man sie wieder kopieren kann (Historie).
Die Daten in der Tabelle können sogar manipuliert werden. Wenn Felder mit einem "ID" im Feldname geändert werden kann die Konsistenz der Daten nicht gewährleistet werden.
Das Häkchen "MultiInsert" ist nur sichtbar bei Benutzung der SQLite Datenbank. Hier werden MySQL Tabellen-Inserts, die als Mehrzeilige Inserts ausgeführt sind automatisch einzeln nacheinander ausgeführt, denn dies unterstützt SQLite nicht.

Bei einer SELECT Anfrage werden die Felder je nach Feldname formatiert um die Lesbarkeit zu erhöhen:

Feldname | Datentyp | Formatierung
EPreis, GPreis, Aufwand, Raster. ValFloat | Real | Zahl als 0.00##
Gewicht | Real | Zahl als 0.###
Tree_Typ_ID | Integer | Anzeige des Typ-Baumes wie bei "Bauteil"
SMD, Top | Integer | Anzeige Ja / Nein
* | * | Begrenzung der Display-Width auf 25 Zeichen

Sobald eine Tabelle mit SELECT geöffnet wurde kann sie gedruckt oder mit der Export-Funktion exportiert werden.

Mit der Taste "Alles Öffnen" können alle Tabellen der anderen Reiter aktualisiert werden. Alternativ kann auch das Programm geschlossen und wieder geöffnet werden. Dies ist nötig wenn Daten über diese "Datenbank"-Funktion direkt manipuliert werden.

Taste | Beschreibung
Speichere Änderung
Abbruch ohne speichern
Löschen Eintrag
Druck als Tabelle
  • Export der sichtbaren Tabelle als CSV oder XML Datei
  • Export / Import der gesamten Datenbank
Strg + e | führt Taste "Execute" aus

Demo-SQL Scripte

Abfrage der Lagerliste mit allen eingelagerten Bauteile, Gehäuseart sowie Einzel- und Gesamtpreis und Lieferanten sowie der Summe der Gesamtpreise:

SELECT b.ID, b.tree_typ_ID, b.Bezeichnung AS Bezeichnung,
l.Bezeichnung AS LBez, g.Bezeichnung AS CBez, l.SMD,
k.Bezeichnung AS KBez, l.LagerNr, l.Menge, adr.Bezeichnung AS AdrBez,
a.BestellNr, a.EPreis, (a.EPreis * l.Menge) AS GPreis
FROM bauteil b
LEFT JOIN bauteillager l ON (b.ID = l.Bauteil_ID)
LEFT JOIN bauteiladr a ON (l.ID = a.BauteilLager_ID)
LEFT JOIN `case` g ON (g.ID = l.Case_ID)
LEFT JOIN kiste k ON (k.ID = l.Kiste_ID)
LEFT JOIN adr ON (adr.ID = a.Adr_ID)
UNION
SELECT '-1', COUNT(b.ID), ' _SUMME_', '', '', '', '', '', SUM(Menge), '', '', '', SUM(a.EPreis * l.Menge)
FROM bauteil b
LEFT JOIN bauteillager l ON (b.ID = l.Bauteil_ID)
LEFT JOIN bauteiladr a ON (l.ID = a.BauteilLager_ID)
LEFT JOIN `case` g ON (g.ID = l.Case_ID)
LEFT JOIN kiste k ON (k.ID = l.Kiste_ID)
LEFT JOIN adr d ON (d.ID = a.Adr_ID)
ORDER BY Bezeichnung

Anzeige wie viele Bauteile bereits angelegt wurden:

SELECT COUNT(ID) FROM bauteil

Komprimieren der Datenbank (nur SQLite):
Vor einem Komprimieren sollte unbedingt die Datenbankdatei *.SQ3 gesichert werden. Ein Komprimieren baut die Datenbank neu auf und entfernt dabei alle gelöschten Datensätze. Es muss sichergestellt sein, dass kein zweites Programm die Datenbank während dem Komprimieren benutzt.

VACUUM


Export/Import Datenbank

Export/Import Datenbank

Mit dieser Funktion kann die aktive Datenbank in eine SQLite Datenbank gesichert werden oder aus einer SQLite Datenbank importiert werden. Diese Funktion wird unter "Extras" > "Datenbank" > "Export-Taste" > "Menü: Exportiere/Importiere Datenbank" aufgerufen, sofern das Programm mit einer MySQL Datenbank verbunden ist.

Zu erst muss eine Datei ausgewählt werden.

Anschließen alle Tabellen, die man Importieren/Exportieren möchte. In der Regel sind das alle Tabellen, denn diese verweisen untereinander mit ID-Spalten. Das Importieren/Exportieren einzelner Tabellen wird nicht empfohlen.

Die Taste "Export" exportiert die gesamten Tabellen der Datenbank in die Datei die ausgewählt wurde. Wenn die Datei noch nicht existiert wird sie angelegt und die Tabellen erzeugt. Bevor die Tabellen in der Datei gespeichert werden, wird die Tabelle der Datei geleert.

Die Taste "Import" importiert die gesamten Tabellen der Datenbank aus der Datei die ausgewählt wurde. Dabei werden zu erst alle Tabellen der Datenbank geleert, anschließend werden die Daten aus der Datei importiert.

Über den Fortschrittsbalken wird der Fortschritt angezeigt.

Ein Export/Import sollte niemals unterbrochen werden, da die Daten ansonsten korrupt sind. Auch sollte während dem Import kein anderer die Datenbank benutzen.

Tipp:

Diese Funktion wird benötigt, wenn Sie von SQLite auf MySQL umbauen wollen, da MySQL Netzwerkfähig und schneller ist. Sichern Sie sich in jedem Fall VORHER die aktuelle "EleLa.sq3" Datenbankdatei, bevor Sie importieren/Exportieren, bzw. machen Sie ein Backup der Datenbank.

Das Vorgehen bei Umstieg von SQLite auf MySQL (PostgreSQL ist identisch):

  • Installation MySQL so wie in der Install-Anleitung beschrieben
  • Einrichtung der INI-Datei für die MySQL Datenbank-Verbindung
  • Öffnen dieses Programm mit der MySQL Datenbank
  • Diesen Import-Dialog öffnen
  • Die bestehende SQLite Datenbankdatei "EleLa.sq3" auswählen
  • Importieren
  • Nun sind die Daten der alten SQLite übernommen in MySQL

Das Vorgehen bei Umzug der Datenbank auf einen anderen MySQL-Server (PostgreSQL ist identisch):
(Alternativ kann auch die Import/Export-Funktion mit phpMyAdmin (nur MySQL) verwendet werden.)

  • Öffnen dieses Programms, dieses Menüs
  • Auswahl einer Datei z.B. "D:\Export.sq3"
  • Taste "Export", damit wird die Datei neu erstellt mit Daten gefüllt
  • Installation MySQL auf dem neuen Server so wie in der Install-Anleitung beschrieben
  • Einrichtung der INI Datei mit der Verbindung zum neuen Server
  • Öffnen dieses Programm mit der neuen MySQL Datenbank
  • Diesen Import-Dialog öffnen
  • Die zuvor exportierte SQLite Datenbankdatei "D:\Export.sq3" auswählen
  • Importieren
  • Nun sind die Daten auf dem neuen MySQL-Server verfügbar

Mit dieser Funktion kann auch problemlos von z.B. MySQL auf PostgreSQL oder SQLite gewechselt werden. Der Export macht automatisch eine SQLite-Datenbank als Sicherung die direkt weiter verwendet werden kann.

Tipp:

Um in alten Daten zu suchen, z.B. weil ein Datensatz unbeabsichtigt gelöscht wurde, so kann ein zweites EleLa installiert werden und in der INI-Datei die Konfiguration für SQLite Datenbank aktiviert werden. Somit kann mit dieser EleLa Kopie die alte gesicherten Daten angeschaut werden.


Extra Info/Übersetzung

Extra Info/Übersetzung

Hier werden Infos des Autors gezeigt und es kann die Sprach-Datei gespeichert und geladen werden. Somit kann jeder das Programm in eine andere Sprache übersetzen.

Taste "Speichern Texte" erstellt eine Datei "Lang_Save.txt" im Ordner "TempDir" mit allen Texten im Programmverzeichnis. Diese Datei kann mit einem UTF8 fähigen Texteditor editiert werden. Notepad ab WinXP reicht dafür in der Regel aus.

Um die Änderungen der Datei an zu schauen kann mit der Taste "Lade Texte" die Datei geöffnet werden, dann werden sofort die neuen Texte sichtbar.

Folgende Regel ist zu beachten:

  • Zeilenumbruch wird mit \r\n gekennzeichnet (z.B. Dialogboxen. Bei Statusbar oder Tabelle geht das nicht, denn die haben nur eine Zeile)
  • Zeilenumbrüche sind nur in Dialog-Texten und in Formularen erlaubt.
  • UTF8 Codiert, somit sind alle Unicode Zeichen nutzbar
  • Einige Texte sind doppelt in der Datei, was daran liegt dass die Komponenten automatisch erkannt und gelesen werden, unabhängig von deren Funktion.
  • Die Formulartexte neben einem Eingabefeld sind verbunden mit dem Eingabefeld. In dem Bezeichner des Eingabefeldes sollte ein "&" Zeichen vor einem Buchstabe stehen, damit wird das Feld aktiviert bei Druck der ALT-Taste + und diesem ausgewählten Zeichen. Sind mehrere Zeichen definiert, dann sollten alle mit einem anderen Buchstaben verbunden sein, denn sonst ist nur ein Feld mit der ALT-Taste anwählbar.

Übersetzen wird von EleLa unterstützt

Mit der Taste "Übersetzung" kann ein Dialog geöffnet werden der bei der Übersetzung hilft.

Dieser Dialog zeigt zu Anfang eine leere Tabelle. Wenn zuvor die Texte mit der Taste "Speichern Texte" in die Datei "Lang_Save.txt" kann der Text mit der Taste Import/Export [image] in diese Tabelle importiert werden. Während dem Laden kann festgelegt werden in welche Spalte der Text eingelesen werden soll. Mit Exportieren kann eine übersetzte Spalte wieder als Text-Datei gespeichert werden.

Diese Übersetzungs-Tabelle wird in der Datenbank mit gespeichert, somit kann jederzeit der Text übersetzt werden, so wie man gerade Zeit hat.

Diese "Translate"-Tabelle dient nur zur Übersetzungs-Hilfe. Um die Texte im Programm an zu schauen muss die Sprache exportiert und mit der Taste "Lade Texte" aus dem Hauptprogramm ("Extras" >> "Info") geladen werden.

Im Schnellsuchen-Feld kann zu dem Datensatz gesprungen werden, der als Sortierspalte ausgewählt wurde. Wenn die "Y" Taste für Filter gedrückt wurde, so werden nur die Datensätze gezeigt, die mit der Sortierspalte übereinstimmen, dabei kann auch ein * als Wildcard verwendet werden.

In der Tabelle sind Felder für die Sprachen DE, DE_Waren, EN, ES, FR, IT, NL, PL, RU vorbereitet, diese können für beliebige Sprachen genutzt werden.

Übersetzung in EleLa dauerhaft hinterlegen

In der INI-Datei kann die Übersetzungs-Datei eingegeben werden. Dazu muss die INI Konfigurationsdatei geöffnet und folgende Parameter werden hier hinterlegt:

[Programm]
LanguageFile=Lang_xxxx.txt
LanguageFileLCL=lclstrconsts.xx.po

Wobei die zweite Datei von Lazarus kommt und die Texte für die Standard-Messageboxen enthält.

Bevor Sie übersetzen, schreiben Sie MmVisual ein Mail um die Übersetzung zu koordinieren. Jeder Übersetzer darf sich in der Übersetzungsdatei unter dem Text "frmMain.lbDInfoTranslatedBy=" verewigen. (Text z.B. "Translated by Max Mustermann V0.0.10903")


Inhalt

Homepage EleLa: http://www.MmVisual.de >> EleLa

Forum mit Fragen und Antworten rund um EleLa: http://www.mikrocontroller.net/topic/223348

Artikel in dem ebenfalls EleLa bezogen werden kann: http://www.mikrocontroller.net/articles/Elektronik_Lagerverwaltung

Links *

Links zu externen Seiten mit nützlichen Infos und Funktionen:

  • SMD-Code Tabelle von ElKo für die kleinen Halbleiter
  • Transistor-Vergleichstypen / Vergleichstabelle von ElKo
  • TTL-Schaltkreisfamilie von ElKo
  • Formelsammlung, Onlinerechner auf Calculatoredge
  • Programm Spannungsteiler
  • Formelsammlung, Programm MiscEl
  • Widerstands Farbcodetabelle
  • LED Vorwiderstandsberechner

Publikationen / Weiterempfehlungen *

  • www.jtronics.de
  • http://schnittpunkt2012.blogspot.com/2010/11/weitere-tipps-zur-krisenvorsorge.html
  • http://www.schauungen.de/forum2/forum_entry.php?id=439
  • Elektor Ausgabe 2011/02
* Ich möchte ausdrücklich betonen, dass ich keinerlei Einfluss auf die Gestaltung und die Inhalte der gelinkten Seiten habe. Deshalb distanziere ich mich hiermit ausdrücklich von allen Inhalten aller gelinkten Seiten dieser Hilfedatei und mache ihre Inhalte nicht zu Eigen. Diese Erklärung gilt für alle in dieser Hilfedatei angebrachten Links und für alle Inhalte der Seiten, zu denen die bei mir angemeldeten Links führen.