mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik hct165 zu langsam?


Autor: Lutz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe ein kleines Problem. Ich benutze das Schieberegister hct165 um 
weitere Eingänge für den Controller (mega8 bei 16mhz) zu erhalten. Die 
Zustände werden dann über den UART an den PC übertragen. Nun bekomme ich 
aber ab und zu (wirklich zufällig) nur Nullen zurück gegeben auch wenn 
an den Pins des Registers Signale anliegen. In 90% stimmt das Ergebnis 
aber ab und zu ist es halt 0. Kann es sein das das Register nach dem 
hochziehen des PL etwas mehr zeit braucht um den zustand zu übernehmen? 
Ich benutze nicht die spi Lösung falls das interessant ist.

Habt ihr ne Idee?

Lg, Lutz

Autor: B e r n d W. (smiley46)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist Du sicher, dass das Problem vom Schieberegister kommt? Könntest Du 
eine LED blinken lassen, falls der ATmega Null liest?

Könnte es auch an der Schnittstelle / Windows API liegen? Das hatte ich 
schon mal.

Autor: Lutz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernd, danke für deinen Tipp. Das Problem lag an meiner 
provisorischen Testumgebung. Hatte ein Kabel mit Kontaktproblemen 
**peinlich** Dank dir trotzdem für die schnelle Antwort!
lg,
Lutz

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.