www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LPC2148 - SPI0 Problem


Autor: Marc (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein ARM-Board von Keil (MCB2140) mit dem LPC 2148. Ich will 
Daten über den SPI-Anschluß senden bzw, empfangen. Dazu benutze ich das 
SPI0-Interface.

Mein Initialisierungscode sieht wie folgt aus:

    S0SPCR = 0x00;
    PINSEL0 |= (1<<14) | (1<<12) | (1<<10) | (1<<8);
    S0SPCCR = 8;
    S0SPCR = 0x20;

SSEL0 wird auf 3.3V gezogen.

Wenn ich nur Daten in das Register S0SPDR schreibe und mit dem 
Oszilloskop die Ausgänge messe, bleibt SCLK tod.

Weiß jemand woran das liegen könnte???


Gruß Marc

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.