mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ARM AT91 Timer Problem


Autor: need_help (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi! Ich hab hier ein Board mit nem AT91RM9200 und brauche 3 Timer um 
Pulsabfolgen zu generieren. Dabei haben alle die gleiche Periode. Nun 
möchte ich die Timer synchron zueinander starten. Im Datenblatt steht, 
dass dazu im BCR-Register SYNC mit 1 beschrieben werden muss. Soweit 
funktioniert das auch, zumindest starten die Timer. Das Problem ist, nur 
zwei davon starten synchron, der dritte startet versetzt. Dabei ist der 
Versatz immer unterschiedlich. Wie kann ich das beeinflussen?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.