mikrocontroller.net

Forum: Platinen Eagle - Thermal Pads + VIAs + Pastenmaske


Autor: Nobody (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich mache gerade mit Eagle mein erstes Layout und steh schon vor den 
ersten Problemen, die ich mit anderen Tools nicht hatte.
Aber ich nehme an es gibt eine Lösung.

1.) Ich habe ein QFN44 Gehäuse und möchte in das Exposed Pad auf der 
Unterseite VIAs setzen um es mit GND zu verbinden. Beim DRC Check wird 
jedoch ein Clearance Fehler ausgegeben. Wenn Gerber Files produziert 
werden, dann passt wahrscheinlich alles, da ein Pad ja auch nichts 
anderes ist wie Kupfer und folglich wie ein Leitung + VIA behandelt 
wird. Nichts desto trotz ist es unschön, wenn Eagle einen Fehler 
ausgibt, obwohl es gewollt ist und vor allem Thermal-Vias state of the 
art sind.

2.) Die Kühlfläche des QFN44 ist relativ groß, würde man über die ganze 
Fläche Lötpaste auftragen, dann kann es zu Schwierigkeiten beim Verlöten 
kommen. Kann man in Eagle die Pastenmaske selbst verändern, so dass sie 
beispielsweise nur die halbe Padfläche bedeckt?

3.) Ich habe einige TSSOP Gehäuse auf meinem Print. Die Clearance habe 
ich überall auf 8 mil gestellt. Der Abstand zwischen den einzelnen Pads 
des TSSOP ist 9.5mil. Bei einem DRC Check wird trotzdem ein Clearance 
Fehler ausgegeben. Woran kann das liegen?


Vielen Dank!!

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Nobody (Gast)

>wird. Nichts desto trotz ist es unschön, wenn Eagle einen Fehler
>ausgibt, obwohl es gewollt ist und vor allem Thermal-Vias state of the
>art sind.

Kann man bei Eagle leider AFAIK nicht sauber lösen. Es sei denn, man 
legt das Pad im Layout (nicht Bibliothek) als Polygon an.

>kommen. Kann man in Eagle die Pastenmaske selbst verändern, so dass sie
>beispielsweise nur die halbe Padfläche bedeckt?

Ja. In der Bibliothek mit CHANGE/CREAM OFF. Dann manuell im Layer tcream 
die Lotpastenbereiche zeichnen.

>des TSSOP ist 9.5mil. Bei einem DRC Check wird trotzdem ein Clearance
>Fehler ausgegeben. Woran kann das liegen?

Ist AFAIK ein Bug im Eagle.

MFG
Falk

Autor: Gast XIV (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Billigen
2. In Library verändern
3. Fehler erstmal bei sich suchen

Autor: Nobody (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Falk, ich werd das einfach einmal so hinnehmen.

Das mit der Pastenmaske hat tadellos funktioniert.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.