mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART Scratch-Register korrupt


Autor: Wastl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich benutze das Scratch-Register eines SC16C2550 (Doppel-UART, ähnlich 
dem 8250) um zu testen, ob die Anbindung an meinen ARM9-Prozessor 
korrekt ist. Erstaunlicherweise gibt es zwei Bytefolgen, bei denen das 
Scratch-Register anscheinend eigenständig seinen Wert ändert.

Schreibt man erst ein 0xDE und anschließend ein 0xB1 oder ein 0xB2 dann 
ändert sich der Wert des Scratch-Registers auf 0.

Vielleicht kann das ja hier jemand bestätigen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.