mikrocontroller.net

Forum: FPGA, VHDL & Co. ISE 11.5 unisim library BUFGMUX


Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi, meine letzten FPGA spielerein sind ein paar Tage her, deshalb hab 
ich mein ISE auf Version 11.5 geupdated. Seit dem Update bekomme ich den 
Fehler, das er die Libaray unisim_vcomp nicht kennt. Weglassen kann ich 
die Lib auch nicht, weil in dem Design ein BUFGMUX ist.

Wie komme ich weiter?

Autor: Dirk (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Anscheinend ist das Problem nicht ISE, sondern Modelsim. Wieso bekomme 
ich die Library nicht geladen ?

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die Library mal neu kompiliert? Vielleicht hat sich da was 
geändert.

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, in der Vergangenheit hab ich nur ISE 9.2i und Modelsim PE 
(Student) installiert und konnte ohne Probleme alles simulieren.

Bei der Synthese meckert er nicht und läuft ohne Probleme durch.

Hat jemand weitere Tipps und eine gute Anleitung zur Library 
kompilieren?

Autor: Klaus Falser (kfalser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soviel ich weiss, ist die Library normalerweise im ModelSim 
Programm-Verzeichnis unter Xilinx/vhdl/unisim.

Du kannst :
- die Library von Hand zum Projekt geben :
Im Fenster mit den Libraries rechts klicken -> New... -> Library -> 
Create a Map to an existing Library.
Name ist unisim
- Die MPF Datei im Projektverzeichnis editieren

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du den Simulator richtig in den Preferences von ISE eingetragen 
hast, kannst du das Design in der Projektansicht da markieren und unten 
beim Design Flow hast du dann den Punkt "Compile all simulation 
libraries" und dann erstellt der mit deiner Modelsim Version die Libs 
neu. Probelm ist nämlich, dass die vorkompilierten Libs nur mit der 
Modelsim Version funktionieren, mit der sie erstellt wurden.

Autor: Johan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Xilinx schreib das nur Leute die mit dem Virtex 6 und Spartan 6 arbeiten 
ein Update auf 11.5 vornehemen sollten, alle anderen ziehen keinen 
Nutzen aus dem Update.

Also nicht gleich alle auf Version 11.5 updaten :-)

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für die Hilfe. Ich versuche heute abend eure Ratschläge 
umzusetzen.

>Also nicht gleich alle auf Version 11.5 updaten :-)

Das Design ist momentan auf ein Spartan 3AN ausgelegt, aber ich möchte 
es in naher Zukunft auf einen Spartan 6 portieren, deshalb hab ich einen 
Update von Version 9.2i auf 11.5 gewagt.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, Update schadet aber auch nicht. Hier geht noch alles.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.