mikrocontroller.net

Forum: FPGA, VHDL & Co. UART / ASCII codierung


Autor: Squanto (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

Ich bin ein absoluter noob und probiere mit dem AVR Butterfly Zeichen
via Uart an das Hyperterminal zu senden. Leider erscheinen im
Hyperterminal die falschen Zeichen.. =( Weiss jemand wie ich das
richtig biegen kann? Als Noob vermute ich, das das Problem an den
Datentypen liegt, aber so ganz nachvollziehen kann ich es nicht...

Vielen Dank für eure Hilfe

Squanto

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scheinst die compiler warnings/errors zu ignorieren, oder ? Probiers mal
hiermit :

USART_Transmit('T');
USART_Transmit('H');
USART_Transmit('\r');

Dein code versucht einen String (= Zeiger auf char array) an eine
Funktion zu uebergeben, die nur einen einzelnen char erwartet. Piff.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.