mikrocontroller.net

Forum: FPGA, VHDL & Co. CJNE kann nicht benutzt werden.


Autor: rub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich bin gerade dabei meinen Einstieg in die Programmierung von 
Controllern zu tätigen und komme mit den einfachsten Sachen nicht klar.

Also ich habe mir das AVR-Studio gezogen und will eine Ampelschaltung, 
für einen ATMega32 schreiben.
Leider habe ich keine Ahnung wie ich eine IF-Abfrage realisieren soll.
Dabei bin ich über den Befehl CJNE gestolpert, jedoch kennt das Studio 
diesen nicht. Auch IF wird nicht erkannt.
Was muss ich denn dafür includieren, damit ich anständig arbeiten kann ?

Autor: rub (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs gelöst, das geht ja mit den CP (compare)-Befehlen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.