mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Wie Analog-Komparator mit AVR (4433)?


Autor: marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich versuche (mit BASCOM AVR) eine Komparator-Funktion zu
programmieren. Die "Hilfe" ist nicht sehr gut. Wer kann damit was
anfangen??

Syntax
CONFIG  ACI = ON|OFF, COMPARE = ON|OF

Habe diverse Sachen ausprobiert, bekomme jedoch Fehlermeldungen im
Compiler...

Wie muss ich eine funktionierende Compare-Funktion programmieren (was
ist in welcher Reihenfolge zu tun?)?

-AT90S4433
-eine feste analoge Spannung an einem Eingang
-mit einer Entladekurve eines Kondensators vergleichen
-die Zeit messen (Zähler)
-und bei Spannungsgleichheit Zähler auswerten

Danke für Hilfe!

Marco

Autor: Fabian Braun (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo marco,

mal so ne banale frage: hast du den abschnitt über den analogkomparator
im datenblatt überhaupt mal angeschaut?!??
http://www.atmel.com/dyn/resources/prod_documents/...
Seite 62 & 63!!!
zuerst musst du natürlich mal die bits im ACSR register richtig sezten.
kommt jetzt halt drauf an ob du während der uC auf das
auswerten des signals wartet noch was anderes tun muss oder nicht, ob
du diese sache mit interuppts oder ohne machst!
falls du es ohne interrupts machst, schreibst du einfach 0x00 (ist zwar
schon initial value aber doppelt gehnät hält besser ;-)) ins ACSR
register und wartest bis das ACO bit im ACSR register 0 oder eben halt
1 ist...

hat das geholfen?!?

gruss fabian

Autor: christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch's mal so :

Disable Interrupts
Disable Aci
Config Aci=On, Compare=Off, Trigger=Falling
Start Ac
Enable Aci
Enable Interrupts
On Aci Irgendeinesprungmarke

main:
Hauptprogramm
goto main


Irgendeinesprungmarke:
...



Bei mir funktioniert es so.

Autor: marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der compiler von BASCOM AVR bringt bei der Befehlszeile:

Config Aci=On, Compare=Off, Trigger=Falling

Fehlermeldungen...
...unknown CONFIG parameter [4]
...unknown CONFIG parameter [compare]
...unknown CONFIG parameter [trigger]

So steht der Befehl aber auch in der HILFE.

Weiss jemand Rat?

Marco

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.