mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit der PWM


Autor: Jörg Nitsche (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich hab ein Problem mit der Puls Weiten Modultion, und zwar bekomm ich
es einfach nicht hin, dass eine LED auf meinem Testboard, mit halber
Helligkeit leuchtet.
Hab schon diverse Sachen aus dem Internet ausprobiert, aber
funktioniert hat bis jetz noch nichts.
Schwer kanns ja nicht sein, der Timer1 hat ja eine "PWM Betriebsart",
oder sehe ich das falsch?
Der Mikrocontroller ist ein AT90S2313 und programmieren tu ich unter
Bascom.
Das Ziel wird es sein, dass ich über einen BUZ11 eine Halogenlampen
dimmen kann.
Wär nett wenn ihr mir aus die Sprüunge helfen könntet,
Mfg

Jörg Nitsche

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

in der Hilfe zu Bascom steht nicht das man den OC Pin als Output
definieren muss.


Mfg

Dirk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.