mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AT89S8252 Programmierung


Autor: Benjamin Deiss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich arbeite zur Zeit an einem immer größer werdenden Programm (ca. 4kB)
und nun habe ich das Problem das ich das Programm nicht mehr korrekt in
den Flash Mem bekomme. Umso umfangreicher es wurde, umso öfter musste
ich den Flashvorgang wiederholen. Ich verwende das Flashtool AtmelISP
Vers. 20030210 und habe es auch schon mit einem für die Parallele
Schnittstelle versucht aber hatte ebenfalls keinen Erfolg. Ein
verkürztes Kabel habe ich auch schon versucht, leider ohne Erfolg. Kann
mir jemand helfen? Ich habe sonst nichts gefunden im Internet.

Gruß Benjamin

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuchs mal unter Windows98.


Peter

Autor: Benjamin Deiss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter Win98 verhält es sich genau gleich. Ich habe noch bemerkt das ich
mit der vorigen AtmelISP Version höhere Chancen habe auf ein
erfolgreiches flashen. Ich wäre auch dankbar für ein Tipp über ein
sicheres, bewährtes Flashtool

Benjamin

Autor: buz11 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Glaube nicht , das ATMELISP Probleme macht .
Ich benutze die gleiche Version .

Vielleicht liegts am ACPI oder sonstigem PC-Harware-Setup .

Flashst Du in der Schaltung oder solo ?

Autor: Benjamin Deiss (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Problem wird immer komischer. Es tritt jetzt zusätzlich noch auf
das er nach ein paar Flash versuchen meint "No device found on serial
port". Wenn ich dann "Chip Erase" wähle kann ich danach wieder
zugreifen.

Ich flashe in der Schaltung, aber das hat bisher auch funktioniert.

Ich habe 3 versch. Rechner getestet, sowohl mit Win XP und Win98, ich
habe 3 Prozessoren getestet und bekommen kein Programm mehr geflasht.
Es gab keine Hardware-Änderung und auch die Flash-Software ist die
gleiche, ich habe keine Ahnung mehr was ich versuchen soll.

Dumm daran ist das es sich um meine Technikerarbeit handelt die
demnächst fertig sein muss.

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hältst Du davon:

http://www.specs.de/users/danni/tools/isp53/index.htm


Hat mich noch nie im Stich gelassen.
Aber ich benutze immer noch Windows98 (never change a running system).


Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.