mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega8 ADC-Problem


Autor: L. Kostrykin (Firma: evoid.de) (thevoid)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich versuche den AD-Wandler zu testen. Hier mein Test-Programm (es soll 
die Werte vom AD-Wandler lesen und per RS-232 versenden):
http://nopaste.com/p/aGbIiCYY6

Allerdings kommen nur Nullen an. Was mache ich falsch? Ich denke, dass 
die Verdrahtung stimmt. Ich verwende ein MyAVR-2-Board und habe den Poti 
mit Port C Pin 0 verbunden.

Danke im Voraus!

Autor: Dussel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beim kurzen durchlesen sind mir zwei Dinge aufgefallen. Beim ADC 
schreibst du erstens ins Register ADCSR, es gibt aber meines Wissens nur 
ADCSRA, da müsste der Assembler meckern und im ADMUX setzt du eine 
externe Referenz. Für Versuche würde ich eher die interne bevorzugen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.