mikrocontroller.net

Forum: FPGA, VHDL & Co. Uart-hello programm läuft nicht-Hilfe


Autor: Birefsane (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich will mit einem Altera DE2 Board Cyclone II Prozessor (EP2C35) eine 
RS232 Schnittstelle realisieren. Für die Ansteuerung eines Roboterarms.

Habe mir das Programm Uart-Hello.zip Programm von hier runtergeladen und 
wollte es ausprobieren. compilieren funktionier bringt keine 
Fehlermeldung. Nur kann ich es danach nicht auf das Board laden ?? Was 
für Anschlüsse brauche ich den bei dem Altera Board ??

Könnte mir evtl. jemand das Programm näher erläutern ich verstehe nur 
Bahnhof ???

Danke

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Birefsane (Gast)

>Dateianhang: DE2.doc (272,5 KB, 3 Downloads)

Bildformate!!!. .doc ist sinnlos bis gefährlich (Makroviren)

>Fehlermeldung. Nur kann ich es danach nicht auf das Board laden ?? Was
>für Anschlüsse brauche ich den bei dem Altera Board ??

Einen JTAG Anschluss nebst Programmierkabel.

>Könnte mir evtl. jemand das Programm näher erläutern ich verstehe nur
>Bahnhof ???

Welches Programm?

Fang mal klein an und lass ne LED blinken. Dann sehen wir weiter.

MfG
Falk

Autor: Birefsane (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohh sorry wuste ich nicht.

Nun ja ich kann ja das Programm garnicht auf das IC brennen also kann 
ich auch kein LED brennen lassen :(

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Birefsane (Gast)

>Nun ja ich kann ja das Programm garnicht auf das IC brennen also kann

Nennen wir es konfigurieren. Und wenn du nciht weisst wie das geht, 
musst du halt mal das schlaue Handbuch fragen.

>ich auch kein LED brennen lassen :(

Wenn sie brennt, ist was schief gelaufen ;-)

MFG
Falk

Autor: Birefsane (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Error: Can't access JTAG chain
Error: Operation failed

bekomme diese Fehlermeldung !! Hab den JTAG schon angeschlossen

Autor: Birefsane (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe den USB Blaster angeschlossen brauche ich den diesen Bit Blaster 
damit ich das Program konfigurieren (siehst Du ich bin lernfähig :))) ) 
kann ??

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stromversorgung?

Autor: Birefsane (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
klar ist der dran

Autor: Birefsane (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab es hinbekommen.

Danke nochmals Falk Brunner :)

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und woran lag's?

Autor: Birefsane (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber nicht lachen :) bin halt ne Frau :) und lerne neu VHDL

Ich hatte das Board nur an 5V angeschlossen und nicht an 9V !!!!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.