mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 7-Segm. problem


Autor: Andreas S. (andi1301)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich habe ein kleines Problem mit einer 4x7 segm. anzeige. Ich 
habe das ganze mit 4 schieberegistern vom typ 74hc595 angesteuert, was 
auch tadeloß läuft. Aber die dritte stelle ist etwas dunkler als die 
anderen 3. Es betrifft auch die gesammte Anzeige, und nicht nur ein 
segmennt. Worann könnte das liegen ?

Danke !!!

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltung? Ansteuerung? Programmcode? Oszibild der gem. Anoden?

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Strohbehn wrote:
> anderen 3. Es betrifft auch die gesammte Anzeige, und nicht nur ein
> segmennt. Worann könnte das liegen ?

- Die 3. Anzeige ist ein anderer Typ

- Die Segmente der 3. Anzeige bekommen einen geringeren Strom
  (niedrigere Versorgungsspannung [kalte Lötstelle?], größere
   Vorwiderstände...)

Autor: Andreas S. (andi1301)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Die bedingungen sind für alle 4 Anzeigen die gleichen, die Vorwdst. sind 
alle   1k .

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schickst du die Daten kontinuierlich an die Schieberegister, oder 
schickst du die Daten nur bei Änderung des Inhaltes?

[Edit]

Auf dem Layout lässt sich übrigens nicht viel erkennen.

[/Edit]

Autor: Andreas S. (andi1301)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kontinuierlich, weil sie sich laufend ändern. Es ist ein 
Thermostat/Timer kombi.

Autor: Matthias Lipinsky (lippy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Schaltung? Ansteuerung? Programmcode? Oszibild der gem. Anoden?

Autor: Skua (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andere Charge.

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Strohbehn wrote:
> Kontinuierlich, weil sie sich laufend ändern. Es ist ein

Was passiert, wenn du die Übertragung anhältst? Sind die Segmente dann 
immer noch dunkler?

Autor: Andreas S. (andi1301)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jop, ist nicht anders. Also es sind nicht einzelne segmente einer 
Anzeige dunkler, sondern die ganze Anzeige (eine von vier). Ich kann so 
keinen fehler finden, da sie exakt wie die anderen drei angeschloßen 
ist. Ich tausche sie morgen mal aus..........

Autor: Skua (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnt auch das Schieberegister sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.