mikrocontroller.net

Forum: Compiler & IDEs Servofunktion von AVRLib


Autor: flinkflash (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus,

ich habe Probleme mit den Servofunktionen von Procyon AVRLib.

Mein kleines Progrämmchen:

#include "avr/io.h"
#include "include/servo.h"

int main(void)
{
  servoInit();
  servoSetPosition (0, 60);
  while(1)
  {
  }
}
Compilieren klappt fehlerfrei, make extcoff klappt auch fehlerfrei.
Wenn ich nun mit dem AVRStudio das ganze simuliere, würde ich
eigentlich eine ständige Veränderung am PORTB.0 erwarten (da soll ja
das PWM Signal rauskommen). Leider kann ich dort nichts feststellen.

Kann mir jemand helfen. Hat schon jemand damit mal gearbeitet und
Erfolg gehabt???

Vielen Dank

flinkflash

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.