mikrocontroller.net

Forum: Compiler & IDEs avrlib pwm/timer


Autor: Danilo Reinhardt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich versuche die timer/pwm funktionen der procyon avrlib zu verwenden.
Leider hab ich ein paar mir Unerklärliche Dinge hier. Die PWM
funktioniert im Prinzip, nur die Frequenz stimmt nicht. Nun dachte ich
mir ich probiere mal timerPause aus, diese Funktion benutzt ja den
Atmel Timer0. Bei 8MHz Clock und einer gewollten Pause von 1sec bekomme
ich ca 8Sec raus. Im STK500 bei 3,68 MHz sind es um die 4-5 sec...

Das das PWM dann bei angedachten 100Hz und mehr sichtbar eine LED zu
flimmern bringt ist dann natürlich logisch...

Hatte jemand schonmal das Problem, und evtl nen tipp?

Ciao

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.