mikrocontroller.net

Forum: Compiler & IDEs Problem mit Timer OCxy Ausgangssignal


Autor: Andreas Koczwara (koczwara)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

ich habe ein blödes Problem mit dem Timerausgangssignal OC3A, das beim 
Timer-Compare-Match auf High wechseln soll und dann in der 
On-Compare-Interrupt-Routine abgeschaltet werden soll um beim nächsten 
Timer-Compare-Match wieder auf High zu wechseln (also einen kurzen 
positiven Impuls erzeugen, der die steigende Flanke genau beim Compare 
des Timers hat).
Das Einschalten funktioniert einwandfrei, nur das Abschalten geht nicht 
und ist nirgends beschrieben.
Vielleicht hat ja jemand eine Idee.

Grüße
Andreas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.