mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik RTC-Fehler beim LPC


Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo allerseits!

Hat von Euch jemandeinen Fehler beim LPC
(speziell beim LPC2365) gehabt wie ich?

Folgender Fehler:
Die interne RTC des LPC wird ständig abgefragt, und am LCD angezeigt.
Anzeige mit Tag, Monat, Jahr, Stunde, Minute und Sekunde
Irgendwann am Tag springt der Monatswert auf "0" !?
Ist ist kein Absturz geschehen; es kann auch Tage gut gehen, aber
irgendwann ist der Monatswert weg.

Der Monatswert würde eigentlich ja niemals den Wert 0 annehmen (laut
Datenblatt). Im Programm wird dieser ebenfalls nie auf 0 gesetzt!

Was läuft hier schief ?

Hat jemand was ähnliches bereits gehabt?

Grüße
Markus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.